source: projects/specs/trunk/lib/libi/libimobiledevice/libimobiledevice-vl.spec @ 12445

Revision 12445, 7.4 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

ifuse-1.1.4-1

libgudev-233-1

libimobiledevice-1.3.0-1

libplist-2.2.0-1

libusbmuxd-2.0.2-1

upower-0.99.11-1

usbmuxd-1.1.1-1

Line 
1%bcond_with python
2
3Summary:        Library for connecting to mobile devices
4Summary(ja):    モバイルデバイスに接続するためのライブラリ
5Name:           libimobiledevice
6Version:        1.3.0
7Release:        1%{?_dist_release}
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Packager:       daisuke
11
12License:        LGPLv2+
13URL:            https://libimobiledevice.org/
14Source0:        https://github.com/libimobiledevice/libimobiledevice/releases/download/%{version}/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires:  automake
18BuildRequires:  autoconf
19BuildRequires:  libxml2-devel
20BuildRequires:  libusb1-devel
21BuildRequires:  libtasn1-devel
22BuildRequires:  libplist-devel >= 1.11
23BuildRequires:  glib2-devel
24BuildRequires:  gnutls-devel
25BuildRequires:  swig
26BuildRequires:  libusbmuxd-devel >= 1.0.9
27BuildRequires:  libgcrypt-devel
28#BuildRequires: readline-devel
29
30Provides: libiphone = %{version}
31Obsoletes: libiphone < 0.9.7
32
33%description
34libimobiledevice is a library for connecting to mobile devices including phones
35and music players
36
37%package devel
38Summary: Development package for libimobiledevice
39Summary(ja): libimobiledevice の開発用パッケージ
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Provides: libiphone-devel = %{version}
43Obsoletes: libiphone-devel < 0.9.7
44
45%description devel
46Files for development with libimobiledevice.
47
48
49%if %{with python}
50%package -n python3-imobiledevice
51Summary: Python bindings for libimobiledevice
52Summary(ja): libimobiledevice の Python バインディング
53Group: System Environment/Libraries
54BuildRequires:  python3-devel
55BuildRequires:  python3-rpm-macros
56BuildRequires:  python3-setuptools
57BuildRequires:  python3-libplist
58BuildRequires:  python3-Cython
59Requires: %{name} = %{version}-%{release}
60Provides: libiphone-python = %{version}
61Obsoletes: libiphone-python < 0.9.7
62
63%description -n python3-imobiledevice
64Python bindings for libimobiledevice.
65
66%endif
67
68
69%prep
70%setup -q
71
72# Fix dir permissions on html docs
73chmod +x docs/html
74
75
76%build
77aclocal
78automake --add-missing --copy
79autoconf
80
81%configure \
82  --disable-static \
83  --disable-openssl \
84%if %{with python}
85  --without-cython \
86  --without-python \
87%endif
88  ;
89
90sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
91sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
92
93make %{?_smp_mflags} V=1
94
95
96%install
97rm -rf %{buildroot}
98make install DESTDIR=%{buildroot}
99
100#Remove libtool archives.
101find %{buildroot} -name '*.la' -exec rm -f {} ';'
102
103
104%clean
105rm -rf %{buildroot}
106
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root,-)
115%license COPYING.LESSER
116%doc AUTHORS README*
117%doc %{_datadir}/man/man1/idevice*
118%{_bindir}/idevice*
119%{_libdir}/libimobiledevice*.so.*
120
121%files devel
122%defattr(-,root,root,-)
123%doc docs/html/
124%{_libdir}/pkgconfig/libimobiledevice-1.0.pc
125%{_libdir}/libimobiledevice*.so
126%{_includedir}/libimobiledevice/
127
128%if %{with python}
129%files -n python3-imobiledevice
130%defattr(-,root,root,-)
131%{python3_sitearch}/imobiledevice.so
132%endif
133
134
135%changelog
136* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
137- new upstream release.
138
139* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-2
140- built with gnutls-3.4.x.
141
142* Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-1
143- new upstream release
144
145* Tue Jul 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.6-1
146- update to 1.1.6
147- add BR: libusbmuxd-devel >= 1.0.9, libgcrypt-devel, readline-devel
148- disable python
149- disable openssl
150
151* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-2
152- rebuild with VineSeed environment
153- add Patch2 (libimobiledevice-1.1.5-cython.patch)
154
155* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-1
156- new upstream release
157
158* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
159- new upstream release
160- add BuildRequires: openssl-devel, Cython
161- add Patch1 (libimobiledevice-1.1.4-pkgconfig.patch)
162
163* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
164- rebuild with python-2.7.2
165
166* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
167- new upstream release
168
169* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
170- new upstream release
171
172* Tue Dec 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
173- new upstream release
174
175* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
176- rebuilt with rpm-4.8.1 for pkg-config
177
178* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
179- new upstream release
180
181* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-2
182- updated devel package Requires
183
184* Thu Apr 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
185- initial build for Vine Linux
186
187* Sun Mar 21 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.0-1
188- New upstream stable 1.0.0 release
189
190* Mon Feb 15 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-3
191- Add patch to fix DSO linking. Fixes bug 565084
192
193* Wed Feb  3 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-2
194- Package review updates, add developer docs
195
196* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-1
197- New package for new library name. Update to 0.9.7
198
199* Sun Jan 24 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.6-1
200- Update to 0.9.6 release
201
202* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.5-3
203- Updated to the new python sysarch spec file reqs
204
205* Tue Dec 15 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-2
206- Update python bindings
207
208* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-1
209- Update to 0.9.5 release for new usbmuxd/libplist 1.0.0 final
210
211* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-3
212- Rebuild for libplist .so bump
213
214* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-2
215- Update from libusb to libusb1
216
217* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-1
218- Update to 0.9.4 release for new usbmuxd 1.0.0-rc1
219
220* Mon Aug 10 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.3-1
221- Update to 0.9.3 release
222
223* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-3
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Wed May 13 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-2
227- Add new build reqs
228
229* Tue May 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-1
230- Update to official 0.9.1 release
231
232* Fri Apr 03 2009 - Bastien Nocera <bnocera@redhat.com> - 0.1.0-11.20090325git443edc8
233- Update to latest master version
234
235* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-10.20090103git5cde554
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
237
238* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-9.git5cde554
239- Add back gnutls version patch
240
241* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-8.git5cde554
242- Upload bzipped source file
243
244* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-7.git5cde554
245- New git snapshot
246
247* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-6.git8c3a01e
248- Fix devel dependency
249
250* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-5.git8c3a01e
251- Fix gnutls check for new rawhide version
252
253* Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-4.git8c3a01e
254- Rebuild for pkgconfig
255
256* Tue Dec 2 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-3.git8c3a01e
257- Fix git file generation
258
259* Mon Dec 1 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-2.git8c3a01e
260- Updates for package review
261
262* Sat Nov 29 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-1
263- Initial package
Note: See TracBrowser for help on using the repository browser.