source: projects/specs/trunk/lib/libi/libimobiledevice/libimobiledevice-vl.spec @ 5701

Revision 5701, 6.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Name:          libimobiledevice
2Version:       1.1.1
3Release:       2%{?_dist_release}
4Summary:       Library for connecting to mobile devices
5Summary(ja):   モバイルデバイスに接続するためのライブラリ
6
7Group:         System Environment/Libraries
8License:       LGPLv2+
9URL:           http://matt.colyer.name/projects/iphone-linux/
10
11Source0:       http://cloud.github.com/downloads/MattColyer/libiphone/%{name}-%{version}.tar.bz2
12Patch0:        libimobiledevice-fixdso.patch
13
14BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: libxml2-devel
16BuildRequires: libusb1-devel
17BuildRequires: libtasn1-devel
18BuildRequires: libplist-devel
19BuildRequires: glib2-devel
20BuildRequires: gnutls-devel
21BuildRequires: python-devel
22BuildRequires: swig
23BuildRequires: usbmuxd-devel
24
25Provides: libiphone = %{version}
26Obsoletes: libiphone < 0.9.7
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32libimobiledevice is a library for connecting to mobile devices including phones
33and music players
34
35%package devel
36Summary: Development package for libimobiledevice
37Summary(ja): libimobiledevice の開発用パッケージ
38Group: Development/Libraries
39Requires: libimobiledevice = %{version}-%{release}
40Requires: libplist-devel >= 0.12
41Requires: usbmuxd-devel >= 0.1.0
42Requires: glib2-devel >= 2.14.1
43Requires: gnutls-devel >= 1.6.3
44Requires: libtasn1-devel >= 1.1
45Requires: pkgconfig
46Provides: libiphone-devel = %{version}
47Obsoletes: libiphone-devel < 0.9.7
48
49%description devel
50Files for development with libimobiledevice.
51
52%package python
53Summary: Python bindings for libimobiledevice
54Summary(ja): libimobiledevice の Python バインディング
55Group: Development/Libraries
56Requires: libimobiledevice = %{version}-%{release}
57Requires: pkgconfig
58Provides: libiphone-python = %{version}
59Obsoletes: libiphone-python < 0.9.7
60
61%description python
62Python bindings for libimobiledevice.
63
64%prep
65%setup -q
66%patch0 -p1 -b .fixdso
67
68# Fix dir permissions on html docs
69chmod +x docs/html
70
71# Allow build against swig 2.0.0. A proper fix would be nicer.
72sed -i 's|1.3.21|2.0.0|g' configure
73
74%build
75%configure --disable-static
76# Remove rpath as per https://fedoraproject.org/wiki/Packaging/Guidelines#Beware_of_Rpath
77sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80make %{?_smp_mflags} V=1
81
82%install
83rm -rf %{buildroot}
84make install DESTDIR=%{buildroot}
85
86#Remove libtool archives.
87find %{buildroot} -name '*.la' -exec rm -f {} ';'
88
89%clean
90rm -rf %{buildroot}
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc AUTHORS COPYING.LESSER README
99%doc %{_datadir}/man/man1/idevice*
100%{_bindir}/idevice*
101%{_libdir}/libimobiledevice.so.*
102
103%files devel
104%defattr(-,root,root,-)
105%doc docs/html/
106%{_libdir}/pkgconfig/libimobiledevice-1.0.pc
107%{_libdir}/libimobiledevice.so
108%{_includedir}/libimobiledevice/
109
110%files python
111%defattr(-,root,root,-)
112%{python_sitearch}/imobiledevice/
113
114%changelog
115* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
116- rebuild with python-2.7.2
117
118* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
119- new upstream release
120
121* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
122- new upstream release
123
124* Tue Dec 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
125- new upstream release
126
127* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
128- rebuilt with rpm-4.8.1 for pkg-config
129
130* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
131- new upstream release
132
133* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-2
134- updated devel package Requires
135
136* Thu Apr 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
137- initial build for Vine Linux
138
139* Sun Mar 21 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.0-1
140- New upstream stable 1.0.0 release
141
142* Mon Feb 15 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-3
143- Add patch to fix DSO linking. Fixes bug 565084
144
145* Wed Feb  3 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-2
146- Package review updates, add developer docs
147
148* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-1
149- New package for new library name. Update to 0.9.7
150
151* Sun Jan 24 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.6-1
152- Update to 0.9.6 release
153
154* Sat Jan  9 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.5-3
155- Updated to the new python sysarch spec file reqs
156
157* Tue Dec 15 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-2
158- Update python bindings
159
160* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-1
161- Update to 0.9.5 release for new usbmuxd/libplist 1.0.0 final
162
163* Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-3
164- Rebuild for libplist .so bump
165
166* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-2
167- Update from libusb to libusb1
168
169* Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-1
170- Update to 0.9.4 release for new usbmuxd 1.0.0-rc1
171
172* Mon Aug 10 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.3-1
173- Update to 0.9.3 release
174
175* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-3
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
177
178* Wed May 13 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-2
179- Add new build reqs
180
181* Tue May 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-1
182- Update to official 0.9.1 release
183
184* Fri Apr 03 2009 - Bastien Nocera <bnocera@redhat.com> - 0.1.0-11.20090325git443edc8
185- Update to latest master version
186
187* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-10.20090103git5cde554
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
189
190* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-9.git5cde554
191- Add back gnutls version patch
192
193* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-8.git5cde554
194- Upload bzipped source file
195
196* Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-7.git5cde554
197- New git snapshot
198
199* Mon Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-6.git8c3a01e
200- Fix devel dependency
201
202* Mon Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-5.git8c3a01e
203- Fix gnutls check for new rawhide version
204
205* Mon Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-4.git8c3a01e
206- Rebuild for pkgconfig
207
208* Tue Dec 2 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-3.git8c3a01e
209- Fix git file generation
210
211* Mon Dec 1 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-2.git8c3a01e
212- Updates for package review
213
214* Sat Nov 29 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-1
215- Initial package
Note: See TracBrowser for help on using the repository browser.