source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 9472

Revision 9472, 7.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-28 Ryoichi INAGAKI <ryo1@…>

  • dbus-sharp, dbus-sharp-glib, gecko-sharp2, gio-sharp, gnome-desktop-sharp2, kimono, libgpod, mono-debugger, mono-zeroconf, webkit-sharp: rebuilt
  • gnome-sharp2, libgdiplus, mono, mono-addins, mono-basic, nant: updated


Line 
1%define with_mono 1
2
3Summary:       Library to access the iPod
4Summary(ja):   iPod にアクセスするためのライブラリ
5Name:          libgpod
6Version:       0.8.3
7Release:       5%{?_dist_release}
8Group:         System Environment/Libraries
9License:       LGPLv2+
10URL:           http://www.gtkpod.org/libgpod.html
11
12Source0:       %{name}-%{version}.tar.bz2
13
14# Vine Patch
15Patch100:      %{name}-0.8.3-python-uncomment.patch
16
17Buildroot:     %{_tmppath}/%{name}-%{version}-root
18BuildRequires: docbook-style-xsl
19BuildRequires: glib2-devel
20BuildRequires: gtk2-devel
21BuildRequires: gettext
22BuildRequires: intltool
23BuildRequires: libimobiledevice-devel >= 1.1.4
24BuildRequires: libplist-devel >= 1.0
25BuildRequires: libusb1-devel
26BuildRequires: libxml2-devel
27BuildRequires: libxslt
28BuildRequires: libffi-devel
29BuildRequires: perl(XML::Parser)
30BuildRequires: pygobject-devel
31BuildRequires: python-devel
32BuildRequires: python-mutagen
33BuildRequires: sg3_utils-devel
34BuildRequires: sqlite3-devel
35BuildRequires: taglib-devel
36BuildRequires: swig
37%if %{with_mono}
38BuildRequires: mono-devel
39BuildRequires: gtk-sharp2-devel
40%endif
41
42Requires:      udev
43
44Vendor:        Project Vine
45Distribution:  Vine Linux
46Packager:      daisuke
47
48%description
49libgpod is a library meant to abstract access to an iPod content. It
50provides an easy to use API to retrieve the list of files and playlist
51stored on an iPod, to modify them and to save them back to the iPod.
52
53%description -l ja
54libgpod は iPod のコンテンツにアクセスするためのライブラリです。
55iPod に格納されているファイルリストやプレイリストを取得し、変更し、
56iPod に書き戻すための API が提供されています。
57
58%package devel
59Summary:     Support files necessary to compile applications with libgpod.
60Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
61Group:       Development/Libraries
62Requires:    libgpod = %{version}-%{release}
63Requires:    glib2-devel
64Requires:    gtk2-devel
65
66%description devel
67Libraries, headers, and support files necessary to compile applications using libgpod.
68
69%description -l ja devel
70libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,ヘッダファイルなどが含まれています.
71
72%package -n python-gpod
73Summary:     Python module to access iPod content
74Summary(ja): iPod にアクセスするための Python モジュール
75Group:       Development/Libraries
76Requires:    %{name} = %{version}-%{release}
77Requires:    python-mutagen
78
79%description -n python-gpod
80A python module to access iPod content. This module provides bindings to the libgpod library.
81
82
83%if %{with_mono}
84%package sharp
85Summary:     C#/.NET library to access iPod content
86Summary(ja): iPod にアクセスするための C#/.NET ライブラリ
87Group:       System Environment/Libraries
88Requires:    %{name} = %{version}-%{release}
89
90%description sharp
91C#/.NET library to access iPod content.  Provides bindings to the libgpod library.
92
93%package sharp-devel
94Summary:     Development files for libgpod-sharp
95Summary(ja): libgpod-sharp の開発用ファイル
96Group:       Development/Libraries
97Requires:    %{name}-sharp = %{version}-%{release}
98Requires:    pkgconfig
99
100%description sharp-devel
101C#/.NET library to access iPod content. Provides bindings to the libgpod library.
102
103This package contains the files required to develop programs that will use
104libgpod-sharp.
105%endif
106
107
108%prep
109%setup -q
110%patch100 -p1 -b .uncomment
111
112chmod -x bindings/python/examples/*.py
113
114%build
115%configure \
116    --without-hal \
117    --enable-udev \
118    --with-temp-mount-dir=%{_localstatedir}/run/%{name}
119make %{?_smp_mflags}
120
121%install
122if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
123
124make DESTDIR=%{buildroot} install
125
126%find_lang %{name}
127
128rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
129rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
130
131%clean
132if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%files -f %{name}.lang
139%defattr(-, root, root, 0755)
140%doc AUTHORS ChangeLog COPYING README
141%{_bindir}/*
142%{_libdir}/lib*.so.*
143%dir %{_localstatedir}/run/%{name}
144/lib/udev/iphone-set-info
145/lib/udev/ipod-set-info
146/lib/udev/rules.d/*.rules
147
148%files devel
149%defattr(-, root, root, 0755)
150%{_libdir}/lib*.so
151%{_libdir}/pkgconfig/%{name}-1.0.pc
152%{_includedir}/gpod-1.0/
153%{_datadir}/gtk-doc/html/%{name}
154
155%files -n python-gpod
156%defattr(-, root, root, 0755)
157%doc COPYING bindings/python/README bindings/python/examples
158%{python_sitearch}/gpod
159
160%if %{with_mono}
161%files sharp
162%defattr(-, root, root, 0755)
163%{_libdir}/%{name}/%{name}-sharp*
164
165%files sharp-devel
166%defattr(-, root, root, 0755)
167%{_libdir}/pkgconfig/%{name}-sharp.pc
168%endif
169
170
171%changelog
172* Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-5
173- rebuilt with mono 3.12.1
174
175* Sun Mar  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-4
176- added patch100 to build swig 3.0.5
177- moved %%{_libdir}/pkgconfig/libgpod-sharp.pc to sharp subpackage
178
179* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-3
180- moved sharp subpackage to System Environment/Libraries Group
181- moved sharp-devel subpackage to Development/Libraries Group
182
183* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
184- rebuild with new libplist, libimobiledevice
185
186* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
187- new upstream release
188
189* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
190- rebuild with libimobiledevice-1.1.5
191
192* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
193- update to 0.8.2
194- remove Patch0
195- add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
196- create sharp and sharp-devel package
197
198* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
199- rebuild with libimobiledevice-1.1.4
200
201* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
202- rebuild with python-2.7.2
203
204* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
205- rebuild with libimobiledevice-1.1.1
206
207* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
208- update to 0.8.0
209
210* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
211- rebuilt with rpm-4.8.1 for pkg-config
212
213* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
214- new upstream release
215- add configure option (disable hal, enable udev, specify temp mount dir)
216- add python subpackage
217- add BR:
218
219* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
220- new upstream release
221- remove static library
222
223* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
224- added BuildRequires: libffi-devel
225
226* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
227- spec in utf-8
228
229* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
230- applied new versioning policy
231
232* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
233- new upstream release
234
235* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
236- for VineSeedPlus
237- new upstream release
238- built with new toolchain
239
240* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
241- new upstream release
242- build with dbus-0.62
243
244* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
245- new upstream release
246- build with dbus-0.61
247
248* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
249- initial package
Note: See TracBrowser for help on using the repository browser.