source: projects/specs/trunk/lib/libg/libgnomeprint20/libgnomeprint20-vl.spec @ 521

Revision 521, 11.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.0
5
6%define glib2_base_version 2.0.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.0.99
9%define libxml2_version 2.4.21
10%define libart_lgpl_version 2.3.8
11%define libbonobo_version 2.0.0
12%define bonobo_activation_version 1.0.0
13%define freetype_version 2.0.3
14%define gtk_doc_version 0.9
15
16Summary: Printing library for GNOME.
17Summary(ja): GNOME ¥×¥ê¥ó¥È¥é¥¤¥Ö¥é¥ê
18Name:           libgnomeprint20
19Version:        1.116.0
20Release:        0vl2
21License:        LGPL
22Group:          System Environment/Libraries
23Source:         ftp://ftp.gnome.org/pub/GNOME/sources/libgnomeprint/1.116/libgnomeprint-%{version}.tar.bz2
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26PreReq: urw-fonts
27PreReq: ghostscript
28PreReq: ghostscript-fonts
29PreReq: libxml
30PreReq: perl
31PreReq: XOrg
32
33BuildPrereq: glib2-devel >= %{glib2_version}
34BuildPrereq: pango-devel >= %{pango_version}
35BuildPrereq: libxml2-devel >= %{libxml2_version}
36BuildPrereq: libart_lgpl-devel >= %{libart_lgpl_version}
37BuildPrereq: libbonobo-devel >= %{libbonobo_version}
38BuildPrereq: bonobo-activation-devel >= %{bonobo_activation_version}
39BuildPrereq: freetype2 >= %{freetype_version}
40BuildPrereq: gtk-doc >= %{gtk_doc_version}
41BuildPrereq: automake14
42
43# Bug fix patches
44# remove libexec breakage
45Patch3: libgnomeprint-1.105.0.90-libexec.patch
46# improve the printing performance
47Patch4: libgnomeprint-1.116.0-perfprint.patch
48# generate the correct PostScript
49Patch5: libgnomeprint-1.116.0-correctps.patch
50
51# for Vine
52# build with newer freetype2
53Patch100: libgnomeprint-1.116.0-ft2build.patch
54
55%description
56GNOME (GNU Network Object Model Environment) is a user-friendly set of
57applications and desktop tools to be used in conjunction with a window
58manager for the X Window System. The gnome-print package contains
59libraries and fonts needed by GNOME applications for printing.
60
61You should install the gnome-print package if you intend to use any of
62the GNOME applications that can print. If you would like to develop
63GNOME applications that can print you will also need to install the
64gnome-print devel package.
65
66%package devel
67Summary: Libraries and include files for developing GNOME applications.
68Group: Development/Libraries
69
70Requires: %{name} = %{PACKAGE_VERSION}
71
72Requires: glib2-devel >= %{glib2_version}
73Requires: pango-devel >= %{pango_version}
74Requires: libxml2-devel >= %{libxml2_version}
75Requires: libart_lgpl-devel >= %{libart_lgpl_version}
76Requires: libbonobo-devel >= %{libbonobo_version}
77Requires: bonobo-activation-devel >= %{bonobo_activation_version}
78Requires: freetype2 >= %{freetype_version}
79
80%description devel
81GNOME (GNU Network Object Model Environment) is a user-friendly set of
82applications and desktop tools to be used in conjunction with a window
83manager for the X Window System. The gnome-print-devel package
84includes the libraries and include files needed for developing
85applications that use the GNOME printing capabilities.
86
87You should install the gnome-print-devel package if you would like to
88develop GNOME applications that will use the GNOME print capabilities.
89You do not need to install the gnome-print-devel package if you just
90want to use the GNOME desktop environment.
91
92%prep
93%setup -q -n libgnomeprint-%{version}
94
95%patch3 -p1 -b .libexec
96%patch4 -p0 -b .perfprint
97%patch5 -p1 -b .correctps
98%patch100 -p1 -b .ft2build
99
100%build
101
102automake-1.4
103
104%configure --disable-font-install
105make
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
111# instead of %%makeinstall with this hack.
112%makeinstall FONTMAPDIR_STATIC=$RPM_BUILD_ROOT/usr/share/gnome/libgnomeprint-2.0/fonts
113./mkinstalldirs $RPM_BUILD_ROOT/%{_sysconfdir}/gnome/libgnomeprint-2.0/fonts
114
115/bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
116
117%find_lang %{gettext_package}
118
119#Add redhat-update-gnome-font-install
120cat > $RPM_BUILD_ROOT%{_bindir}/redhat-update-gnome-font-install2 << EOF
121#! /bin/sh
122/usr/bin/libgnomeprint-2.0-font-install                                 \
123        --aliases=%{_datadir}/gnome/libgnomeprint-2.0/fonts/adobe-urw.font              \
124        --target=%{_sysconfdir}/gnome/libgnomeprint-2.0/fonts/libgnomeprint-rpm.fontmap \
125        --recursive --clean                                             \
126        /usr/X11R6/lib/X11/fonts/Type1                                  \
127        %{_datadir}/fonts
128EOF
129chmod 755 $RPM_BUILD_ROOT%{_bindir}/redhat-update-gnome-font-install2
130
131# remove unpackaged files from the buildroot
132rm -f $RPM_BUILD_ROOT%{_datadir}/fonts/README.installer
133rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint-2.la
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139/sbin/ldconfig
140## we could pass --dynamic here to install to /etc instead
141## but I think it makes more sense to have this not be a config
142## file, then people make their changes in /etc if they want
143/usr/bin/redhat-update-gnome-font-install2
144
145%postun -p /sbin/ldconfig
146
147%files -f %{gettext_package}.lang
148%defattr(-, root, root)
149%dir %{_sysconfdir}/gnome/libgnomeprint-2.0
150%doc AUTHORS COPYING ChangeLog NEWS README installer/README.*
151%{_bindir}/*
152%{_libdir}/gnome-print-2.0
153%{_libdir}/lib*.so.%{sover}
154%{_libdir}/lib*.so.%{sover}.*
155%{_datadir}/gnome-print-2.0
156%{_datadir}/gnome/libgnomeprint-2.0
157
158%files devel
159%defattr(-, root, root)
160
161%{_libdir}/lib*.so
162%{_libdir}/*.a
163%{_includedir}/*
164%{_libdir}/pkgconfig/*
165
166%changelog
167* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.116.0-0vl2
168- added Japanese summary
169- changed Group to System Environment/Libraries
170- added Patch100 for build with newer freetype2
171
172* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.116.0-0vl1
173- libgnomeprint20 for compatibility
174
175* Mon Dec 16 2002 Havoc Pennington <hp@redhat.com>
176- nuke the docs, conflicts with 2.1.x libgnomeprint, and this one is
177  deprecated anyway
178
179* Fri Dec 13 2002 Tim Powers <timp@redhat.com> 1.116.0-3
180- remove unpackaged files from the buildroot
181- don't list the dirs twice in the file list
182
183* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
184- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
185
186* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
187- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
188  performance issue. (#66715)
189
190* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
191- includes redhat-update-gnome-font-install2 script. (#66899)
192- fix the install path for fontmap.
193- add some directory owners.
194
195* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
196- rebuilt
197
198* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
199- 1.115.0
200- include gtk-doc docs
201- move pkg-config files to -devel package
202
203* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
204- rebuild in different environment
205
206* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
207- 1.114.0
208
209* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
210- rebuild in different environment
211
212* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
213- rebuild in different environment
214- add bonobo-activation requires to make build system happy
215
216* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
217- 1.113.0
218
219* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
220- rebuild for new libraries
221
222* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
223- 1.112.0
224
225* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
226- 1.111.0
227
228* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
229- Version 1.110.0
230
231* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
232- automake14
233
234* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
235- 1.109.0.90 snap
236- remove .options patch which is upstream
237- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
238  and has --disable-font-install configure option
239- remove .fontmapdir, now fixed upstream
240
241* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
242- rebuild due to build system fuckup
243
244* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
245- cvs snap 1.106.0.90, glib 1.3.11
246
247* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
248- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
249
250* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
251- remove epoch screwup
252
253* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
254- libgnomeprint package based on the gnome-print package
255
256* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
257- use 0.30 tarball
258
259* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
260- new cvs snap, with headers moved
261
262* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
263- Back out freetype change, for now, until we can get it in upstream.
264- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
265  Making them %config doesn't seem compatible with locating them
266  in gnome-print/<ver>.
267
268* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
269- no replace profiles.
270
271* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
272- Move profiles directory to /etc/gnome-print/<ver>/profiles/
273
274* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
275- Add freetype support patch. (Bug#50360)
276
277* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
278- Add missing directory
279
280* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
281- Upgrade to 0.29
282- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
283- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
284- Make libgnomeprint package require gnome-print package; otherwise
285  packages requiring libgnomeprint might not get a runtime environment
286- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
287
288* Mon Jul 16 2001 Trond Eivind Glomsr½ó?<teg@redhat.com>
289- Kill output from run-gnome-font-install
290- s/Copyright/License/
291- Add post/postun scripts for the libgnomeprint subpackage
292
293* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
294- Bump release + rebuild.
295
296* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
297- new version (0.28)
298
299* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
300- Rebuild for GTK+-1.2.9 include paths
301
302* Fri Feb 23 2001 Trond Eivind Glomsr½ó?<teg@redhat.com>
303- langify
304- patch it to compile (didn't include locale.h when needed)
305- use %%{_tmppath}
306
307* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
308- Fixed font problem for Japanese.
309- Fixed library dependency on VFlib (Bug#28331)
310
311* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
312- Fixed bugzilla bug #27417, simple specfile %post fix.
313
314* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
315- Fixed PostScript broken.
316- Added autoheader,automake,autoconf stuff.
317
318* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
319- add libtoolize to make porting to new archs easy
320
321* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
322- Updated Japanese patch for Gnumeric.
323  Created dummy .afm.
324
325* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
326- Fixed gdk_fontset_load().
327- Added Japanese patch for Gnumeric.
328
329* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
330- Added Japanese patch.
331  Fixed Print and Preview with Japanese.
332
333* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
334- 0.25
335
336* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
337- added "|| true" to %%post so that if font-install screws up we don't get a
338  bad exit status.  gnome-font-install expects that the directory specified by
339  HOME env. var is writable, but it isn't always if you install with 'sudo'
340  or the equivalent.  bad. bad. bad.
341
342* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
343- Up Epoch and release
344
345* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
346- redirect %%post script output to /dev/null
347
348* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
349- automatic rebuild
350
351* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
352- Spec file fixes
Note: See TracBrowser for help on using the repository browser.