source: projects/specs/trunk/lib/libg/libglade2/libglade2-vl.spec @ 521

Revision 521, 9.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __libtoolize :
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4%define libxml2_version 2.4.29
5%define gtk2_version 2.6.0
6%define pango_version 1.8.0
7
8Summary: The libglade library for loading user interfaces.
9Name: libglade2
10Version: 2.6.4
11Release: 4%{?_dist_release}
12License: LGPL
13Group: System Environment/Libraries
14Source: libglade-%{version}.tar.bz2
15#Source2: fixed-ltmain.sh
16URL: http://www.gnome.org/
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: gtk2-devel >= %{gtk2_version}
21BuildRequires: pango-devel >= %{pango_version}
22BuildRequires: python-devel >= 2.2.1
23BuildRequires: python >= 2.2.1
24Requires(post): libxml2 >= %{libxml2_version}
25Requires(postun): libxml2 >= %{libxml2_version}
26Requires(post): xml-common
27Requires(postun): xml-common
28
29%description
30Libglade is a small library that allows a program to load its user
31interface from am XML description at runtime. Libglade uses the XML
32file format used by the GLADE user interface builder GLADE, so
33libglade acts as an alternative to GLADE's code generation
34approach. Libglade also provides a simple interface for connecting
35handlers to the various signals in the interface (on platforms where
36the gmodule library works correctly, it is possible to connect all the
37handlers with a single function call). Once the interface has been
38instantiated, libglade gives no overhead, so other than the short
39initial interface loading time, there is no performance tradeoff.
40#'
41
42%package devel
43Summary: The files needed for libglade application development.
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: libxml2-devel >= %{libxml2_version}
47Requires: gtk2-devel >= %{gtk2_version}
48Conflicts: libglade < 0.17
49
50%description devel
51The libglade-devel package contains the libraries and include files
52that you can use to develop libglade applications.
53
54%package -n compat32-%{name}
55Summary: The libglade library for loading user interfaces.
56Group: System Environment/Libraries
57Requires: %{name} = %{version}-%{release}
58
59%description -n compat32-%{name}
60Libglade is a small library that allows a program to load its user
61interface from am XML description at runtime. Libglade uses the XML
62file format used by the GLADE user interface builder GLADE, so
63libglade acts as an alternative to GLADE's code generation
64approach. Libglade also provides a simple interface for connecting
65handlers to the various signals in the interface (on platforms where
66the gmodule library works correctly, it is possible to connect all the
67handlers with a single function call). Once the interface has been
68instantiated, libglade gives no overhead, so other than the short
69initial interface loading time, there is no performance tradeoff.
70#'
71
72%package -n compat32-%{name}-devel
73Summary: The files needed for libglade application development.
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76Requires: compat32-%{name} = %{version}-%{release}
77Requires: compat32-libxml2-devel >= %{libxml2_version}
78Requires: compat32-gtk2-devel >= %{gtk2_version}
79
80%description -n compat32-%{name}-devel
81The libglade-devel package contains the libraries and include files
82that you can use to develop libglade applications.
83
84%prep
85%setup -q -n libglade-%{version}
86
87%build
88
89#rm ltmain.sh && cp %{SOURCE2} ltmain.sh
90%configure --disable-gtk-doc --disable-static
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%makeinstall
97install -m755 libglade-convert $RPM_BUILD_ROOT%{_bindir}
98
99rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105/sbin/ldconfig
106CATALOG=/etc/xml/catalog
107/usr/bin/xmlcatalog --noout --add "system" \
108 "http://glade.gnome.org/glade-2.0.dtd" \
109 "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
110
111%postun
112/sbin/ldconfig
113# remove entries only on removal of package
114if [ "$1" = 0 ]; then
115  CATALOG=/etc/xml/catalog
116  /usr/bin/xmlcatalog --noout --del \
117   "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
118fi
119
120%post   -n compat32-%{name} -p /sbin/ldconfig
121
122%postun -n compat32-%{name} -p /sbin/ldconfig
123
124%files
125%defattr(-, root, root)
126%doc AUTHORS ChangeLog NEWS README COPYING
127%{_libdir}/lib*.so.*
128%{_datadir}/xml
129
130%files devel
131%defattr(-, root, root)
132%doc test-libglade.c
133%{_bindir}/*
134%{_libdir}/lib*.so
135%{_libdir}/pkgconfig/*.pc
136%{_includedir}/*
137%{_datadir}/gtk-doc
138
139%if %{build_compat32}
140%files -n compat32-%{name}
141%defattr(-, root, root)
142%{_libdir}/lib*.so.*
143
144%files -n compat32-%{name}-devel
145%defattr(-, root, root)
146%{_libdir}/lib*.so
147%{_libdir}/pkgconfig/*.pc
148%endif
149
150%changelog
151* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
152- rebuilt with new toolchain
153
154* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-3
155- added compat32-libglade2-devel for x86_64 architecture
156
157* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
158- add Requires(post,postun): xml-common
159- remove static library
160
161* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
162- new upstream release
163
164* Mon Sep 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-1
165- new upstream release
166- run /usr/bin/xmlcatlog at %%post and %%postun section
167
168* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-1vl5
169- used %%{?_dist_release} tag
170- removed lib*.la from devel package
171
172* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-0vl1
173- new upstream release
174
175* Wed Aug  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.0-0vl1
176- new upstream release
177
178* Fri May 26 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.1-0vl2
179- added compat32-libglade2 package for x86_64 architecture support
180
181* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
182- new upstream version
183
184* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
185- new upstream release
186
187* Tue Jun 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl1
188- new upstream release
189- drop obsoleted Source2
190- s/COPYRIGHT/LICENSE/
191
192* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl2
193- rebuild with python2
194
195* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl1
196- build for Vine Linux
197
198* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
199- automated rebuild
200
201* Sat Jun 15 2002 Havoc Pennington <hp@redhat.com>
202- 2.0.0
203- check over file list, add XML DTD to it
204
205* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
206- rebuild in different environment
207
208* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
209- don't run auto*
210
211* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
212- 1.99.12
213- remove gtk-doc hack, --disable-gtk-doc now works
214
215* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
216- 1.99.11
217
218* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
219- 1.99.10
220
221* Tue Mar 19 2002 Alex Larsson <alexl@redhat.com>
222- Update autoconf dependency to 2.53
223
224* Mon Mar 11 2002 Alex Larsson <alexl@redhat.com>
225- Update to 1.99.9
226
227* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
228- Bump for rebuild
229
230* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
231- Bump for rebuild
232
233* Tue Feb 19 2002 Alex Larsson <alexl@redhat.com>
234- Add horrible buildroot check hacks. Require new Gtk+.
235
236* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
237- rebuild for new gtk
238
239* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
240- Rebuild against new GTK+
241
242* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
243- put "nogtkdoc" patch back, it avoids X display requirement
244- automake14
245
246* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
247- 1.99.5.90 snap
248- comment out "nogtkdoc" patch, don't run autoconf
249
250* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
251- new 1.99.4.91 snap with Jacob's fixes, he
252  assures me we are 1.99.4.90 ABI-compatible
253
254* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
255- new 1.99.4.90 snap, gtk 1.3.11
256
257* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
258- new snap, rebuild on gtk 1.3.10
259
260* Sat Oct  6 2001 Havoc Pennington <hp@redhat.com>
261- new snap, add hack to avoid trying to build docs
262- add the ltmain.sh hack to avoid relinking
263
264* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
265- new snap
266
267* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
268- convert libglade rpm to libglade2 rpm, initial build of libglade2
269
270* Mon Aug 20 2001 Jonathan Blandford <jrb@redhat.com>
271- Escape strings, #51966
272
273* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
274- add build requires, bug #49508
275
276* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
277- Bump release + rebuild.
278
279* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
280- New Version.
281
282* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
283- Rebuild for GTK+-1.2.9 include paths
284
285* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
286- add libtoolize to make porting to new archs easy
287
288* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
289- 0.14
290- added patch for gtk-doc scanner linkage
291
292* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
293- Up Epoch and release
294
295* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
296- automatic rebuild
297
298* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
299- specfile fixes
300
301* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
302- Upgraded to libglade-0.13
303- Use %makeinstall, since that is required when %configure is used.
304
305* Fri May 19 2000 Owen Taylor <otaylor@redhat.com>
306- Upgraded to libglade-0.12
307
308* Tue Sep 07 1999 Elliot Lee <sopwith@redhat.com>
309- Updated RHL 6.1 package to libglade-0.5
310
311* Sun Nov  1 1998 James Henstridge <james@daa.com.au>
312
313- Updated the dependencies of the devel package, so users must have gtk+-devel.
314
315* Sun Oct 25 1998 James Henstridge <james@daa.com.au>
316
317- Initial release 0.0.1
Note: See TracBrowser for help on using the repository browser.