source: projects/specs/trunk/lib/libg/libglade2/libglade2-vl.spec @ 8084

Revision 8084, 9.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define __libtoolize :
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4%define libxml2_version 2.4.29
5%define gtk2_version 2.6.0
6%define pango_version 1.8.0
7
8Summary: The libglade library for loading user interfaces.
9Name: libglade2
10Version: 2.6.4
11Release: 6%{?_dist_release}
12License: LGPL
13Group: System Environment/Libraries
14Source: libglade-%{version}.tar.bz2
15#Source2: fixed-ltmain.sh
16URL: http://www.gnome.org/
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: gtk2-devel >= %{gtk2_version}
21BuildRequires: pango-devel >= %{pango_version}
22BuildRequires: python-devel >= 2.2.1
23BuildRequires: python >= 2.2.1
24Requires(post): libxml2 >= %{libxml2_version}
25Requires(postun): libxml2 >= %{libxml2_version}
26Requires(post): xml-common
27Requires(postun): xml-common
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Libglade is a small library that allows a program to load its user
34interface from am XML description at runtime. Libglade uses the XML
35file format used by the GLADE user interface builder GLADE, so
36libglade acts as an alternative to GLADE's code generation
37approach. Libglade also provides a simple interface for connecting
38handlers to the various signals in the interface (on platforms where
39the gmodule library works correctly, it is possible to connect all the
40handlers with a single function call). Once the interface has been
41instantiated, libglade gives no overhead, so other than the short
42initial interface loading time, there is no performance tradeoff.
43#'
44
45%package devel
46Summary: The files needed for libglade application development.
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: libxml2-devel >= %{libxml2_version}
50Requires: gtk2-devel >= %{gtk2_version}
51Conflicts: libglade < 0.17
52
53%description devel
54The libglade-devel package contains the libraries and include files
55that you can use to develop libglade applications.
56
57%package -n compat32-%{name}
58Summary: The libglade library for loading user interfaces.
59Group: System Environment/Libraries
60Requires: %{name} = %{version}-%{release}
61
62%description -n compat32-%{name}
63Libglade is a small library that allows a program to load its user
64interface from am XML description at runtime. Libglade uses the XML
65file format used by the GLADE user interface builder GLADE, so
66libglade acts as an alternative to GLADE's code generation
67approach. Libglade also provides a simple interface for connecting
68handlers to the various signals in the interface (on platforms where
69the gmodule library works correctly, it is possible to connect all the
70handlers with a single function call). Once the interface has been
71instantiated, libglade gives no overhead, so other than the short
72initial interface loading time, there is no performance tradeoff.
73#'
74
75%package -n compat32-%{name}-devel
76Summary: The files needed for libglade application development.
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79Requires: compat32-%{name} = %{version}-%{release}
80Requires: compat32-libxml2-devel >= %{libxml2_version}
81Requires: compat32-gtk2-devel >= %{gtk2_version}
82
83%description -n compat32-%{name}-devel
84The libglade-devel package contains the libraries and include files
85that you can use to develop libglade applications.
86
87%prep
88%setup -q -n libglade-%{version}
89
90%build
91
92#rm ltmain.sh && cp %{SOURCE2} ltmain.sh
93%configure --disable-gtk-doc --disable-static
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%makeinstall
100install -m755 libglade-convert $RPM_BUILD_ROOT%{_bindir}
101
102rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post
108/sbin/ldconfig
109CATALOG=/etc/xml/catalog
110/usr/bin/xmlcatalog --noout --add "system" \
111 "http://glade.gnome.org/glade-2.0.dtd" \
112 "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
113
114%postun
115/sbin/ldconfig
116# remove entries only on removal of package
117if [ "$1" = 0 ]; then
118  CATALOG=/etc/xml/catalog
119  /usr/bin/xmlcatalog --noout --del \
120   "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
121fi
122
123%post   -n compat32-%{name} -p /sbin/ldconfig
124
125%postun -n compat32-%{name} -p /sbin/ldconfig
126
127%files
128%defattr(-, root, root)
129%doc AUTHORS ChangeLog NEWS README COPYING
130%{_libdir}/lib*.so.*
131%{_datadir}/xml
132
133%files devel
134%defattr(-, root, root)
135%doc test-libglade.c
136%{_bindir}/*
137%{_libdir}/lib*.so
138%{_libdir}/pkgconfig/*.pc
139%{_includedir}/*
140%{_datadir}/gtk-doc
141
142%if %{build_compat32}
143%files -n compat32-%{name}
144%defattr(-, root, root)
145%{_libdir}/lib*.so.*
146
147%files -n compat32-%{name}-devel
148%defattr(-, root, root)
149%{_libdir}/lib*.so
150%endif
151
152%changelog
153* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-6
154- rebuild with VineSeed environment
155
156* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.4-5
157- build with rpm-4.8.1-1 for pkg-config file
158
159* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
160- rebuilt with new toolchain
161
162* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-3
163- added compat32-libglade2-devel for x86_64 architecture
164
165* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
166- add Requires(post,postun): xml-common
167- remove static library
168
169* Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
170- new upstream release
171
172* Mon Sep 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-1
173- new upstream release
174- run /usr/bin/xmlcatlog at %%post and %%postun section
175
176* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-1vl5
177- used %%{?_dist_release} tag
178- removed lib*.la from devel package
179
180* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-0vl1
181- new upstream release
182
183* Wed Aug  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.0-0vl1
184- new upstream release
185
186* Fri May 26 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.1-0vl2
187- added compat32-libglade2 package for x86_64 architecture support
188
189* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
190- new upstream version
191
192* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
193- new upstream release
194
195* Thu Jun 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl1
196- new upstream release
197- drop obsoleted Source2
198- s/COPYRIGHT/LICENSE/
199
200* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl2
201- rebuild with python2
202
203* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl1
204- build for Vine Linux
205
206* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
207- automated rebuild
208
209* Sat Jun 15 2002 Havoc Pennington <hp@redhat.com>
210- 2.0.0
211- check over file list, add XML DTD to it
212
213* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
214- rebuild in different environment
215
216* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
217- don't run auto*
218
219* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
220- 1.99.12
221- remove gtk-doc hack, --disable-gtk-doc now works
222
223* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
224- 1.99.11
225
226* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
227- 1.99.10
228
229* Tue Mar 19 2002 Alex Larsson <alexl@redhat.com>
230- Update autoconf dependency to 2.53
231
232* Mon Mar 11 2002 Alex Larsson <alexl@redhat.com>
233- Update to 1.99.9
234
235* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
236- Bump for rebuild
237
238* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
239- Bump for rebuild
240
241* Tue Feb 19 2002 Alex Larsson <alexl@redhat.com>
242- Add horrible buildroot check hacks. Require new Gtk+.
243
244* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
245- rebuild for new gtk
246
247* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
248- Rebuild against new GTK+
249
250* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
251- put "nogtkdoc" patch back, it avoids X display requirement
252- automake14
253
254* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
255- 1.99.5.90 snap
256- comment out "nogtkdoc" patch, don't run autoconf
257
258* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
259- new 1.99.4.91 snap with Jacob's fixes, he
260  assures me we are 1.99.4.90 ABI-compatible
261
262* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
263- new 1.99.4.90 snap, gtk 1.3.11
264
265* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
266- new snap, rebuild on gtk 1.3.10
267
268* Sat Oct  6 2001 Havoc Pennington <hp@redhat.com>
269- new snap, add hack to avoid trying to build docs
270- add the ltmain.sh hack to avoid relinking
271
272* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
273- new snap
274
275* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
276- convert libglade rpm to libglade2 rpm, initial build of libglade2
277
278* Mon Aug 20 2001 Jonathan Blandford <jrb@redhat.com>
279- Escape strings, #51966
280
281* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
282- add build requires, bug #49508
283
284* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
285- Bump release + rebuild.
286
287* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
288- New Version.
289
290* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
291- Rebuild for GTK+-1.2.9 include paths
292
293* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
294- add libtoolize to make porting to new archs easy
295
296* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
297- 0.14
298- added patch for gtk-doc scanner linkage
299
300* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
301- Up Epoch and release
302
303* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
304- automatic rebuild
305
306* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
307- specfile fixes
308
309* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
310- Upgraded to libglade-0.13
311- Use %makeinstall, since that is required when %configure is used.
312
313* Fri May 19 2000 Owen Taylor <otaylor@redhat.com>
314- Upgraded to libglade-0.12
315
316* Tue Sep 07 1999 Elliot Lee <sopwith@redhat.com>
317- Updated RHL 6.1 package to libglade-0.5
318
319* Sun Nov  1 1998 James Henstridge <james@daa.com.au>
320
321- Updated the dependencies of the devel package, so users must have gtk+-devel.
322
323* Sun Oct 25 1998 James Henstridge <james@daa.com.au>
324
325- Initial release 0.0.1
Note: See TracBrowser for help on using the repository browser.