source: projects/specs/trunk/lib/libg/libgksu/libgksu-vl.spec @ 4193

Revision 4193, 7.4 KB checked in by daisuke, 13 years ago (diff)

libgksu:

  • update to 2.0.12
  • add patch100 to enable sudo_mode by default.
  • add BR: libgnome-keyring-devel
Line 
1Summary: GKSu libraries
2SUmmary(ja): GKSu ライブラリ
3Name: libgksu
4Version: 2.0.12
5Release: 1%{?_dist_release}
6Url: http://www.nongnu.org/gksu/
7Group: System Environment/Libraries
8License: GPL
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14Source: http://people.debian.org/~kov/gksu/%{name}-%{version}.tar.gz
15Source10: libgksu-2.0.9-ja.po
16Patch0: libgksu-2.0.5-i18n.patch
17Patch1: libgksu-2.0.9-ja.patch
18
19# patches from ubuntu
20Patch9: libgksu-2.0.9-multihead.patch
21Patch12: libgksu-2.0.9-no_password_dialog.patch
22Patch13: libgksu-2.0.9-startup_notification.diff
23Patch14: libgksu-2.0.9-polish_startup.diff
24Patch15: libgksu-2.0.12-extra_paranoia_for_gconf.diff.patch
25Patch17: libgksu-2.0.9-composited_fade.patch
26Patch18: libgksu-2.0.9-g_markup_escape_text_for_command.patch
27Patch20: libgksu-2.0.9-better_usleep.patch
28Patch21: libgksu-2.0.9-composited_rgba_addition.patch
29Patch22: libgksu-2.0.9-sudo_keep_env.patch
30
31Patch100: libgksu-2.0.12-default-sudo_mode.patch
32
33BuildRoot: %{_tmppath}/%{name}-buildroot
34BuildRequires: glib2-devel
35BuildRequires: gtk-doc
36BuildRequires: libgtop2-devel
37BuildRequires: startup-notification-devel
38BuildRequires: gnome-keyring-devel
39BuildRequires: libgnome-keyring-devel
40BuildRequires: GConf2-devel
41BuildRequires: gtk2-devel
42BuildRequires: libglade2-devel
43BuildRequires: perl-XML-Parser
44BuildRequires: desktop-file-utils
45
46%description
47GKSu is a library that provides a Gtk+ frontend to su and sudo. It
48supports login shells and preserving environment when acting as a su
49 frontend. It is useful to menu items or other graphical programs
50that need to ask a user's password to run another program as another user.
51
52%package devel
53Summary: Development package for %{name}
54Group: Development/Libraries
55Requires: %{name} = %{version}
56
57%description devel
58Development package for %{name}
59
60GKSu is a library that provides a Gtk+ frontend to su and sudo. It
61supports login shells and preserving environment when acting as a su
62 frontend. It is useful to menu items or other graphical programs
63that need to ask a user's password to run another program as another user.
64
65%package -n gksu-utils
66Summary: Utilities package for %{name}
67Group: Applications/System
68Requires: %{name} = %{version}
69
70%description -n gksu-utils
71Utilities package for %{name}
72
73GKSu is a library that provides a Gtk+ frontend to su and sudo. It
74supports login shells and preserving environment when acting as a su
75 frontend. It is useful to menu items or other graphical programs
76that need to ask a user's password to run another program as another user.
77
78# '
79%prep
80%setup -q
81%patch0 -p1 -b .i18n
82%patch1 -p1 -b .ja
83
84%patch9 -p1 -b .multihead
85%patch12 -p1 -b .no_password_dialog
86%patch13 -p1 -b .startup_notification
87%patch14 -p1 -b .polish_startup
88%patch17 -p1 -b .composited_fade
89%patch18 -p0 -b .g_markup_escape_text_for_command
90%patch20 -p1 -b .better_usleep
91%patch21 -p1 -b .composited_rgba_addition
92%patch22 -p1 -b .sudo_keep_env
93
94%patch100 -p1 -b .default-sudo_mode
95
96## For x86_64, we use /usr/lib64/libgksu/gksu-run-helper
97%__sed -i 's@\(gchar auxcommand\[\] = PREFIX "/\)lib\(/" PACKAGE "/gksu-run-helper";\)@\1%{_lib}\2@' libgksu/libgksu.c
98
99
100cp -f %{SOURCE10} po/ja.po
101
102
103
104%build
105intltoolize -f
106touch README NEWS
107autoreconf -f -i
108%configure
109%__make %{?_smp_mflags}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113%makeinstall
114
115sed -i -e 's/Icon=gksu.png/Icon=gksu/g' $RPM_BUILD_ROOT%{_datadir}/applications/*
116desktop-file-install --vendor="" \
117  --remove-category="Application" \
118  --remove-category="AdvancedSettings" \
119  --add-category="Settings" \
120  --add-category="X-GNOME-SystemSettings" \
121  --dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/*
122
123%find_lang %{name}
124
125rm $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133%post -n gksu-utils
134export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
136
137%preun -n gksu-utils
138if [ "$1" -eq 0 ]; then
139  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
140  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
141fi
142
143%files -f %{name}.lang
144%defattr(-,root,root)
145%{_libdir}/*.so.*
146%{_libdir}/%{name}
147
148%files devel
149%defattr(-,root,root)
150%doc INSTALL ChangeLog AUTHORS
151%{_libdir}/*.so
152%{_includedir}/*
153%{_libdir}/pkgconfig/*
154%{_datadir}/gtk-doc/html/%{name}
155
156%files -n gksu-utils
157%defattr(-,root,root)
158%{_sysconfdir}/gconf/schemas/gksu.schemas
159%{_bindir}/gksu-properties
160%{_datadir}/applications/gksu-properties.desktop
161%{_datadir}/libgksu/gksu-properties.ui
162%{_datadir}/pixmaps/gksu.png
163%{_mandir}/man1/gksu-properties.1*
164
165%changelog
166* Tue Jun 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-1
167- update to 2.0.12
168- add patch100 to enable sudo_mode by default.
169- add BR: libgnome-keyring-devel
170
171* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.9-5
172- rebuilt with rpm-4.8.1 for pkg-config
173
174* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.9-4
175- add Categories=X-GNOME-SystemSettings for .desktop
176
177* Thu Jun 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0.9-3
178- use /usr/lib64/libgksu/gksu-run-helper for x86_64
179
180* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-2
181- import Patch9-22 from ubuntu
182  - Patch9: fix multihead
183  - Patch12: don't show password dialog if no password was needed
184  - Patch13: make startup notification more reliable
185  - Patch14: improve startup notification messages
186  - Patch17: nicer fadeout on composited display
187  - Patch18: fix missing g_markup_escape when commands are displayed
188  - Patch20: add small usleep() to avoid race condition when
189             the hostname can not be resolved.
190  - Patch21: bling
191  - Patch22: If gksudo -k is used, pass the -E option to sudo
192             to preserve the environment if we're allowed to do so
193- update ja.po
194
195* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-1
196- new upstream release
197- remove static library
198
199* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.7-1
200- new upstream release
201- new versioning policy
202
203* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-0vl1
204- initial build for Vine Linux
205
206* Tue Jul 03 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.5-1mdv2008.0
207+ Revision: 47621
208- new version
209
210* Fri Jun 22 2007 Thierry Vignaud <tvignaud@mandriva.com> 2.0.4-2mdv2008.0
211+ Revision: 43013
212- remove "AdvancedSettings" category from menu
213- kill X-MandrivaLinux-System-Configuration-Other
214- fix group
215
216
217* Tue Mar 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.4-1mdv2007.0
218+ Revision: 134081
219- New version 2.0.4
220- disable gtk-doc (build problem)
221
222* Tue Feb 20 2007 G旦tz Waschk <waschk@mandriva.org> 2.0.3-5mdv2007.1
223+ Revision: 123029
224- fix scripts
225
226* Sat Jan 27 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-4mdv2007.1
227+ Revision: 114416
228- xdg menu
229  handles gconf schemas
230
231* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-3mdv2007.1
232+ Revision: 104863
233- fix provides
234
235* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-2mdv2007.1
236+ Revision: 104797
237- rebuild
238
239* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-1mdv2007.1
240+ Revision: 104663
241- buildrequires perl-XML-Parser
242- buildrequires libglade2.0-devel
243- buildrequires libGConf2-devel
244  buildrequires gtk+2-devel
245- buildrequires startup-notification-devel
246  gnome-keyring-devel
247- New version 2.0.3
248  fix provides
249  buildrequires libgtop2.0-devel
250
251  + J辿r担me Soyer <saispo@mandriva.org>
252    - Import libgksu
253
Note: See TracBrowser for help on using the repository browser.