source: projects/specs/trunk/lib/libg/libgksu/libgksu-vl.spec @ 8451

Revision 8451, 8.0 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild with libgtop2-2.30.0

Line 
1Summary: GKSu libraries
2SUmmary(ja): GKSu ライブラリ
3Name: libgksu
4Version: 2.0.12
5Release: 3%{?_dist_release}
6Url: http://www.nongnu.org/gksu/
7Group: System Environment/Libraries
8License: GPL
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14Source: http://people.debian.org/~kov/gksu/%{name}-%{version}.tar.gz
15Source10: libgksu-2.0.9-ja.po
16Patch0: libgksu-2.0.5-i18n.patch
17Patch1: libgksu-2.0.9-ja.patch
18
19# patches from ubuntu
20Patch9: libgksu-2.0.9-multihead.patch
21Patch12: libgksu-2.0.9-no_password_dialog.patch
22Patch13: libgksu-2.0.9-startup_notification.diff
23Patch14: libgksu-2.0.9-polish_startup.diff
24Patch15: libgksu-2.0.12-extra_paranoia_for_gconf.diff.patch
25Patch17: libgksu-2.0.9-composited_fade.patch
26Patch18: libgksu-2.0.9-g_markup_escape_text_for_command.patch
27Patch20: libgksu-2.0.9-better_usleep.patch
28Patch21: libgksu-2.0.9-composited_rgba_addition.patch
29Patch22: libgksu-2.0.9-sudo_keep_env.patch
30Patch30:  libgksu-2.0.12-revert-forkpty.patch
31
32Patch100: libgksu-2.0.12-default-sudo_mode.patch
33Patch101: libgksu-2.0.12-makefile-vine.patch
34
35BuildRoot: %{_tmppath}/%{name}-buildroot
36BuildRequires: glib2-devel
37BuildRequires: gtk-doc
38BuildRequires: libgtop2-devel
39BuildRequires: libX11-devel
40BuildRequires: startup-notification-devel
41BuildRequires: libgnome-keyring-devel
42BuildRequires: GConf2-devel
43BuildRequires: gtk2-devel
44BuildRequires: libglade2-devel
45BuildRequires: perl-XML-Parser
46BuildRequires: desktop-file-utils
47BuildRequires: autoconf213
48
49%description
50GKSu is a library that provides a Gtk+ frontend to su and sudo. It
51supports login shells and preserving environment when acting as a su
52 frontend. It is useful to menu items or other graphical programs
53that need to ask a user's password to run another program as another user.
54
55%package devel
56Summary: Development package for %{name}
57Group: Development/Libraries
58Requires: %{name} = %{version}
59
60%description devel
61Development package for %{name}
62
63GKSu is a library that provides a Gtk+ frontend to su and sudo. It
64supports login shells and preserving environment when acting as a su
65 frontend. It is useful to menu items or other graphical programs
66that need to ask a user's password to run another program as another user.
67
68%package -n gksu-utils
69Summary: Utilities package for %{name}
70Group: Applications/System
71Requires: %{name} = %{version}
72
73%description -n gksu-utils
74Utilities package for %{name}
75
76GKSu is a library that provides a Gtk+ frontend to su and sudo. It
77supports login shells and preserving environment when acting as a su
78 frontend. It is useful to menu items or other graphical programs
79that need to ask a user's password to run another program as another user.
80
81# '
82%prep
83%setup -q
84%patch0 -p1 -b .i18n
85%patch1 -p1 -b .ja
86
87%patch9 -p1 -b .multihead
88%patch12 -p1 -b .no_password_dialog
89%patch13 -p1 -b .startup_notification
90%patch14 -p1 -b .polish_startup
91%patch17 -p1 -b .composited_fade
92%patch18 -p0 -b .g_markup_escape_text_for_command
93%patch20 -p1 -b .better_usleep
94%patch21 -p1 -b .composited_rgba_addition
95%patch22 -p1 -b .sudo_keep_env
96%patch30 -p1 -b .revert_forkpty
97
98%patch100 -p1 -b .default-sudo_mode
99%patch101 -p1 -b .vine
100
101## For x86_64, we use /usr/lib64/libgksu/gksu-run-helper
102%__sed -i 's@\(gchar auxcommand\[\] = PREFIX "/\)lib\(/" PACKAGE "/gksu-run-helper";\)@\1%{_lib}\2@' libgksu/libgksu.c
103
104
105cp -f %{SOURCE10} po/ja.po
106
107
108
109%build
110intltoolize -f
111touch README NEWS
112autoreconf-2.13 -f -i
113%configure
114%__make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118make install DESTDIR=$RPM_BUILD_ROOT
119
120sed -i -e 's/Icon=gksu.png/Icon=gksu/g' $RPM_BUILD_ROOT%{_datadir}/applications/*
121desktop-file-install --vendor="" \
122  --remove-category="Application" \
123  --remove-category="AdvancedSettings" \
124  --add-category="Settings" \
125  --add-category="X-GNOME-SystemSettings" \
126  --dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/*
127
128%find_lang %{name}
129
130rm $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post -p /sbin/ldconfig
136%postun -p /sbin/ldconfig
137
138%post -n gksu-utils
139export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
140gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
141
142%preun -n gksu-utils
143if [ "$1" -eq 0 ]; then
144  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
145  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
146fi
147
148%files -f %{name}.lang
149%defattr(-,root,root)
150%{_libdir}/*.so.*
151%{_libdir}/%{name}
152
153%files devel
154%defattr(-,root,root)
155%doc INSTALL ChangeLog AUTHORS
156%{_libdir}/*.so
157%{_includedir}/*
158%{_libdir}/pkgconfig/*
159%{_datadir}/gtk-doc/html/%{name}
160
161%files -n gksu-utils
162%defattr(-,root,root)
163%{_sysconfdir}/gconf/schemas/gksu.schemas
164%{_bindir}/gksu-properties
165%{_datadir}/applications/gksu-properties.desktop
166%{_datadir}/libgksu/gksu-properties.ui
167%{_datadir}/pixmaps/gksu.png
168%{_mandir}/man1/gksu-properties.1*
169
170%changelog
171* Sun May 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.12-3
172- rebuild with libgtop2-2.30.0
173- add Patch101 (libgksu-2.0.12-makefile-vine.patch)
174- add BuildRequires: autoconf213, libX11-devel
175
176* Wed Jun 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-2
177- add patch30 from ubuntu
178  + revert the upstream change to run sudo in a forkpty()
179    environment, this is incompatible with our default sudo
180    tty_tickets configuration
181
182* Tue Jun 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-1
183- update to 2.0.12
184- add patch100 to enable sudo_mode by default.
185- add BR: libgnome-keyring-devel
186
187* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.9-5
188- rebuilt with rpm-4.8.1 for pkg-config
189
190* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.9-4
191- add Categories=X-GNOME-SystemSettings for .desktop
192
193* Wed Jun 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0.9-3
194- use /usr/lib64/libgksu/gksu-run-helper for x86_64
195
196* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-2
197- import Patch9-22 from ubuntu
198  - Patch9: fix multihead
199  - Patch12: don't show password dialog if no password was needed
200  - Patch13: make startup notification more reliable
201  - Patch14: improve startup notification messages
202  - Patch17: nicer fadeout on composited display
203  - Patch18: fix missing g_markup_escape when commands are displayed
204  - Patch20: add small usleep() to avoid race condition when
205             the hostname can not be resolved.
206  - Patch21: bling
207  - Patch22: If gksudo -k is used, pass the -E option to sudo
208             to preserve the environment if we're allowed to do so
209- update ja.po
210
211* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-1
212- new upstream release
213- remove static library
214
215* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.7-1
216- new upstream release
217- new versioning policy
218
219* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-0vl1
220- initial build for Vine Linux
221
222* Tue Jul 03 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.5-1mdv2008.0
223+ Revision: 47621
224- new version
225
226* Fri Jun 22 2007 Thierry Vignaud <tvignaud@mandriva.com> 2.0.4-2mdv2008.0
227+ Revision: 43013
228- remove "AdvancedSettings" category from menu
229- kill X-MandrivaLinux-System-Configuration-Other
230- fix group
231
232
233* Tue Mar 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.4-1mdv2007.0
234+ Revision: 134081
235- New version 2.0.4
236- disable gtk-doc (build problem)
237
238* Tue Feb 20 2007 G旦tz Waschk <waschk@mandriva.org> 2.0.3-5mdv2007.1
239+ Revision: 123029
240- fix scripts
241
242* Sat Jan 27 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-4mdv2007.1
243+ Revision: 114416
244- xdg menu
245  handles gconf schemas
246
247* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-3mdv2007.1
248+ Revision: 104863
249- fix provides
250
251* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-2mdv2007.1
252+ Revision: 104797
253- rebuild
254
255* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-1mdv2007.1
256+ Revision: 104663
257- buildrequires perl-XML-Parser
258- buildrequires libglade2.0-devel
259- buildrequires libGConf2-devel
260  buildrequires gtk+2-devel
261- buildrequires startup-notification-devel
262  gnome-keyring-devel
263- New version 2.0.3
264  fix provides
265  buildrequires libgtop2.0-devel
266
267  + J辿r担me Soyer <saispo@mandriva.org>
268    - Import libgksu
269
Note: See TracBrowser for help on using the repository browser.