source: projects/specs/trunk/lib/libg/libgksu/libgksu-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: GKSu libraries
2SUmmary(ja): GKSu ライブラリ
3Name: libgksu
4Version: 2.0.9
5Release: 4%{?_dist_release}
6Url: http://www.nongnu.org/gksu/
7Group: System Environment/Libraries
8License: GPL
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14Source: http://people.debian.org/~kov/gksu/%{name}-%{version}.tar.gz
15Source10: libgksu-2.0.9-ja.po
16Patch0: libgksu-2.0.5-i18n.patch
17Patch1: libgksu-2.0.9-ja.patch
18
19# patches from ubuntu
20Patch9: libgksu-2.0.9-multihead.patch
21Patch12: libgksu-2.0.9-no_password_dialog.patch
22Patch13: libgksu-2.0.9-startup_notification.diff
23Patch14: libgksu-2.0.9-polish_startup.diff
24Patch17: libgksu-2.0.9-composited_fade.patch
25Patch18: libgksu-2.0.9-g_markup_escape_text_for_command.patch
26Patch20: libgksu-2.0.9-better_usleep.patch
27Patch21: libgksu-2.0.9-composited_rgba_addition.patch
28Patch22: libgksu-2.0.9-sudo_keep_env.patch
29
30BuildRoot: %{_tmppath}/%{name}-buildroot
31BuildRequires: glib2-devel
32BuildRequires: gtk-doc
33BuildRequires: libgtop2-devel
34BuildRequires: startup-notification-devel
35BuildRequires: gnome-keyring-devel
36BuildRequires: GConf2-devel
37BuildRequires: gtk2-devel
38BuildRequires: libglade2-devel
39BuildRequires: perl-XML-Parser
40BuildRequires: desktop-file-utils
41
42%description
43GKSu is a library that provides a Gtk+ frontend to su and sudo. It
44supports login shells and preserving environment when acting as a su
45 frontend. It is useful to menu items or other graphical programs
46that need to ask a user's password to run another program as another user.
47
48%package devel
49Summary: Development package for %{name}
50Group: Development/Libraries
51Requires: %{name} = %{version}
52
53%description devel
54Development package for %{name}
55
56GKSu is a library that provides a Gtk+ frontend to su and sudo. It
57supports login shells and preserving environment when acting as a su
58 frontend. It is useful to menu items or other graphical programs
59that need to ask a user's password to run another program as another user.
60
61%package -n gksu-utils
62Summary: Utilities package for %{name}
63Group: Applications/System
64Requires: %{name} = %{version}
65
66%description -n gksu-utils
67Utilities package for %{name}
68
69GKSu is a library that provides a Gtk+ frontend to su and sudo. It
70supports login shells and preserving environment when acting as a su
71 frontend. It is useful to menu items or other graphical programs
72that need to ask a user's password to run another program as another user.
73
74# '
75%prep
76%setup -q
77%patch0 -p1 -b .i18n
78%patch1 -p1 -b .ja
79
80%patch9 -p1 -b .multihead
81%patch12 -p1 -b .no_password_dialog
82%patch13 -p1 -b .startup_notification
83%patch14 -p1 -b .polish_startup
84%patch17 -p1 -b .composited_fade
85%patch18 -p0 -b .g_markup_escape_text_for_command
86%patch20 -p1 -b .better_usleep
87%patch21 -p1 -b .composited_rgba_addition
88%patch22 -p1 -b .sudo_keep_env
89
90## For x86_64, we use /usr/lib64/libgksu/gksu-run-helper
91%__sed -i 's@\(gchar auxcommand\[\] = PREFIX "/\)lib\(/" PACKAGE "/gksu-run-helper";\)@\1%{_lib}\2@' libgksu/libgksu.c
92
93
94cp -f %{SOURCE10} po/ja.po
95
96
97
98%build
99intltoolize -f
100touch README NEWS
101autoreconf -f -i
102%configure
103%__make %{?_smp_mflags}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107%makeinstall
108
109sed -i -e 's/Icon=gksu.png/Icon=gksu/g' $RPM_BUILD_ROOT%{_datadir}/applications/*
110desktop-file-install --vendor="" \
111  --remove-category="Application" \
112  --remove-category="AdvancedSettings" \
113  --add-category="Settings" \
114  --add-category="X-GNOME-SystemSettings" \
115  --dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/*
116
117%find_lang %{name}
118
119rm $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%post -n gksu-utils
128export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
129gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
130
131%preun -n gksu-utils
132if [ "$1" -eq 0 ]; then
133  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
134  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
135fi
136
137%files -f %{name}.lang
138%defattr(-,root,root)
139%{_libdir}/*.so.*
140%{_libdir}/%{name}
141
142%files devel
143%defattr(-,root,root)
144%doc INSTALL ChangeLog AUTHORS
145%{_libdir}/*.so
146%{_includedir}/*
147%{_libdir}/pkgconfig/*
148%{_datadir}/gtk-doc/html/%{name}
149
150%files -n gksu-utils
151%defattr(-,root,root)
152%{_sysconfdir}/gconf/schemas/gksu.schemas
153%{_bindir}/gksu-properties
154%{_datadir}/applications/gksu-properties.desktop
155%{_datadir}/libgksu/gksu-properties.glade
156%{_datadir}/pixmaps/gksu.png
157
158%changelog
159* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.9-4
160- add Categories=X-GNOME-SystemSettings for .desktop
161
162* Thu Jun 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0.9-3
163- use /usr/lib64/libgksu/gksu-run-helper for x86_64
164
165* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-2
166- import Patch9-22 from ubuntu
167  - Patch9: fix multihead
168  - Patch12: don't show password dialog if no password was needed
169  - Patch13: make startup notification more reliable
170  - Patch14: improve startup notification messages
171  - Patch17: nicer fadeout on composited display
172  - Patch18: fix missing g_markup_escape when commands are displayed
173  - Patch20: add small usleep() to avoid race condition when
174             the hostname can not be resolved.
175  - Patch21: bling
176  - Patch22: If gksudo -k is used, pass the -E option to sudo
177             to preserve the environment if we're allowed to do so
178- update ja.po
179
180* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-1
181- new upstream release
182- remove static library
183
184* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.7-1
185- new upstream release
186- new versioning policy
187
188* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-0vl1
189- initial build for Vine Linux
190
191* Tue Jul 03 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.5-1mdv2008.0
192+ Revision: 47621
193- new version
194
195* Fri Jun 22 2007 Thierry Vignaud <tvignaud@mandriva.com> 2.0.4-2mdv2008.0
196+ Revision: 43013
197- remove "AdvancedSettings" category from menu
198- kill X-MandrivaLinux-System-Configuration-Other
199- fix group
200
201
202* Tue Mar 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.4-1mdv2007.0
203+ Revision: 134081
204- New version 2.0.4
205- disable gtk-doc (build problem)
206
207* Tue Feb 20 2007 G旦tz Waschk <waschk@mandriva.org> 2.0.3-5mdv2007.1
208+ Revision: 123029
209- fix scripts
210
211* Sat Jan 27 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-4mdv2007.1
212+ Revision: 114416
213- xdg menu
214  handles gconf schemas
215
216* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-3mdv2007.1
217+ Revision: 104863
218- fix provides
219
220* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-2mdv2007.1
221+ Revision: 104797
222- rebuild
223
224* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-1mdv2007.1
225+ Revision: 104663
226- buildrequires perl-XML-Parser
227- buildrequires libglade2.0-devel
228- buildrequires libGConf2-devel
229  buildrequires gtk+2-devel
230- buildrequires startup-notification-devel
231  gnome-keyring-devel
232- New version 2.0.3
233  fix provides
234  buildrequires libgtop2.0-devel
235
236  + J辿r担me Soyer <saispo@mandriva.org>
237    - Import libgksu
238
Note: See TracBrowser for help on using the repository browser.