source: projects/specs/trunk/lib/libg/libghc-aeson/libghc-aeson-vl.spec @ 11634

Revision 11634, 2.5 KB checked in by ara_t, 6 years ago (diff)

libghc-*: rebuild with ghc-8.4.2

Line 
1%define pkg_name    aeson
2%define pkg_version 1.3.1.1
3%define pkg_release 1%{?_dist_release}
4
5Summary: Haskell libraries: %{pkg_name} and dependent libraries
6Name:    libghc-%{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: base-compat-0.10.1.tar.gz
17Source12: base-compat.cabal
18Source13: th-abstraction-0.2.6.0.tar.gz
19Source14: th-abstraction.cabal
20Source15: time-locale-compat-0.1.1.4.tar.gz
21Source16: time-locale-compat.cabal
22Source17: transformers-compat-0.6.2.tar.gz
23Source18: transformers-compat.cabal
24Source19: uuid-types-1.0.3.tar.gz
25Source20: uuid-types.cabal
26Source21: tagged-0.8.5.tar.gz
27Source22: tagged.cabal
28Source23: aeson-1.3.1.1.tar.gz
29Source24: aeson.cabal
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33BuildRequires: ghc haskell-platform
34BuildRequires: libffi-devel gmp-devel zlib-devel
35BuildRequires: libghc-dlist
36BuildRequires: libghc-old-locale
37
38BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
39
40Requires: ghc haskell-platform
41Requires: haskell-platform-dep
42Requires: libghc-dlist
43Requires: libghc-old-locale
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: ara_t
48
49
50%description
51Haskell libraries: %{pkg_name}
52
53
54%prep
55%{__rm} -rf ${RPM_BUILD_ROOT}
56
57%build
58%ghc_pkg_init
59
60cd %{_builddir}
61for pkg in `cat %{SOURCE0}`; do
62    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
63    pushd ${pkg}
64        %ghc_fix_dependencies ${pkg}
65        %cabal_configure2 %{name} ${pkg}
66        %cabal_build
67        %cabal_haddock
68        %cabal_copy_resister %{name}_${pkg}
69    popd
70done
71
72
73%install
74# copy documents
75pushd %{_builddir}/%{pkg_name}-%{version}
76    %{__cp} changelog.md README.markdown \
77     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
78popd
79
80
81%clean
82%{__rm} -rf ${RPM_BUILD_ROOT}
83
84%post
85%ghc_pkg_recache
86
87%postun
88%ghc_pkg_recache
89
90
91%files
92%defattr(-, root, root)
93%{_libdir}/ghc-%{ghc_version}/
94%{_libdir}/ghc-lib/
95%{_datadir}/
96
97
98%changelog
99* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-1
100- update to 1.3.1.1
101- rebuild using ghc-8.4.2
102- rewrite using macro
103
104* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 1.2.3.0-1
105- update to 1.2.3.0
106- build using ghc-8.2.2
107
108* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.11.3.0-1
109- update to 0.11.3.0
110- build using ghc-8.0.1
111
112* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-3
113- rebuilt
114
115* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-2
116- correct SPEC file
117
118* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-1
119- new package
Note: See TracBrowser for help on using the repository browser.