source: projects/specs/trunk/lib/libg/libghc-aeson/libghc-aeson-vl.spec @ 11988

Revision 11988, 2.7 KB checked in by ara_t, 5 years ago (diff)

libghc-*: (re)build with ghc-8.6.3

Line 
1%define pkg_name    aeson
2%define pkg_version 1.4.2.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: Haskell libraries: %{pkg_name} and dependent libraries
6Name:    libghc-%{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: base-compat-0.10.5.tar.gz
17Source12: base-compat.cabal
18Source13: tagged-0.8.6.tar.gz
19Source14: tagged.cabal
20Source15: th-abstraction-0.2.8.0.tar.gz
21Source16: th-abstraction.cabal
22Source17: time-locale-compat-0.1.1.5.tar.gz
23Source18: time-locale-compat.cabal
24Source19: uuid-types-1.0.3.tar.gz
25Source20: uuid-types.cabal
26Source21: aeson-1.4.2.0.tar.gz
27Source22: aeson.cabal
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31BuildRequires: ghc haskell-platform
32BuildRequires: libffi-devel gmp-devel zlib-devel
33BuildRequires: libghc-dlist
34BuildRequires: libghc-old-locale
35
36BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
37
38Requires: ghc haskell-platform
39Requires: haskell-platform-dep
40Requires: libghc-dlist
41Requires: libghc-old-locale
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: ara_t
46
47
48%description
49Haskell libraries: %{pkg_name}
50
51
52%prep
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55%build
56%ghc_pkg_init
57
58cd %{_builddir}
59for pkg in `cat %{SOURCE0}`; do
60    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
61    pushd ${pkg}
62        %ghc_fix_dependencies ${pkg}
63        %cabal_configure2 %{name} ${pkg}
64        %cabal_build
65        %cabal_haddock
66        %cabal_copy_resister %{name}_${pkg}
67    popd
68done
69
70
71%install
72# copy documents
73pushd %{_builddir}/%{pkg_name}-%{version}
74    %{__cp} changelog.md README.markdown \
75     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
76popd
77
78
79%clean
80%{__rm} -rf ${RPM_BUILD_ROOT}
81
82%post
83%ghc_pkg_recache
84
85%postun
86%ghc_pkg_recache
87
88
89%files
90%defattr(-, root, root)
91%{_libdir}/ghc-%{ghc_version}/
92%{_libdir}/ghc-lib/
93%{_datadir}/
94
95
96%changelog
97* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 1.4.2.0-1
98- update to 1.4.2.0
99- build using ghc-8.6.3
100
101* Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-3
102- build with ghc-8.4.3-2
103
104* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-2
105- build using ghc-8.4.3
106
107* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.3.1.1-1
108- update to 1.3.1.1
109- rebuild using ghc-8.4.2
110- rewrite using macro
111
112* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 1.2.3.0-1
113- update to 1.2.3.0
114- build using ghc-8.2.2
115
116* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.11.3.0-1
117- update to 0.11.3.0
118- build using ghc-8.0.1
119
120* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-3
121- rebuilt
122
123* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-2
124- correct SPEC file
125
126* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.9.0.1-1
127- new package
Note: See TracBrowser for help on using the repository browser.