source: projects/specs/trunk/lib/libg/libgda/libgda-vl.spec @ 10291

Revision 10291, 15.0 KB checked in by Takemikaduchi, 8 years ago (diff)

gnubiff,httping,lftp,libarchive,libgadu,libgit2,mosh: new upstream release
others: rebuild

Line 
1%define major   5
2%define minor   2
3%define micro   4
4%define version %{major}.%{minor}.%{micro}
5
6%define __libtoolize :
7# Default provider build options (MySQL, Postgres & unixODBC)
8#
9# Package build options:
10# --with tds
11# --with db2
12# --with oracle
13# --without sqlite
14# --with sybase
15# --with mdb
16# --without ldap
17# --without mysql
18# --without odbc
19# --without postgres
20#
21
22%define           FREETDS  0
23%define           IBMDB2   0
24%define           MYSQL    1
25%define           ODBC     0
26%define           ORACLE   0
27%define           POSTGRES 1
28%define           SQLITE   1
29%define           SYBASE   0
30%define           MDB      0
31%define           LDAP     0
32
33%{?_with_tds:%define FREETDS    1}
34%{?_with_db2:%define IBMDB2     1}
35%{?_without_ldap:%define LDAP   0}
36%{?_with_mdb:%define MDB        1}
37%{?_with_oracle:%define ORACLE  1}
38%{?_without_sqlite:%define SQLITE 0}
39%{?_with_sybase:%define SYBASE  1}
40%{?_without_mysql:%define MYSQL 0}
41%{?_without_odbc:%define ODBC   0}
42%{?_without_postgres:%define POSTGRES   0}
43
44%define libver  5.0
45
46Summary:        A (relatively small) database access library
47Name:           libgda
48Version:        %{version}
49Release:        2%{?_dist_release}
50Source:         %{name}-%{version}.tar.xz
51URL:            http://www.gnome-db.org/
52Group:          System Environment/Libraries
53License:        LGPL
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55Summary(ja):    比較的小規模なデータベース接続ライブラリ
56
57Patch0:         libgda-4.2.0-disable-mdb.patch
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: yasumichi
62
63BuildRequires:  pkgconfig       >= 0.8
64BuildRequires:  intltool        >= 0.35.5
65BuildRequires:  glib2-devel     >= 2.12.0
66BuildRequires:  gtk3-devel
67BuildRequires:  gobject-introspection-devel
68BuildRequires:  libxml2-devel
69BuildRequires:  libxslt-devel >= 1.0.9
70BuildRequires:  db4-devel ncurses-devel
71BuildRequires:  gamin-devel >= 0.1.8
72BuildRequires:  libgcrypt-devel >= 1.1.42
73BuildRequires:  gtksourceview3-devel
74BuildRequires:  libsoup-devel
75BuildRequires:  libsecret-devel
76BuildRequires:  iso-codes
77BuildRequires:  yelp-tools
78
79%if %{FREETDS}
80BuildRequires:    freetds-devel
81%endif
82
83%if %{MYSQL}
84BuildRequires:    MySQL-devel
85%endif
86
87%if %{POSTGRES}
88BuildRequires:    libpq-devel
89%endif
90
91%if %{ODBC}
92BuildRequires:    unixODBC-devel
93%endif
94
95%if %{SQLITE}
96BuildRequires:    sqlite3-devel
97%endif
98
99%if %{MDB}
100BuildRequires:    mdbtools-devel
101%endif
102
103%if %{LDAP}
104BuildRequires:    openldap-devel
105%endif
106
107%description
108Libgda is a (relatively small) database access library:
109 - a wrapper like ODBC but with more features to access several database
110   engines
111 - a meta data extractor (to know all about database objects in a common
112   way)
113 - comes with an SQL console application (like mysql, psql or sqlite3
114   consoles)
115 - relies on GLib, coded in C, its API is easy to use
116 - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
117   is in progress for other database types (such as Firebird and Oracle) and
118   to wrap JDBC for more wider usage.
119     
120Build option is:
121 --with mysql postgres sqlite
122 --without tds ibmdb2 ldap mdb odbc oracle sybase
123
124%package devel
125Summary:          Development libraries and header files for libgda.
126Group:            Development/Libraries
127Requires:         %{name} = %{version}
128Requires:         glib2-devel   >= 2.12.0
129Requires:         libxml2-devel
130Requires:         libxslt-devel >= 1.0.9
131
132%description devel
133This package contains the header files and libraries needed to write
134or compile programs that use libgda.
135
136
137#%package sharp
138#Summary:          Mono bindings for libgda
139#Group:            System Environment/Libraries
140#Requires:         %{name} = %{version}-%{release}
141#Requires:         mono-core
142#
143#%description sharp
144#This package contains the dll files needed to run (and compile) Mono
145#applications which use libgda.
146
147
148%if %{FREETDS}
149%package -n gda-freetds
150Summary:        GDA FreeTDS Provider
151Group:          System Environment/Libraries
152%description -n gda-freetds
153This package includes the GDA FreeTDS provider.
154%endif
155
156%if %{IBMDB2}
157%package -n gda-ibmdb2
158Summary:        GDA IBM DB2 Provider
159Group:          System Environment/Libraries
160%description -n gda-ibmdb2
161This package includes the GDA IBM DB2 provider.
162%endif
163
164%if %{MYSQL}
165%package -n gda-mysql
166Summary:        GDA MySQL Provider
167Group:          System Environment/Libraries
168%description -n gda-mysql
169This package includes the GDA MySQL provider.
170%endif
171
172%if %{ODBC}
173%package -n gda-odbc
174Summary:        GDA ODBC Provider
175Group:          System Environment/Libraries
176%description -n gda-odbc
177This package includes the GDA ODBC provider.
178%endif
179
180%if %{ORACLE}
181%package -n gda-oracle
182Summary:        GDA Oracle Provider
183Group:          System Environment/Libraries
184%description -n gda-oracle
185This package includes the GDA Oracle provider.
186%endif
187
188%if %{POSTGRES}
189%package -n gda-postgres
190Summary:        GDA PostgreSQL Provider
191Group:          System Environment/Libraries
192%description -n gda-postgres
193This package includes the GDA PostgreSQL provider.
194%endif
195
196%if %{SQLITE}
197%package -n gda-sqlite
198Summary:        GDA SQLite Provider
199Group:          System Environment/Libraries
200%description -n gda-sqlite
201This package includes the GDA SQLite provider.
202%endif
203
204%if %{SYBASE}
205%package -n gda-sybase
206Summary:        GDA Sybase Provider
207Group:          System Environment/Libraries
208%description -n gda-sybase
209This package includes the GDA Sybase provider.
210%endif
211
212%if %{MDB}
213%package -n gda-mdb
214Summary:        GDA MDB Provider
215Group:          System Environment/Libraries
216%description -n gda-mdb
217This package includes the GDA MDB provider.
218%endif
219
220%if %{LDAP}
221%package -n gda-ldap
222Summary:        GDA LDAP Provider
223Group:          System Environment/Libraries
224%description -n gda-ldap
225This package includes the GDA LDAP provider.
226%endif
227
228%prep
229%setup -q -n %{name}-%{version}
230%patch0 -p1 -b .mdb
231
232%build
233%if %{FREETDS}
234CONFIG="$CONFIG --with-tds"
235%else
236CONFIG="$CONFIG --without-tds"
237%endif
238
239%if %{IBMDB2}
240CONFIG="$CONFIG --with-ibmdb2"
241%else
242CONFIG="$CONFIG --without-ibmdb2"
243%endif
244
245%if %{MYSQL}
246CONFIG="$CONFIG --with-mysql"
247%else
248CONFIG="$CONFIG --without-mysql"
249%endif
250
251%if %{POSTGRES}
252CONFIG="$CONFIG --with-postgres"
253%else
254CONFIG="$CONFIG --without-postgres"
255%endif
256
257%if %{ODBC}
258CONFIG="$CONFIG --with-odbc"
259%else
260CONFIG="$CONFIG --without-odbc"
261%endif
262
263%if %{ORACLE}
264CONFIG="$CONFIG --with-oracle"
265%else
266CONFIG="$CONFIG --without-oracle"
267%endif
268
269%if %{SQLITE}
270CONFIG="$CONFIG --with-sqlite"
271%else
272CONFIG="$CONFIG --without-sqlite"
273%endif
274
275%if %{SYBASE}
276CONFIG="$CONFIG --with-sybase"
277%else
278CONFIG="$CONFIG --without-sybase"
279%endif
280
281%if %{MDB}
282CONFIG="$CONFIG --with-mdb"
283%else
284CONFIG="$CONFIG --without-mdb"
285%endif
286
287%if %{LDAP}
288CONFIG="$CONFIG --with-ldap"
289%else
290CONFIG="$CONFIG --without-ldap"
291%endif
292
293%configure $CONFIG \
294        --disable-static \
295        --enable-introspection \
296        --disable-gtk-doc \
297        --with-libdir-name=%{_lib}
298make
299
300%install
301rm -rf $RPM_BUILD_ROOT
302#makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
303make install DESTDIR=$RPM_BUILD_ROOT
304
305#fixup mono / sharp related files install
306#mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
307#mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
308#mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
309#mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
310#rmdir %{buildroot}/%{_libdir}/libgda
311
312# Cleanup unnecessary, unpackaged files
313find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
314rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
315
316%find_lang libgda-%{libver}
317
318%post -p /sbin/ldconfig
319
320%postun -p /sbin/ldconfig
321
322%clean
323rm -rf $RPM_BUILD_ROOT
324
325
326%files
327%defattr(-,root,root)
328%doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
329%dir %{_sysconfdir}/libgda-%{libver}
330%config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
331%{_bindir}/*
332%{_libdir}/*.so.*
333%{_libdir}/girepository-1.0/Gda-5.0.typelib
334
335%dir %{_libdir}/libgda-%{libver}
336%dir %{_libdir}/libgda-%{libver}/plugins
337%{_libdir}/libgda-%{libver}/plugins/*.xml
338%{_libdir}/libgda-%{libver}/plugins/libgda-ui-plugins.so
339%dir %{_libdir}/libgda-%{libver}/providers
340%{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
341%{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
342%{_libdir}/libgda-%{libver}/providers/libgda-web.so
343
344%{_datadir}/appdata/gda-browser-5.0.appdata.xml
345%{_datadir}/applications/*.desktop
346%{_datadir}/icons/hicolor/*/*/*
347%{_datadir}/pixmaps/gda-browser-5.0.png
348%{_datadir}/help/*/gda-browser
349
350%dir %{_datadir}/libgda-%{libver}
351%{_datadir}/libgda-%{libver}/demo
352%{_datadir}/libgda-%{libver}/dtd
353%{_datadir}/libgda-%{libver}/gda_trml2html
354%{_datadir}/libgda-%{libver}/gda_trml2pdf
355%{_datadir}/libgda-%{libver}/icons
356%{_datadir}/libgda-%{libver}/language-specs/gda-sql.lang
357%{_datadir}/libgda-%{libver}/php
358%{_datadir}/libgda-%{libver}/pixmaps
359%{_datadir}/libgda-%{libver}/server_operation.glade
360%{_datadir}/libgda-%{libver}/ui
361%{_datadir}/libgda-%{libver}/*.xml
362%{_datadir}/libgda-%{libver}/web
363
364%{_mandir}/man1/*
365%{_datadir}/locale/*/LC_MESSAGES/*
366
367%files devel
368%defattr(-,root,root)
369%{_includedir}/libgda-%{libver}
370%{_libdir}/*.so
371%{_libdir}/pkgconfig/*
372%{_datadir}/gir-1.0/Gda-5.0.gir
373%{_datadir}/gtk-doc/html/*
374
375#files sharp
376#defattr(-,root,root)
377#{_datadir}/gapi-2.0
378#/usr/lib/mono/gda-sharp-2.0
379#{_libdir}/pkgconfig/gda-sharp-2.0.pc
380
381%if %{FREETDS}
382%files -n gda-freetds
383%{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
384%endif
385
386%if %{IBMDB2}
387%files -n gda-ibmdb2
388%{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
389%endif
390
391%if %{MYSQL}
392%files -n gda-mysql
393%{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
394%{_datadir}/libgda-%{libver}/mysql_*.xml
395%endif
396
397%if %{ODBC}
398%files -n gda-odbc
399%{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
400%{_datadir}/libgda-%{libver}/odbc_*.xml
401%endif
402
403%if %{ORACLE}
404%files -n gda-oracle
405%{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
406%endif
407
408%if %{POSTGRES}
409%files -n gda-postgres
410%{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
411%{_datadir}/libgda-%{libver}/postgres_*.xml
412%endif
413
414%if %{SQLITE}
415%files -n gda-sqlite
416%{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
417%{_datadir}/libgda-%{libver}/sqlite_*.xml
418%endif
419
420%if %{SYBASE}
421%files -n gda-sybase
422%{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
423%endif
424
425%if %{MDB}
426%files -n gda-mdb
427%{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
428%endif
429
430%if %{LDAP}
431%files -n gda-ldap
432%{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
433%{_datadir}/libgda-%{libver}/ldap_*.xml
434%endif
435
436
437%changelog
438* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.4-2
439- rebuild with openssl-1.0.2
440
441* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.4-1
442- new upstream release
443
444* Sat Jul 19 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.2.2-2
445- rebuild with libpq-devel instead of postgresql-devel
446
447* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.2-1
448- new upstream release
449
450* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.1-1
451- new upstream release
452- add BuildRequires: yelp-tools
453
454* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.2-1
455- new upstream release
456
457* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.1-1
458- new upstream release
459- add BuildRequires: gtksourceview3-devel, libsoup-devel, libsecret-devel
460- remove BuildRequires: gcr-devel
461
462* Tue Apr 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.3-1
463- new upstream release
464- add BuildRequires: gtk3-devel, gobject-introspection-devel, gcr-devel, iso-codes
465
466* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.12-1
467- new upstream release
468
469* Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.11-1
470- new upstream release
471
472* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
473- new upstream release
474
475* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
476- new upstream release
477
478* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
479- new upstream release
480- add Patch0 (libgda-4.2.0-disable-mdb.patch)
481- change %%{libver}
482
483* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
484- rebuild with rpm-4.8.1 for pkg-config file
485
486* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
487- new upstream release
488
489* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
490- new upstream release
491
492* Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
493- new upstream release
494- remove gnome-vfs2-devel from BR.(use gio-2.0)
495- add Vendor, Distribution and Packager.
496- update summary and description.
497
498* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
499- rebuilt with postgresql-8.4.0
500
501* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
502- added intltool to BuildRequires.
503- rebuilt with MySQL-5.1.34.
504
505* Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
506- update from upstream.
507- update description and files.
508- ODBC,LDAP outdated
509
510* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
511- rebuilt with postgresql-8.3.3
512
513* Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
514- new upstream release
515- not build sharp subpackage
516- built with db4-4.6.21, MySQL-5.0.51a
517
518* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
519- rebuilt with postgresql-8.2.6
520
521* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
522- rebuilt with postgresql-8.2.5
523
524* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
525- rebuilt with new toolchain
526
527* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
528- rebuilt with openldap 2.3.27, MySQL 5.0.27
529- added Patch0 from Fedora
530
531* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
532- rebuilt with openldap-devel-2.3.24-0vl4
533
534* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
535- rebuilt with gamin-devel in place of fam-devel
536
537* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
538- rebuilt with readline 5.1
539- added subpackage for Mono binding
540
541* Mon Jan  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
542- new upstream release
543
544* Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
545- new upstream release
546- rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
547
548* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
549- new upstream release
550- fixed %files on devel package
551
552* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
553- new upstream release
554- re-define __libtoolize to compile shared object
555- updated summary
556- make sqlite package by default
557
558* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
559- new upstream release
560- build with new MySQL
561- make ldap package by default
562
563* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
564- new upstream release
565
566* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
567- new upstream release
568
569* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
570- updated to 1.0.0
571- based on original spec
572- disabled smp_flag at compile time
573
574* Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
575- added BuildPreReq: bonobo >= 1.0.9
576  (0.2.96-0vl2 seems to be lost by accident, so putting again here)
577
578* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
579- New upstream release.
580- use gcc-2.95.3 and g++-2.95.3
581
582* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
583- New upstream release.
584
585* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
586- Rebuild for Vine.
587
588* Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
589- Cleaned
590
591* Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
592- Initial spec imported from old GNOME-DB spec
593
Note: See TracBrowser for help on using the repository browser.