source: projects/specs/trunk/lib/libe/libexo/libexo-vl.spec @ 3330

Revision 3330, 6.1 KB checked in by Takemikaduchi, 13 years ago (diff)

fix: failed to build package

Line 
1%define srcname exo
2
3Summary: extension library to Xfce
4Summary(ja): Xfce の拡張ライブラリ
5Name: libexo
6Version: 0.6.0
7Release: 2%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2
11URL: http://www.xfce.org/
12
13Source0: http://www.xfce.org/archive/xfce-%{version}/src/%{srcname}-%{version}.tar.bz2
14# FIXME: upstream this patch
15Patch0:        exo-0.5.4-x86_64-build.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= 2.27.0
19BuildRequires: gtk2-devel >= 2.14.0
20BuildRequires: libSM-devel
21BuildRequires: intltool >= 0.31
22BuildRequires: libxfce4util-devel >= 4.8.0
23BuildRequires: libnotify-devel >= 0.4.0
24BuildRequires: python-devel
25BuildRequires: pygtk2-devel
26BuildRequires: perl-URI
27BuildRequires: chrpath
28Requires(post): gtk2
29Requires(postun): gtk2
30
31Provides: %{srcname} = %{version}-%{release}
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37libexo is the extension library to Xfce developed by os-cillation.
38While Xfce ships with quite a few libraries that are primarly targeted
39at desktop development, libexo is targeted at application development,
40with a focus on applications for Xfce.
41
42%description -l ja
43libexo は os-cillation により開発された Xfce の拡張ライブラリです.
44Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
45と共に作成されていますが,libexo はアプリケーションの開発,それも
46Xfce 用のアプリケーション開発に焦点を定めています.
47
48%package -n %{name}-devel
49Summary: Header files and libraries for developing apps which will use %{name}
50Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: gtk2-devel >= 2.6.0
54Requires: libxfce4util-devel >= 4.2.2
55Provides: %{srcname}-devel = %{version}-%{release}
56
57%description -n %{name}-devel
58The libexo-devel package contains the header files and libraries needed
59to develop programs that use the libexo library.
60
61%description -n %{name}-devel -l ja
62libexo-develはlibexoライブラリを用いるプログラムの開発に
63必要なヘッダファイル及びライブラリを含むパッケージです。
64
65%prep
66%setup -q -n %{srcname}-%{version}
67%patch0 -p1 -b .x86_64-build
68
69%build
70%configure --disable-static
71%__make
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
76
77rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
78rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
79
80chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
81chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
82chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
83chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
84#chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
85
86rm -rf _docs_to_include
87mkdir -p _docs_to_include
88mv $RPM_BUILD_ROOT%{_docdir}/exo/html _docs_to_include/
89rm -rf $RPM_BUILD_ROOT%{_docdir}/exo
90
91%find_lang exo-1
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post
97/sbin/ldconfig
98touch --no-create %{_datadir}/icons/hicolor
99
100%postun
101/sbin/ldconfig
102if [ $1 -eq 0 ]; then
103    touch --no-create %{_datadir}/icons/hicolor
104    /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
105fi
106
107%posttrans
108gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
109
110
111%files -f exo-1.lang
112%defattr(-,root,root)
113%doc AUTHORS COPYING ChangeLog README THANKS TODO
114%doc _docs_to_include/*
115%config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
116%{_bindir}/*
117%{_libdir}/lib*.so.*
118%{_libdir}/python?.?/site-packages/*
119%{_libdir}/xfce4/*
120%{_datadir}/applications/*.desktop
121%{_datadir}/icons/hicolor/*/apps/*.png
122%{_datadir}/pixmaps/exo-1
123%{_datadir}/pygtk/2.0/*
124%{_datadir}/xfce4/helpers
125%{_mandir}/man1/*
126
127%files -n %{name}-devel
128%defattr(-,root,root)
129%{_libdir}/lib*.so
130%{_libdir}/pkgconfig/*.pc
131%{_includedir}/exo-1
132%{_datadir}/gtk-doc/html/exo-1
133
134%changelog
135* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
136- add BuildRequires: libSM-devel
137
138* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
139- new upstrem release
140
141* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
142- rebuilt with rpm-4.8.1 for pkg-config
143
144* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
145- new upstrem release
146- built with new toolchain
147
148* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
149- new upstrem release
150- added BR: perl-URI
151
152* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
153- rebuilt with python-2.6.4
154
155* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
156- new upstrem release
157
158* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
159- new upstrem release
160- removed lib*.a from devel package
161
162* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
163- applied with new versioning policy
164- spec in UTF-8
165
166* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
167- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
168
169* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
170- new upstream release.
171
172* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
173- build for VineSeed
174
175* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
176- new upstream version
177- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
178- add %{_bindir}/* in files section.
179- add %{_libdir}/xfce4 in files section.
180- add %{_libexecdir}/* in files section.
181- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
182- add %{_mandir}/man1/* in files section.
183- add %{_datadir}/xfce4/doc/*/* in files section.
184- add %{_datadir}/xfce4/helpers in files section.
185- remove %{_datadir}/gtk-doc/html/exo in files section.
186- update icon-cache in %post and %postun.
187
188* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
189- changed Group to System Environment/Libraires
190- changed devel Group to Development/Libraries
191- added %post and %postun section
192
193* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
194- rebuild for VineSeed
195
196* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
197- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.