source: projects/specs/trunk/lib/libe/libexo/libexo-vl.spec @ 3253

Revision 3253, 5.9 KB checked in by inagaki, 13 years ago (diff)

update: Xfce4

Line 
1%define srcname exo
2
3Summary: extension library to Xfce
4Summary(ja): Xfce の拡張ライブラリ
5Name: libexo
6Version: 0.6.0
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2
11URL: http://www.xfce.org/
12
13Source0: http://www.xfce.org/archive/xfce-%{version}/src/%{srcname}-%{version}.tar.bz2
14# FIXME: upstream this patch
15Patch0:        exo-0.5.4-x86_64-build.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: glib2-devel >= 2.27.0
19BuildRequires: gtk2-devel >= 2.14.0
20BuildRequires: intltool >= 0.31
21BuildRequires: libxfce4util-devel >= 4.8.0
22BuildRequires: libnotify-devel >= 0.4.0
23BuildRequires: python-devel
24BuildRequires: pygtk2-devel
25BuildRequires: perl-URI
26BuildRequires: chrpath
27Requires(post): gtk2
28Requires(postun): gtk2
29
30Provides: %{srcname} = %{version}-%{release}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36libexo is the extension library to Xfce developed by os-cillation.
37While Xfce ships with quite a few libraries that are primarly targeted
38at desktop development, libexo is targeted at application development,
39with a focus on applications for Xfce.
40
41%description -l ja
42libexo は os-cillation により開発された Xfce の拡張ライブラリです.
43Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
44と共に作成されていますが,libexo はアプリケーションの開発,それも
45Xfce 用のアプリケーション開発に焦点を定めています.
46
47%package -n %{name}-devel
48Summary: Header files and libraries for developing apps which will use %{name}
49Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: gtk2-devel >= 2.6.0
53Requires: libxfce4util-devel >= 4.2.2
54Provides: %{srcname}-devel = %{version}-%{release}
55
56%description -n %{name}-devel
57The libexo-devel package contains the header files and libraries needed
58to develop programs that use the libexo library.
59
60%description -n %{name}-devel -l ja
61libexo-develはlibexoライブラリを用いるプログラムの開発に
62必要なヘッダファイル及びライブラリを含むパッケージです。
63
64%prep
65%setup -q -n %{srcname}-%{version}
66%patch0 -p1 -b .x86_64-build
67
68%build
69%configure --disable-static
70%__make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
75
76rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
77rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
78
79chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
80chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
81chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
82chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
83#chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
84
85rm -rf _docs_to_include
86mkdir -p _docs_to_include
87mv $RPM_BUILD_ROOT%{_docdir}/exo/html _docs_to_include/
88rm -rf $RPM_BUILD_ROOT%{_docdir}/exo
89
90%find_lang exo-1
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post
96/sbin/ldconfig
97touch --no-create %{_datadir}/icons/hicolor
98
99%postun
100/sbin/ldconfig
101if [ $1 -eq 0 ]; then
102    touch --no-create %{_datadir}/icons/hicolor
103    /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
104fi
105
106%posttrans
107gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
108
109
110%files -f exo-1.lang
111%defattr(-,root,root)
112%doc AUTHORS COPYING ChangeLog README THANKS TODO
113%doc _docs_to_include/*
114%config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
115%{_bindir}/*
116%{_libdir}/lib*.so.*
117%{_libdir}/python?.?/site-packages/*
118%{_libdir}/xfce4/*
119%{_datadir}/applications/*.desktop
120%{_datadir}/icons/hicolor/*/apps/*.png
121%{_datadir}/pixmaps/exo-1
122%{_datadir}/pygtk/2.0/*
123%{_datadir}/xfce4/helpers
124%{_mandir}/man1/*
125
126%files -n %{name}-devel
127%defattr(-,root,root)
128%{_libdir}/lib*.so
129%{_libdir}/pkgconfig/*.pc
130%{_includedir}/exo-1
131%{_datadir}/gtk-doc/html/exo-1
132
133%changelog
134* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
135- new upstrem release
136
137* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
138- rebuilt with rpm-4.8.1 for pkg-config
139
140* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
141- new upstrem release
142- built with new toolchain
143
144* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
145- new upstrem release
146- added BR: perl-URI
147
148* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
149- rebuilt with python-2.6.4
150
151* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
152- new upstrem release
153
154* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
155- new upstrem release
156- removed lib*.a from devel package
157
158* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
159- applied with new versioning policy
160- spec in UTF-8
161
162* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
163- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
164
165* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
166- new upstream release.
167
168* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
169- build for VineSeed
170
171* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
172- new upstream version
173- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
174- add %{_bindir}/* in files section.
175- add %{_libdir}/xfce4 in files section.
176- add %{_libexecdir}/* in files section.
177- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
178- add %{_mandir}/man1/* in files section.
179- add %{_datadir}/xfce4/doc/*/* in files section.
180- add %{_datadir}/xfce4/helpers in files section.
181- remove %{_datadir}/gtk-doc/html/exo in files section.
182- update icon-cache in %post and %postun.
183
184* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
185- changed Group to System Environment/Libraires
186- changed devel Group to Development/Libraries
187- added %post and %postun section
188
189* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
190- rebuild for VineSeed
191
192* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
193- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.