source: projects/specs/trunk/lib/libe/libev/libev-vl.spec @ 5803

Revision 5803, 5.5 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1%global source_dir  %{_datadir}/%{name}-source
2%global inst_srcdir %{buildroot}/%{source_dir}
3
4Name:           libev
5Version:        4.04
6Release:        1%{?_dist_release}
7Summary:        High-performance event loop/event model with lots of features
8Summary(ja):    ‚‹@”\E‚«”\‚̃Cƒxƒ“ƒgƒ‹[ƒvEƒCƒxƒ“ƒgƒ‚ƒfƒ‹
9Group:          System Environment/Libraries
10License:        BSD or GPLv2+
11URL:            http://software.schmorp.de/pkg/libev.html
12Source0:        http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
13Source1:        %{name}.pc.in
14BuildRequires:  automake libtool
15
16%description
17Libev is modeled (very loosely) after libevent and the Event Perl
18module, but is faster, scales better and is more correct, and also more
19featureful. And also smaller.
20
21%description -l ja
22libev ‚Í libevent ‚¨‚æ‚Ñ Perl ‚Ì Event ‚ð‘å‚Ü‚©‚ÉŽQl‚É‚µ‚čì‚ç‚ê‚Ü‚µ‚½‚ªA
23‚»‚ê‚ç‚æ‚荂‘¬‚É“®ì‚µA‚æ‚èƒXƒP[ƒ‹‚µA‚æ‚萳Šm‚ŁA‚æ‚荂‹@”\‚ŁA
24“¯Žž‚É‚æ‚èƒRƒ“ƒpƒNƒg‚Å‚·B
25
26
27%package        devel
28Summary:        High-performance event loop/event model with lots of features
29Group:          System Environment/Libraries
30Requires:       %{name}%{?_isa} = %{version}-%{release}
31Requires:       pkgconfig
32
33%description    devel
34Libev is modeled (very loosely) after libevent and the Event Perl
35module, but is faster, scales better and is more correct, and also more
36featureful. And also smaller. Development libraries.
37
38%description    devel -l ja
39‚±‚̃pƒbƒP[ƒW‚É‚Í libev —pŠJ”­ƒ‰ƒCƒuƒ‰ƒŠ‚ƃwƒbƒ_‚ªŽû˜^‚³‚ê‚Ä‚¢‚Ü‚·B
40
41
42%package        source
43Summary:        High-performance event loop/event model with lots of features
44Group:          System Environment/Libraries
45%if 0%{?fedora} >= 12 || 0%{?rhel} > 5
46BuildArch:     noarch
47%endif
48
49%description    source
50This package contains the source code for libev.
51
52Libev is modeled (very loosely) after libevent and the Event Perl
53module, but is faster, scales better and is more correct, and also more
54featureful. And also smaller. Development libraries.
55
56%description    source -l ja
57‚±‚̃pƒbƒP[ƒW‚É‚Í libev ‚̃\[ƒXƒR[ƒh‚ªŽû˜^‚³‚ê‚Ä‚¢‚Ü‚·B
58
59
60%prep
61%setup -q
62
63# Add pkgconfig support
64cp -p %{SOURCE1} .
65sed -i.pkgconfig -e 's|Makefile|Makefile libev.pc|' configure.ac configure
66sed -i.pkgconfig -e 's|lib_LTLIBRARIES|pkgconfigdir = $(libdir)/pkgconfig\n\npkgconfig_DATA = libev.pc\n\nlib_LTLIBRARIES|' Makefile.am Makefile.in
67aclocal
68automake
69
70
71%build
72%configure --disable-static --with-pic --includedir=%{_includedir}/%{name}
73make %{?_smp_mflags}
74
75
76%check
77make check
78
79
80%install
81rm -rf %{buildroot}
82make install DESTDIR=%{buildroot} INSTALL="install -p"
83
84rm -rf %{buildroot}%{_libdir}/%{name}.la
85
86# Make the source package
87mkdir -p %{inst_srcdir}
88
89find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
90install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
91
92
93%clean
94rm -rf %{buildroot}
95
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
100
101%files
102%doc Changes LICENSE README
103%{_libdir}/%{name}.so.4
104%{_libdir}/%{name}.so.4.0.0
105
106
107%files devel
108%{_libdir}/%{name}.so
109%{_includedir}/libev/
110%{_libdir}/pkgconfig/%{name}.pc
111%{_mandir}/man?/*
112
113
114%files source
115%{source_dir}
116
117
118%changelog
119* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
120- initial build for Vine Linux
121
122* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
124
125* Tue Aug  9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
126- move man page
127- cleanup spec
128- update to 4.04
129
130* Mon Jun 13 2011 Matěj Cepl <mcepl@redhat.com> - 4.03-2
131- EL5 cannot have noarch subpackages.
132
133* Sat Feb  5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
134- 4.03; RHBZ#674022
135- add a -source subpackage (Mathieu Bridon); RHBZ#672153
136
137* Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
138- 4.01
139- fix grammar in %%description
140
141* Sat Jan  2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
142- 3.9
143
144* Fri Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
145- 3.8
146- always use the most recent automake
147- BuildRequires now libtool
148
149* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
150- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
151
152* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
153- spec file change, which prevented uploading most recent tarball
154  so the RPM was "3.70" but tarball was from 3.60
155
156* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
157- v3.7
158- list libev soname explicitly
159
160* Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
161- previous version was called "3.6" but this is broken update
162  path wrt version "3.53" -- thus bumping to "3.60"
163
164* Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
165- 3.60
166- fixed few mixed-use-of-spaces-and-tabs warnings in spec file
167
168* Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
169- 3.53
170
171* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
173
174* Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
175- 3.52
176
177* Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
178- 3.51
179
180* Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
181- version bump: 3.49
182
183* Sun Nov  9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
184- version bump: 3.48
185
186* Mon Oct  6 2008 kwizart <kwizart at gmail.com> - 3.44-1
187- bump to 3.44
188
189* Tue Sep  2 2008 kwizart <kwizart at gmail.com> - 3.43-4
190- Fix pkgconfig support
191
192* Mon Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
193- removed libev.a
194- installing with "-p"
195- event.h is removed intentionaly, because is there only for
196  backward compatibility with libevent
197
198* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
199- initial package
200
Note: See TracBrowser for help on using the repository browser.