source: projects/specs/trunk/lib/libe/libev/libev-vl.spec @ 12120

Revision 12120, 7.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global source_dir  %{_datadir}/%{name}-source
4%global inst_srcdir %{buildroot}/%{source_dir}
5
6Name:           libev
7Version:        4.25
8Release:        1%{?_dist_release}
9Summary:        High-performance event loop/event model with lots of features
10Summary(ja):    高機能・高性能のイベントループ・イベントモデル
11Group:          System Environment/Libraries
12License:        BSD or GPLv2+
13URL:            http://software.schmorp.de/pkg/libev.html
14Source0:        http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires:  automake libtool
21
22%description
23Libev is modeled (very loosely) after libevent and the Event Perl
24module, but is faster, scales better and is more correct, and also more
25featureful. And also smaller.
26
27%description -l ja
28libev は libevent および Perl の Event を大まかに参考にして作られましたが、
29それらより高速に動作し、よりスケールし、より正確で、より高機能で、
30同時によりコンパクトです。
31
32
33%package        devel
34Summary:        Development files for %{name}
35Summary(ja):    %{name} の開発用ファイル
36Group:          Development/Libraries
37Requires:       %{name}%{?_isa} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description    devel
41Libev is modeled (very loosely) after libevent and the Event Perl
42module, but is faster, scales better and is more correct, and also more
43featureful. And also smaller. Development libraries.
44
45%description    devel -l ja
46このパッケージには libev 用開発ライブラリとヘッダが収録されています。
47
48
49%package libevent-devel
50Summary:          Compatibility development header with libevent for %{name}.
51Summary(ja):      libevent互換の%{name}ヘッダファイル.
52Requires:         %{name}-devel%{?_isa} = %{version}-%{release}
53
54# The event.h file actually conflicts with the one from libevent-devel
55Conflicts:        libevent-devel
56
57%description libevent-devel
58This package contains a development header to make libev compatible with
59libevent.
60
61%description libevent-devel -l ja
62このパッケージにはlibevent互換のlibev用ヘッダファイルが収録されています。
63
64
65%package        source
66Summary:        Source code for libev
67Summary(ja):    libev のソースコード
68Group:          Development/Libraries
69BuildArch:      noarch
70
71%description    source
72This package contains the source code for libev.
73
74Libev is modeled (very loosely) after libevent and the Event Perl
75module, but is faster, scales better and is more correct, and also more
76featureful. And also smaller. Development libraries.
77
78%description    source -l ja
79このパッケージには libev のソースコードが収録されています。
80
81
82%package -n compat32-%{name}
83Summary:        High-performance event loop/event model with lots of features
84Summary(ja):    高機能・高性能のイベントループ・イベントモデル
85Group:          System Environment/Libraries
86
87%description -n compat32-%{name}
88Libev is modeled (very loosely) after libevent and the Event Perl
89module, but is faster, scales better and is more correct, and also more
90featureful. And also smaller.
91
92%description -n compat32-%{name} -l ja
93libev は libevent および Perl の Event を大まかに参考にして作られましたが、
94それらより高速に動作し、よりスケールし、より正確で、より高機能で、
95同時によりコンパクトです。
96
97
98%prep
99%setup -q
100
101#autoreconf -vfi
102
103
104%build
105%configure --disable-static --with-pic
106make %{?_smp_mflags}
107
108
109%check
110make check
111
112
113%install
114rm -rf %{buildroot}
115make install DESTDIR=%{buildroot} INSTALL="install -p"
116
117rm -rf %{buildroot}%{_libdir}/%{name}.la
118
119# Make the source package
120mkdir -p %{inst_srcdir}
121
122find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
123install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
124
125
126%clean
127rm -rf %{buildroot}
128
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133
134%files
135%license LICENSE
136%doc Changes README
137%{_libdir}/%{name}.so.4*
138
139%files devel
140%{_libdir}/%{name}.so
141%{_includedir}/ev++.h
142%{_includedir}/ev.h
143%{_mandir}/man?/*
144
145%files libevent-devel
146%{_includedir}/event.h
147
148%files source
149%{source_dir}
150
151%if %{build_compat32}
152%files -n compat32-%{name}
153%{_libdir}/%{name}.so.4*
154%endif
155
156%changelog
157* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.25-1
158- updated to 4.25.
159
160* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.24-1
161- updated to 4.24.
162- added a sub-package 'libevent-devel'.
163- added a sub-package 'compat32-libev'.
164
165* Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
166- updated to 4.19
167- spec in UTF-8
168- moved devel and source packages to Development/Libraries Group
169
170* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
171- initial build for Vine Linux
172
173* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
175
176* Tue Aug  9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
177- move man page
178- cleanup spec
179- update to 4.04
180
181* Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
182- EL5 cannot have noarch subpackages.
183
184* Sat Feb  5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
185- 4.03; RHBZ#674022
186- add a -source subpackage (Mathieu Bridon); RHBZ#672153
187
188* Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
189- 4.01
190- fix grammar in %%description
191
192* Sat Jan  2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
193- 3.9
194
195* Mon Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
196- 3.8
197- always use the most recent automake
198- BuildRequires now libtool
199
200* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
204- spec file change, which prevented uploading most recent tarball
205  so the RPM was "3.70" but tarball was from 3.60
206
207* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
208- v3.7
209- list libev soname explicitly
210
211* Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
212- previous version was called "3.6" but this is broken update
213  path wrt version "3.53" -- thus bumping to "3.60"
214
215* Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
216- 3.60
217- fixed few mixed-use-of-spaces-and-tabs warnings in spec file
218
219* Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
220- 3.53
221
222* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
224
225* Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
226- 3.52
227
228* Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
229- 3.51
230
231* Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
232- version bump: 3.49
233
234* Sun Nov  9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
235- version bump: 3.48
236
237* Mon Oct  6 2008 kwizart <kwizart at gmail.com> - 3.44-1
238- bump to 3.44
239
240* Tue Sep  2 2008 kwizart <kwizart at gmail.com> - 3.43-4
241- Fix pkgconfig support
242
243* Tue Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
244- removed libev.a
245- installing with "-p"
246- event.h is removed intentionaly, because is there only for
247  backward compatibility with libevent
248
249* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
250- initial package
251
Note: See TracBrowser for help on using the repository browser.