source: projects/specs/trunk/lib/libe/libev/libev-vl.spec @ 11837

Revision 11837, 7.2 KB checked in by tomop, 6 years ago (diff)

libev-4.24-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global source_dir  %{_datadir}/%{name}-source
4%global inst_srcdir %{buildroot}/%{source_dir}
5
6Name:           libev
7Version:        4.24
8Release:        1%{?_dist_release}
9Summary:        High-performance event loop/event model with lots of features
10Summary(ja):    高機能・高性能のイベントループ・イベントモデル
11Group:          System Environment/Libraries
12License:        BSD or GPLv2+
13URL:            http://software.schmorp.de/pkg/libev.html
14Source0:        http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires:  automake libtool
21
22%description
23Libev is modeled (very loosely) after libevent and the Event Perl
24module, but is faster, scales better and is more correct, and also more
25featureful. And also smaller.
26
27%description -l ja
28libev は libevent および Perl の Event を大まかに参考にして作られましたが、
29それらより高速に動作し、よりスケールし、より正確で、より高機能で、
30同時によりコンパクトです。
31
32
33%package        devel
34Summary:        Development files for %{name}
35Summary(ja):    %{name} の開発用ファイル
36Group:          Development/Libraries
37Requires:       %{name}%{?_isa} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description    devel
41Libev is modeled (very loosely) after libevent and the Event Perl
42module, but is faster, scales better and is more correct, and also more
43featureful. And also smaller. Development libraries.
44
45%description    devel -l ja
46このパッケージには libev 用開発ライブラリとヘッダが収録されています。
47
48
49%package libevent-devel
50Summary:          Compatibility development header with libevent for %{name}.
51Summary(ja):      libevent互換の%{name}ヘッダファイル.
52Requires:         %{name}-devel%{?_isa} = %{version}-%{release}
53
54# The event.h file actually conflicts with the one from libevent-devel
55Conflicts:        libevent-devel
56
57%description libevent-devel
58This package contains a development header to make libev compatible with
59libevent.
60
61%description libevent-devel -l ja
62このパッケージにはlibevent互換のlibev用ヘッダファイルが収録されています。
63
64
65%package        source
66Summary:        Source code for libev
67Summary(ja):    libev のソースコード
68Group:          Development/Libraries
69BuildArch:      noarch
70
71%description    source
72This package contains the source code for libev.
73
74Libev is modeled (very loosely) after libevent and the Event Perl
75module, but is faster, scales better and is more correct, and also more
76featureful. And also smaller. Development libraries.
77
78%description    source -l ja
79このパッケージには libev のソースコードが収録されています。
80
81
82%package -n compat32-%{name}
83Summary:        High-performance event loop/event model with lots of features
84Summary(ja):    高機能・高性能のイベントループ・イベントモデル
85Group:          System Environment/Libraries
86
87%description -n compat32-%{name}
88Libev is modeled (very loosely) after libevent and the Event Perl
89module, but is faster, scales better and is more correct, and also more
90featureful. And also smaller.
91
92%description -n compat32-%{name} -l ja
93libev は libevent および Perl の Event を大まかに参考にして作られましたが、
94それらより高速に動作し、よりスケールし、より正確で、より高機能で、
95同時によりコンパクトです。
96
97
98%prep
99%setup -q
100
101autoreconf -vfi
102
103
104%build
105%configure --disable-static --with-pic
106make %{?_smp_mflags}
107
108
109%check
110make check
111
112
113%install
114rm -rf %{buildroot}
115make install DESTDIR=%{buildroot} INSTALL="install -p"
116
117rm -rf %{buildroot}%{_libdir}/%{name}.la
118
119# Make the source package
120mkdir -p %{inst_srcdir}
121
122find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
123install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
124
125
126%clean
127rm -rf %{buildroot}
128
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133
134%files
135%doc Changes LICENSE README
136%{_libdir}/%{name}.so.4*
137
138%files devel
139%{_libdir}/%{name}.so
140%{_includedir}/ev++.h
141%{_includedir}/ev.h
142%{_mandir}/man?/*
143
144%files libevent-devel
145%{_includedir}/event.h
146
147%files source
148%{source_dir}
149
150%if %{build_compat32}
151%files -n compat32-%{name}
152%{_libdir}/%{name}.so.4*
153%endif
154
155%changelog
156* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.24-1
157- updated to 4.24.
158- added a sub-package 'libevent-devel'.
159- added a sub-package 'compat32-libev'.
160
161* Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
162- updated to 4.19
163- spec in UTF-8
164- moved devel and source packages to Development/Libraries Group
165
166* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
167- initial build for Vine Linux
168
169* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
171
172* Tue Aug  9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
173- move man page
174- cleanup spec
175- update to 4.04
176
177* Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
178- EL5 cannot have noarch subpackages.
179
180* Sat Feb  5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
181- 4.03; RHBZ#674022
182- add a -source subpackage (Mathieu Bridon); RHBZ#672153
183
184* Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
185- 4.01
186- fix grammar in %%description
187
188* Sat Jan  2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
189- 3.9
190
191* Mon Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
192- 3.8
193- always use the most recent automake
194- BuildRequires now libtool
195
196* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
198
199* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
200- spec file change, which prevented uploading most recent tarball
201  so the RPM was "3.70" but tarball was from 3.60
202
203* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
204- v3.7
205- list libev soname explicitly
206
207* Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
208- previous version was called "3.6" but this is broken update
209  path wrt version "3.53" -- thus bumping to "3.60"
210
211* Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
212- 3.60
213- fixed few mixed-use-of-spaces-and-tabs warnings in spec file
214
215* Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
216- 3.53
217
218* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
220
221* Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
222- 3.52
223
224* Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
225- 3.51
226
227* Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
228- version bump: 3.49
229
230* Sun Nov  9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
231- version bump: 3.48
232
233* Mon Oct  6 2008 kwizart <kwizart at gmail.com> - 3.44-1
234- bump to 3.44
235
236* Tue Sep  2 2008 kwizart <kwizart at gmail.com> - 3.43-4
237- Fix pkgconfig support
238
239* Tue Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
240- removed libev.a
241- installing with "-p"
242- event.h is removed intentionaly, because is there only for
243  backward compatibility with libevent
244
245* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
246- initial package
247
Note: See TracBrowser for help on using the repository browser.