source: projects/specs/trunk/lib/libe/libedit/libedit-vl.spec @ 9469

Revision 9469, 5.1 KB checked in by inagaki, 9 years ago (diff)

2015-03-24 Ryoichi INAGAKI <ryo1@…>

  • libedit: added compat32
  • mozjs24: rebuilt


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define snap 20140620
3
4Summary:        The NetBSD Editline library
5Summary(ja):    NetBSD Editline ライブラリ
6Name:           libedit
7Version:        3.1
8Release:        2.%{snap}%{?_dist_release}
9License:        BSD
10Group:          System Environment/Libraries
11URL:            http://www.thrysoee.dk/editline/
12
13Source0:        http://www.thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
14# bz #575383
15Patch1:         libedit-3.0-sigwinch.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  gawk
19BuildRequires:  ncurses-devel
20
21%description
22Libedit is an autotool- and libtoolized port of the NetBSD Editline library.
23It provides generic line editing, history, and tokenization functions, similar
24to those found in GNU Readline.
25
26%package devel
27Summary:        Development files for %{name}
28Summary(ja):    %{name} の開発ファイル
29Group:          Development/Libraries
30
31Requires:       %{name} = %{version}-%{release}
32Requires:       pkgconfig
33Requires:       ncurses-devel
34
35%description devel
36This package contains development files for %{name}.
37
38
39%package -n compat32-%{name}
40Summary:        The NetBSD Editline library
41Summary(ja):    NetBSD Editline ライブラリ
42Group:          System Environment/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description -n compat32-%{name}
46Libedit is an autotool- and libtoolized port of the NetBSD Editline library.
47It provides generic line editing, history, and tokenization functions, similar
48to those found in GNU Readline.
49
50%package -n compat32-%{name}-devel
51Summary:        Development files for %{name}
52Summary(ja):    %{name} の開発ファイル
53Group:          Development/Libraries
54Requires:       %{name}-devel = %{version}-%{release}
55Requires:       compat32-%{name} = %{version}-%{release}
56Requires:       compat32-pkgconfig
57Requires:       compat32-ncurses-devel
58
59%description -n compat32-%{name}-devel
60This package contains development files for %{name}.
61
62%prep
63%setup -q -n %{name}-%{snap}-%{version}
64%patch1 -p1
65
66# Suppress rpmlint error.
67iconv --from-code ISO8859-1 --to-code UTF-8 ./ChangeLog \
68  --output ChangeLog.utf-8 && mv ChangeLog.utf-8 ./ChangeLog
69
70%build
71%configure --disable-static --enable-widec
72
73# Trying to omit unused direct shared library dependencies leads to
74# undefined non-weak symbols.
75
76make %{?_smp_mflags}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
82find $RPM_BUILD_ROOT -type f -name "*.la" -delete
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%if %{build_compat32}
91%post -n compat32-%{name} -p /sbin/ldconfig
92%postun -n compat32-%{name} -p /sbin/ldconfig
93%endif
94
95%files
96%defattr(-,root,root,-)
97%doc ChangeLog COPYING THANKS
98%{_libdir}/%{name}.so.*
99
100%files devel
101%defattr(-,root,root,-)
102%doc examples/*.c
103%{_includedir}/histedit.h
104%dir %{_includedir}/editline
105%{_includedir}/editline/readline.h
106%{_libdir}/%{name}.so
107%{_libdir}/pkgconfig/%{name}.pc
108%doc %{_mandir}/man3/*
109%doc %{_mandir}/man5/editrc.5*
110
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root)
114%{_libdir}/%{name}.so.*
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root)
118%{_libdir}/%{name}.so
119%{_libdir}/pkgconfig/%{name}.pc
120%endif
121
122
123%changelog
124* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1-2.20140620
125- added compat32 subpackage
126
127* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1.20140620
128- update to 20140620 snap
129
130* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-4.20120601
131- update to 20120601 snap
132
133* Sun Jan 16 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-3.20100424
134- add --enable-widec to support wide-chat/UTF-8
135
136* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-2.20100424
137- rebuild with rpm-4.8.1 for pkg-config file
138
139* Wed May 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  3.0-1.20100424
140- initial build for Vine Linux
141- update to 20100424 snap
142
143* Tue Mar 30 2010 Kamil Dudka <kdudka@redhat.com> 3.0-2.20090923cvs
144- eliminated compile-time warnings
145- fix to not break the read loop on SIGWINCH, patch contributed
146  by Edward Sheldrake (#575383)
147
148* Fri Nov 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> 3.0-1.20090923cvs
149- Update to 3.0 (20090923 snap)
150
151* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-4.20080712cvs
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
153
154* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-3.20080712cvs
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Thu Jan 22 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.11-2.20080712cvs
158- Add ncurses-devel requires to -devel subpackage (BZ#481252)
159
160* Mon Jul 28 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.11-1.20080712cvs
161- Version bump to 20080712-2.11.
162
163* Sat Feb 16 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.10-4.20070831cvs
164- Rebuilding with gcc-4.3 in Rawhide.
165
166* Sun Nov 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-3.20070831cvs
167- Removed 'Requires: ncurses-devel'.
168
169* Sat Nov 03 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-2.20070831cvs
170- Changed character encoding of ChangeLog from ISO8859-1 to UTF-8.
171
172* Mon Sep 03 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-1.20070831cvs
173- Initial build. Imported SPEC from Rawhide.
Note: See TracBrowser for help on using the repository browser.