source: projects/specs/trunk/lib/libe/libedit/libedit-vl.spec @ 11092

Revision 11092, 5.3 KB checked in by iwaim, 7 years ago (diff)

libedit 3.1-2.20160903

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define snap 20160903
3
4Summary:        The NetBSD Editline library
5Summary(ja):    NetBSD Editline ライブラリ
6Name:           libedit
7Version:        3.1
8Release:        2.%{snap}%{?_dist_release}
9License:        BSD
10Group:          System Environment/Libraries
11URL:            http://thrysoee.dk/editline/
12
13Source0:        http://thrysoee.dk/editline/%{name}-%{snap}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires:  gawk
17BuildRequires:  ncurses-devel
18
19%description
20Libedit is an autotool- and libtoolized port of the NetBSD Editline library.
21It provides generic line editing, history, and tokenization functions, similar
22to those found in GNU Readline.
23
24%package devel
25Summary:        Development files for %{name}
26Summary(ja):    %{name} の開発ファイル
27Group:          Development/Libraries
28
29Requires:       %{name} = %{version}-%{release}
30Requires:       pkgconfig
31Requires:       ncurses-devel
32
33%description devel
34This package contains development files for %{name}.
35
36
37%package -n compat32-%{name}
38Summary:        The NetBSD Editline library
39Summary(ja):    NetBSD Editline ライブラリ
40Group:          System Environment/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%description -n compat32-%{name}
44Libedit is an autotool- and libtoolized port of the NetBSD Editline library.
45It provides generic line editing, history, and tokenization functions, similar
46to those found in GNU Readline.
47
48%package -n compat32-%{name}-devel
49Summary:        Development files for %{name}
50Summary(ja):    %{name} の開発ファイル
51Group:          Development/Libraries
52Requires:       %{name}-devel = %{version}-%{release}
53Requires:       compat32-%{name} = %{version}-%{release}
54Requires:       compat32-pkgconfig
55Requires:       compat32-ncurses-devel
56
57%description -n compat32-%{name}-devel
58This package contains development files for %{name}.
59
60%prep
61%setup -q -n %{name}-%{snap}-%{version}
62
63# Suppress rpmlint error.
64iconv --from-code ISO8859-1 --to-code UTF-8 ./ChangeLog \
65  --output ChangeLog.utf-8 && mv ChangeLog.utf-8 ./ChangeLog
66
67%build
68%configure --disable-static --enable-widec
69
70# Trying to omit unused direct shared library dependencies leads to
71# undefined non-weak symbols.
72
73make %{?_smp_mflags}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
79find $RPM_BUILD_ROOT -type f -name "*.la" -delete
80
81%__mv $RPM_BUILD_ROOT%{_mandir}/man3/history.3 $RPM_BUILD_ROOT%{_mandir}/man3/history_libedit.3
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%if %{build_compat32}
90%post -n compat32-%{name} -p /sbin/ldconfig
91%postun -n compat32-%{name} -p /sbin/ldconfig
92%endif
93
94%files
95%defattr(-,root,root,-)
96%doc ChangeLog COPYING THANKS
97%{_libdir}/%{name}.so.*
98%{_mandir}/man5/editrc.5*
99%{_mandir}/man7/editline.7*
100
101%files devel
102%defattr(-,root,root,-)
103%doc examples/*.c
104%{_includedir}/histedit.h
105%dir %{_includedir}/editline
106%{_includedir}/editline/readline.h
107%{_libdir}/%{name}.so
108%{_libdir}/pkgconfig/%{name}.pc
109%{_mandir}/man3/*
110
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root)
114%{_libdir}/%{name}.so.*
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root)
118%{_libdir}/%{name}.so
119%{_libdir}/pkgconfig/%{name}.pc
120%endif
121
122
123%changelog
124* Wed Mar 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.1-2.20160903
125- update to 20160903 snap
126- drop SIGWINCH patch (Patch1); upstream fixed
127- move editrc.5 to main package
128- add editline.7
129
130* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1-2.20140620
131- added compat32 subpackage
132
133* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1.20140620
134- update to 20140620 snap
135
136* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-4.20120601
137- update to 20120601 snap
138
139* Sun Jan 16 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-3.20100424
140- add --enable-widec to support wide-chat/UTF-8
141
142* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-2.20100424
143- rebuild with rpm-4.8.1 for pkg-config file
144
145* Wed May 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  3.0-1.20100424
146- initial build for Vine Linux
147- update to 20100424 snap
148
149* Tue Mar 30 2010 Kamil Dudka <kdudka@redhat.com> 3.0-2.20090923cvs
150- eliminated compile-time warnings
151- fix to not break the read loop on SIGWINCH, patch contributed
152  by Edward Sheldrake (#575383)
153
154* Fri Nov 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> 3.0-1.20090923cvs
155- Update to 3.0 (20090923 snap)
156
157* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-4.20080712cvs
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
159
160* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-3.20080712cvs
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
162
163* Thu Jan 22 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.11-2.20080712cvs
164- Add ncurses-devel requires to -devel subpackage (BZ#481252)
165
166* Mon Jul 28 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.11-1.20080712cvs
167- Version bump to 20080712-2.11.
168
169* Sat Feb 16 2008 Debarshi Ray <rishi@fedoraproject.org> - 2.10-4.20070831cvs
170- Rebuilding with gcc-4.3 in Rawhide.
171
172* Sun Nov 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-3.20070831cvs
173- Removed 'Requires: ncurses-devel'.
174
175* Sat Nov 03 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-2.20070831cvs
176- Changed character encoding of ChangeLog from ISO8859-1 to UTF-8.
177
178* Mon Sep 03 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.10-1.20070831cvs
179- Initial build. Imported SPEC from Rawhide.
Note: See TracBrowser for help on using the repository browser.