source: projects/specs/trunk/lib/libd/libdesktop-agnostic/libdesktop-agnostic-vl.spec @ 3005

Revision 3005, 5.2 KB checked in by kazutaka, 13 years ago (diff)

docky の更新に併せて新規のパッケージを追加

Line 
1Name:           libdesktop-agnostic
2Version:        0.3.92
3Release:        1%{?_dist_release}
4Summary:        Provides an extensible configuration API
5
6Group:          System Environment/Libraries
7License:        GPLv2+ and LGPLv2+
8URL:            https://launchpad.net/libdesktop-agnostic
9Source0:        http://launchpad.net/libdesktop-agnostic/0.4/%{version}/+download/%{name}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildRequires:  pygtk2-devel
13BuildRequires:  python-devel
14BuildRequires:  gobject-introspection-devel
15BuildRequires:  GConf2-devel
16BuildRequires:  vala
17BuildRequires:  gtk+-devel
18BuildRequires:  gnome-desktop-devel
19BuildRequires:  glade3-devel
20BuildRequires:  gettext
21BuildRequires:  intltool
22
23%description
24This library provides an extensible configuration API.
25A unified virtual file system API, and a desktop item editor.
26
27%package        bin
28Summary:        Helper applications for %{name}
29Group:          Applications/System
30Requires:       %{name} = %{version}-%{release}
31
32%description bin
33This package contains helper applications for libdesktop-agnostic, such as a
34schema converter.
35
36%package        -n python-desktop-agnostic
37Summary:        Python bindings for %{name}
38Group:          Development/Languages
39Requires:       %{name} = %{version}-%{release}
40
41%description    -n python-desktop-agnostic
42This package contains the Python bindings for the core library.
43
44%package        devel
45Summary:        Development files for %{name}
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51The %{name}-devel package contains libraries and header files for
52developing applications that use %{name}.
53
54
55%prep
56%setup -q
57
58
59%build
60export CFLAGS="%{optflags}"
61PYTHONDIR=%{python_sitearch} ./waf configure \
62      --prefix=%{_prefix} \
63      --libdir=%{_libdir} \
64      --sysconfdir=%{_sysconfdir} \
65      --enable-debug \
66      --config-backends=gconf \
67      --vfs-backends=gio \
68      --desktop-entry-backends=glib \
69      --with-glade \
70      --disable-gi
71./waf -v build
72
73%install
74rm -rf $RPM_BUILD_ROOT
75DESTDIR=$RPM_BUILD_ROOT ./waf install
76
77# install man files
78#mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
79#install -D -p -m 0644 debian/lda*1 $RPM_BUILD_ROOT%{_mandir}/man1
80
81# fix permissions so debuginfo is stripped from .so files
82find $RPM_BUILD_ROOT%{_libdir} -name *.so -exec chmod 755 {} \;
83
84%find_lang %{name}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94
95%files -f %{name}.lang
96%defattr(-,root,root,-)
97%doc COPYING COPYING.GPL-2 debian/changelog
98%config(noreplace) %{_sysconfdir}/xdg/libdesktop-agnostic/desktop-agnostic.ini
99%{_libdir}/*.so.*
100%dir %{_libdir}/desktop-agnostic
101%dir %{_libdir}/desktop-agnostic/modules
102%{_libdir}/desktop-agnostic/modules/libda-*.so
103
104%files bin
105%defattr(-,root,root,-)
106%{_bindir}/lda-desktop-entry-editor
107%{_bindir}/lda-schema-to-gconf
108#%{_mandir}/man1/lda*1.gz
109
110%files -n python-desktop-agnostic
111%defattr(-,root,root,-)
112%dir %{python_sitearch}/desktopagnostic
113%{python_sitearch}/desktopagnostic/__init__.p*
114%{python_sitearch}/desktopagnostic/*.so
115
116%files devel
117%defattr(-,root,root,-)
118%{_includedir}/*
119%{_datadir}/pygtk/2.0/defs/desktopagnostic*defs
120%{_datadir}/vala/vapi/desktop-agnostic*
121%{_datadir}/glade3/catalogs/desktop-agnostic.xml
122%{_libdir}/pkgconfig/desktop-agnostic.pc
123%{_libdir}/*.so
124
125
126%changelog
127* Mon Mar 14 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.3.92-1
128- initial build for Vine Linux based on fedora development
129
130* Wed Feb 09 2011 Leigh Scott <leigh123linux@googlemail.com> - 0.3.90-13
131- merge all upstream changes
132- add disable gi
133- add Br intltool gettext
134
135* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.90-12
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
137
138* Mon Dec 06 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-11
139- rebuilt
140
141* Sat Jul 31 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 0.3.90-10
142- Hack to fool the builder the .gir file version. May need real fix.
143- Comment out BR: waf
144
145* Fri Jul 23 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-9
146- drop Br gir-repository-devel
147
148* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.90-8
149- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
150
151* Sat Apr 24 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-7
152- fix mistake in spec file
153
154* Mon Apr 19 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-6
155- merge the remaining sub-package libs into the main package
156
157* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-5
158- merge gir sub-package into main package
159- fix license tag
160
161* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-4
162- make recommended review changes
163
164* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-3
165- add requires pkgconfig to devel package
166- drop unwanted sub-packages
167
168* Mon Apr 12 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-2
169- move vala package and python defs to devel
170
171* Mon Apr 12 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-1
172- update to 0.3.90
173
174* Tue Mar 30 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.9-bzr383.01
175- inital build
Note: See TracBrowser for help on using the repository browser.