source: projects/specs/trunk/lib/libd/libdesktop-agnostic/libdesktop-agnostic-vl.spec @ 5787

Revision 5787, 5.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1Name:           libdesktop-agnostic
2Version:        0.3.92
3Release:        2%{?_dist_release}
4Summary:        Provides an extensible configuration API
5
6Group:          System Environment/Libraries
7License:        GPLv2+ and LGPLv2+
8URL:            https://launchpad.net/libdesktop-agnostic
9Source0:        http://launchpad.net/libdesktop-agnostic/0.4/%{version}/+download/%{name}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildRequires:  pygtk2-devel
13BuildRequires:  python-devel
14BuildRequires:  gobject-introspection-devel
15BuildRequires:  GConf2-devel
16BuildRequires:  vala
17BuildRequires:  gtk+-devel
18BuildRequires:  gnome-desktop-devel
19BuildRequires:  glade3-devel
20BuildRequires:  gettext
21BuildRequires:  intltool
22
23%description
24This library provides an extensible configuration API.
25A unified virtual file system API, and a desktop item editor.
26
27%package        bin
28Summary:        Helper applications for %{name}
29Group:          Applications/System
30Requires:       %{name} = %{version}-%{release}
31
32%description bin
33This package contains helper applications for libdesktop-agnostic, such as a
34schema converter.
35
36%package        -n python-desktop-agnostic
37Summary:        Python bindings for %{name}
38Group:          Development/Languages
39Requires:       %{name} = %{version}-%{release}
40
41%description    -n python-desktop-agnostic
42This package contains the Python bindings for the core library.
43
44%package        devel
45Summary:        Development files for %{name}
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51The %{name}-devel package contains libraries and header files for
52developing applications that use %{name}.
53
54
55%prep
56%setup -q
57sed -i "s/gladeui-1.0/gladeui-2.0/g" data/wscript
58
59
60%build
61export CFLAGS="%{optflags}"
62PYTHONDIR=%{python_sitearch} ./waf configure \
63      --prefix=%{_prefix} \
64      --libdir=%{_libdir} \
65      --sysconfdir=%{_sysconfdir} \
66      --enable-debug \
67      --config-backends=gconf \
68      --vfs-backends=gio \
69      --desktop-entry-backends=glib \
70      --with-glade \
71      --disable-gi
72./waf -v build
73
74%install
75rm -rf $RPM_BUILD_ROOT
76DESTDIR=$RPM_BUILD_ROOT ./waf install
77
78# install man files
79#mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
80#install -D -p -m 0644 debian/lda*1 $RPM_BUILD_ROOT%{_mandir}/man1
81
82# fix permissions so debuginfo is stripped from .so files
83find $RPM_BUILD_ROOT%{_libdir} -name *.so -exec chmod 755 {} \;
84
85%find_lang %{name}
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95
96%files -f %{name}.lang
97%defattr(-,root,root,-)
98%doc COPYING COPYING.GPL-2 debian/changelog
99%config(noreplace) %{_sysconfdir}/xdg/libdesktop-agnostic/desktop-agnostic.ini
100%{_libdir}/*.so.*
101%dir %{_libdir}/desktop-agnostic
102%dir %{_libdir}/desktop-agnostic/modules
103%{_libdir}/desktop-agnostic/modules/libda-*.so
104
105%files bin
106%defattr(-,root,root,-)
107%{_bindir}/lda-desktop-entry-editor
108%{_bindir}/lda-schema-to-gconf
109#%{_mandir}/man1/lda*1.gz
110
111%files -n python-desktop-agnostic
112%defattr(-,root,root,-)
113%dir %{python_sitearch}/desktopagnostic
114%{python_sitearch}/desktopagnostic/__init__.p*
115%{python_sitearch}/desktopagnostic/*.so
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/*
120%{_datadir}/pygtk/2.0/defs/desktopagnostic*defs
121%{_datadir}/vala/vapi/desktop-agnostic*
122%{_datadir}/glade/catalogs/desktop-agnostic.xml
123%{_libdir}/pkgconfig/desktop-agnostic.pc
124%{_libdir}/*.so
125
126
127%changelog
128* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.92-2
129- rebuild with python-2.7.2
130
131* Mon Mar 14 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.3.92-1
132- initial build for Vine Linux based on fedora development
133
134* Wed Feb 09 2011 Leigh Scott <leigh123linux@googlemail.com> - 0.3.90-13
135- merge all upstream changes
136- add disable gi
137- add Br intltool gettext
138
139* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.90-12
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
141
142* Mon Dec 06 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-11
143- rebuilt
144
145* Sat Jul 31 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 0.3.90-10
146- Hack to fool the builder the .gir file version. May need real fix.
147- Comment out BR: waf
148
149* Fri Jul 23 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-9
150- drop Br gir-repository-devel
151
152* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.90-8
153- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
154
155* Sat Apr 24 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-7
156- fix mistake in spec file
157
158* Mon Apr 19 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-6
159- merge the remaining sub-package libs into the main package
160
161* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-5
162- merge gir sub-package into main package
163- fix license tag
164
165* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-4
166- make recommended review changes
167
168* Thu Apr 15 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-3
169- add requires pkgconfig to devel package
170- drop unwanted sub-packages
171
172* Mon Apr 12 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-2
173- move vala package and python defs to devel
174
175* Mon Apr 12 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.90-1
176- update to 0.3.90
177
178* Tue Mar 30 2010 leigh scott <leigh123linux@googlemail.com> - 0.3.9-bzr383.01
179- inital build
Note: See TracBrowser for help on using the repository browser.