source: projects/specs/trunk/lib/libd/libdb/libdb-vl.spec @ 8526

Revision 8526, 18.5 KB checked in by tomop, 10 years ago (diff)

libdb-5.3.28-6, libmysqlclient-10.0.11-1

Line 
1%define __soversion_major 5
2%define __soversion %{__soversion_major}.3
3
4%bcond_with java
5
6Summary: The Berkeley DB database library for C
7Name: libdb
8Version: 5.3.28
9Release: 6%{?_dist_release}
10Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
11Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
12# For mt19937db.c
13Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
14Patch0: libdb-multiarch.patch
15# db-1.85 upstream patches
16Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
17Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
18Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
19Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
20# other patches
21Patch20: db-1.85-errno.patch
22Patch22: db-4.6.21-1.85-compat.patch
23Patch24: db-4.5.20-jni-include-dir.patch
24# License clarification patch
25# http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
26Patch25: 007-mt19937db.c_license.patch
27URL: http://www.oracle.com/database/berkeley-db/
28License: BSD and LGPLv2 and Sleepycat
29Group: System Environment/Libraries
30BuildRequires: perl libtool
31BuildRequires: tcl >= 8.5.2-3
32%if %{with java}
33BuildRequires: java-devel >= 1:1.6.0
34%endif
35#BuildRequires: chrpath
36#Conflicts: filesystem < 3
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: tomop
41
42%description
43The Berkeley Database (Berkeley DB) is a programmatic toolkit that
44provides embedded database support for both traditional and
45client/server applications. The Berkeley DB includes B+tree, Extended
46Linear Hashing, Fixed and Variable-length record access methods,
47transactions, locking, logging, shared memory caching, and database
48recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
49used by many applications, including Python and Perl, so this should
50be installed on all systems.
51
52%package utils
53Summary: Command line tools for managing Berkeley DB databases
54Group: Applications/Databases
55Requires: %{name}%{?_isa} = %{version}-%{release}
56Obsoletes: db4-utils
57Provides: db4-utils
58
59%description utils
60The Berkeley Database (Berkeley DB) is a programmatic toolkit that
61provides embedded database support for both traditional and
62client/server applications. Berkeley DB includes B+tree, Extended
63Linear Hashing, Fixed and Variable-length record access methods,
64transactions, locking, logging, shared memory caching, and database
65recovery. DB supports C, C++, Java and Perl APIs.
66
67%package devel
68Summary: C development files for the Berkeley DB library
69Group: Development/Libraries
70Requires: %{name}%{?_isa} = %{version}-%{release}
71Obsoletes: db4-devel
72Provides: db4-devel
73
74%description devel
75The Berkeley Database (Berkeley DB) is a programmatic toolkit that
76provides embedded database support for both traditional and
77client/server applications. This package contains the header files,
78libraries, and documentation for building programs which use the
79Berkeley DB.
80
81%package devel-doc
82Summary: C development documentation files for the Berkeley DB library
83Group: Documentation
84Requires: %{name} = %{version}-%{release}
85Requires: %{name}-devel = %{version}-%{release}
86BuildArch: noarch
87
88%description devel-doc
89The Berkeley Database (Berkeley DB) is a programmatic toolkit that
90provides embedded database support for both traditional and
91client/server applications. This package contains the header files,
92libraries, and documentation for building programs which use the
93Berkeley DB.
94
95%package devel-static
96Summary: Berkeley DB static libraries
97Group: Development/Libraries
98Requires: %{name}-devel%{?_isa} = %{version}-%{release}
99
100%description devel-static
101The Berkeley Database (Berkeley DB) is a programmatic toolkit that
102provides embedded database support for both traditional and
103client/server applications. This package contains static libraries
104needed for applications that require static linking of
105Berkeley DB.
106
107%package cxx
108Summary: The Berkeley DB database library for C++
109Group: System Environment/Libraries
110Requires: %{name}%{?_isa} = %{version}-%{release}
111
112%description cxx
113The Berkeley Database (Berkeley DB) is a programmatic toolkit that
114provides embedded database support for both traditional and
115client/server applications. The Berkeley DB includes B+tree, Extended
116Linear Hashing, Fixed and Variable-length record access methods,
117transactions, locking, logging, shared memory caching, and database
118recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
119used by many applications, including Python and Perl, so this should
120be installed on all systems.
121
122%package cxx-devel
123Summary: The Berkeley DB database library for C++
124Group: System Environment/Libraries
125Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
126Requires: %{name}-devel%{?_isa} = %{version}-%{release}
127
128%description cxx-devel
129The Berkeley Database (Berkeley DB) is a programmatic toolkit that
130provides embedded database support for both traditional and
131client/server applications. The Berkeley DB includes B+tree, Extended
132Linear Hashing, Fixed and Variable-length record access methods,
133transactions, locking, logging, shared memory caching, and database
134recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
135used by many applications, including Python and Perl, so this should
136be installed on all systems.
137
138%package tcl
139Summary: Development files for using the Berkeley DB with tcl
140Group: Development/Libraries
141Requires: %{name}%{?_isa} = %{version}-%{release}
142
143%description tcl
144The Berkeley Database (Berkeley DB) is a programmatic toolkit that
145provides embedded database support for both traditional and
146client/server applications. This package contains the libraries
147for building programs which use the Berkeley DB in Tcl.
148
149%package tcl-devel
150Summary: Development files for using the Berkeley DB with tcl
151Group: Development/Libraries
152Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
153
154%description tcl-devel
155The Berkeley Database (Berkeley DB) is a programmatic toolkit that
156provides embedded database support for both traditional and
157client/server applications. This package contains the libraries
158for building programs which use the Berkeley DB in Tcl.
159
160%package sql
161Summary: Development files for using the Berkeley DB with sql
162Group: Development/Libraries
163Requires: %{name}%{?_isa} = %{version}-%{release}
164
165%description sql
166The Berkeley Database (Berkeley DB) is a programmatic toolkit that
167provides embedded database support for both traditional and
168client/server applications. This package contains the libraries
169for building programs which use the Berkeley DB in SQL.
170
171%package sql-devel
172Summary: Development files for using the Berkeley DB with sql
173Group: Development/Libraries
174Requires: %{name}-sql%{?_isa} = %{version}-%{release}
175
176%description sql-devel
177The Berkeley Database (Berkeley DB) is a programmatic toolkit that
178provides embedded database support for both traditional and
179client/server applications. This package contains the libraries
180for building programs which use the Berkeley DB in SQL.
181
182%if %{with java}
183%package java
184Summary: Development files for using the Berkeley DB with Java
185Group: Development/Libraries
186Requires: %{name}%{?_isa} = %{version}-%{release}
187
188%description java
189The Berkeley Database (Berkeley DB) is a programmatic toolkit that
190provides embedded database support for both traditional and
191client/server applications. This package contains the libraries
192for building programs which use the Berkeley DB in Java.
193
194%package java-devel
195Summary: Development files for using the Berkeley DB with Java
196Group: Development/Libraries
197Requires: %{name}-java%{?_isa} = %{version}-%{release}
198
199%description java-devel
200The Berkeley Database (Berkeley DB) is a programmatic toolkit that
201provides embedded database support for both traditional and
202client/server applications. This package contains the libraries
203for building programs which use the Berkeley DB in Java.
204%endif
205
206%prep
207%setup -q -n db-%{version} -a 1
208cp %{SOURCE2} .
209
210%patch0 -p1 -b .multiarch
211pushd db.1.85/PORT/linux
212%patch10 -p0 -b .1.1
213popd
214pushd db.1.85
215%patch11 -p0 -b .1.2
216%patch12 -p0 -b .1.3
217%patch13 -p0 -b .1.4
218%patch20 -p1 -b .errno
219popd
220
221%patch22 -p1 -b .185compat
222%patch24 -p1 -b .4.5.20.jni
223%patch25 -p1 -b .licensefix
224
225cd dist
226./s_config
227cd ..
228
229%build
230CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
231CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
232export CFLAGS
233
234# Build the old db-185 libraries.
235make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
236
237test -d dist/dist-tls || mkdir dist/dist-tls
238# Static link db_dump185 with old db-185 libraries.
239/bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
240/bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
241
242# Update config files to understand aarch64
243#for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
244#  cp /usr/lib/rpm/config.{guess,sub} "$dir"
245#done
246
247pushd dist/dist-tls
248%define _configure ../configure
249%configure -C \
250        --enable-compat185 \
251        --enable-dump185 \
252        --enable-shared \
253        --enable-static \
254        --enable-tcl \
255        --with-tcl=%{_libdir} \
256        --enable-cxx \
257        --enable-sql \
258        --enable-test \
259        --disable-rpath \
260        --with-tcl=%{_libdir}/tcl8.5 \
261%if %{with java}
262        --enable-java
263%endif
264
265# Remove libtool predep_objects and postdep_objects wonkiness so that
266# building without -nostdlib doesn't include them twice.  Because we
267# already link with g++, weird stuff happens if you don't let the
268# compiler handle this.
269perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
270perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
271perl -pi -e 's/-shared -nostdlib/-shared/' libtool
272
273make %{?_smp_mflags}
274
275%if %{with java}
276# XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
277LDBJ=./.libs/libdb_java-%{__soversion}.la
278if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
279        sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
280fi
281%endif
282
283popd
284
285%install
286rm -rf ${RPM_BUILD_ROOT}
287mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
288mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
289
290%makeinstall STRIP=/bin/true -C dist/dist-tls
291
292# XXX Nuke non-versioned archives and symlinks
293rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
294
295chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
296
297# Move the header files to a subdirectory, in case we're deploying on a
298# system with multiple versions of DB installed.
299mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
300mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
301
302# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
303for i in db.h db_cxx.h db_185.h; do
304        ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
305done
306
307%if %{with java}
308# Move java jar file to the correct place
309mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
310mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
311%endif
312
313# Eliminate installed doco
314rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
315
316# XXX Avoid Permission denied. strip when building as non-root.
317chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
318
319# remove unneeded .la files (#225675)
320rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
321
322# remove RPATHs
323#chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
324
325# unify documentation and examples, remove stuff we don't need
326rm -rf docs/csharp
327rm -rf examples/csharp
328rm -rf docs/installation
329mv examples docs
330
331%clean
332rm -rf ${RPM_BUILD_ROOT}
333
334%post
335/sbin/ldconfig
336
337%postun
338/sbin/ldconfig
339
340%post cxx
341/sbin/ldconfig
342
343%postun cxx
344/sbin/ldconfig
345
346%post sql
347/sbin/ldconfig
348
349%postun sql
350/sbin/ldconfig
351
352%post tcl
353/sbin/ldconfig
354
355%postun tcl
356 /sbin/ldconfig
357
358%if %{with java}
359%post java
360/sbin/ldconfig
361
362%postun java
363/sbin/ldconfig
364
365%endif
366
367%files
368%defattr(-,root,root,-)
369%doc LICENSE README lgpl-2.1.txt
370%{_libdir}/libdb-%{__soversion}.so
371%{_libdir}/libdb-%{__soversion_major}.so
372
373%files devel
374%defattr(-,root,root,-)
375%{_libdir}/libdb.so
376%dir %{_includedir}/%{name}
377%{_includedir}/%{name}/db.h
378%{_includedir}/%{name}/db_185.h
379%{_includedir}/db.h
380%{_includedir}/db_185.h
381
382%files devel-doc
383%defattr(-,root,root,-)
384%doc    docs/*
385
386%files devel-static
387%defattr(-,root,root,-)
388%{_libdir}/libdb-%{__soversion}.a
389%{_libdir}/libdb_cxx-%{__soversion}.a
390%{_libdir}/libdb_tcl-%{__soversion}.a
391%{_libdir}/libdb_sql-%{__soversion}.a
392%if %{with java}
393%{_libdir}/libdb_java-%{__soversion}.a
394%endif
395
396%files utils
397%defattr(-,root,root,-)
398%{_bindir}/db*_archive
399%{_bindir}/db*_checkpoint
400%{_bindir}/db*_deadlock
401%{_bindir}/db*_dump*
402%{_bindir}/db*_hotbackup
403%{_bindir}/db*_load
404%{_bindir}/db*_printlog
405%{_bindir}/db*_recover
406%{_bindir}/db*_replicate
407%{_bindir}/db*_stat
408%{_bindir}/db*_upgrade
409%{_bindir}/db*_verify
410%{_bindir}/db*_tuner
411
412%files cxx
413%defattr(-,root,root,-)
414%{_libdir}/libdb_cxx-%{__soversion}.so
415%{_libdir}/libdb_cxx-%{__soversion_major}.so
416
417%files cxx-devel
418%defattr(-,root,root,-)
419%{_includedir}/%{name}/db_cxx.h
420%{_includedir}/db_cxx.h
421%{_libdir}/libdb_cxx.so
422
423%files tcl
424%defattr(-,root,root,-)
425%{_libdir}/libdb_tcl-%{__soversion}.so
426%{_libdir}/libdb_tcl-%{__soversion_major}.so
427
428%files tcl-devel
429%defattr(-,root,root,-)
430%{_libdir}/libdb_tcl.so
431
432%files sql
433%defattr(-,root,root,-)
434%{_libdir}/libdb_sql-%{__soversion}.so
435%{_libdir}/libdb_sql-%{__soversion_major}.so
436
437%files sql-devel
438%defattr(-,root,root,-)
439%{_bindir}/dbsql
440%{_libdir}/libdb_sql.so
441%{_includedir}/%{name}/dbsql.h
442
443%if %{with java}
444%files java
445%defattr(-,root,root,-)
446%{_libdir}/libdb_java-%{__soversion_major}*.so
447%{_datadir}/java/*.jar
448
449%files java-devel
450%defattr(-,root,root,-)
451%{_libdir}/libdb_java.so
452%endif
453
454%changelog
455* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
456- added "Provides: db4-{utils,devel}".
457
458* Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
459- initial build for Vine Linux.
460
461* Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
462- Add some of the previous aarch64 bits back as the sub configure don't use the macro
463
464* Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
465- Fix configure macro usage for better aarch64 build fix
466
467* Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
468- Updated config files to allow build on aarch64 (#1022970)
469
470* Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
471- Added Sleepycat to the license list (#1013841)
472- Updated to 5.3.28 (#1013233)
473
474* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
475- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
476
477* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
478- add copy of lgpl-2.1.txt
479
480* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
481- Fix missing debuginfo issue for utils subpackage
482
483* Thu May  9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
484- add license clarification fix
485
486* Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
487- Added sqlite compability CFLAGS (#788496)
488
489* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
490- Cleaning the specfile - removed gcc-java dependecy other way
491
492* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
493- Removed dependency on obsolete gcc-java package (#927742)
494
495* Thu Mar  7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
496- add LGPLv2+ and remove Sleepycat in license tag (#886838)
497
498* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
499- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
500
501* Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
502- fix license tag
503
504* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
505- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
506
507* Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
508- Specify tag for libtool (fixes FTBFS # 838334 )
509
510* Thu Jul  5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
511- update to 5.3.21
512http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
513
514* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
515- move C++ header files to cxx-devel
516
517* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
518- fix -devel packages dependencies yet more (#832225)
519
520* Sun May  6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
521- package -devel packages correctly
522
523* Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
524- fix multiarch conflict in libdb-devel (#812901)
525- remove unneeded dos2unix BR
526
527* Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
528- update to 5.3.15
529  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
530
531* Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
532- Resolves rhbz#794472
533- Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
534
535* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
536- add filesystem guard
537
538* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
539- install everything in /usr
540  https://fedoraproject.org/wiki/Features/UsrMove
541
542* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
543- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
544
545* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
546- update to 5.2.36,
547  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
548
549* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
550- move development documentation to devel-doc subpackage (#705386)
551
552* Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
553- update to 5.2.28
554
555* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
556- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
557
558* Thu Feb  3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
559- update to 5.1.25
560
561* Wed Sep 29 2010 jkeating - 5.1.19-2
562- Rebuilt for gcc bug 634757
563
564* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
565- update to 5.1.19
566- rename -devel-static to -static subpackage (#617800)
567- build java on all arches
568
569* Wed Jul  7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
570- update to 5.0.26
571- drop BR: ed
572
573* Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
574- add Requires: libdb-cxx to libdb-devel
575
576* Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
577- initial build
578
579* Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
580- remove C# documentation
581- disable/remove rpath
582- fix description
583- tighten dependencies
584- run ldconfig for cxx and sql subpackages
585
586* Fri Apr  9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
587- enable sql
588- package 5.0.21
Note: See TracBrowser for help on using the repository browser.