source: projects/specs/trunk/lib/libc/libchamplain/libchamplain-vl.spec @ 9073

Revision 9073, 13.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1%define ver     0.12
2
3Summary:        Map view for Clutter
4Summary(ja):    Clutter用のマップビューア
5Name:           libchamplain
6Version:        0.12.9
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group: System Environment/Libraries
10URL: http://projects.gnome.org/libchamplain/
11Source0: http://download.gnome.org/sources/libchamplain/0.12/%{name}-%{version}.tar.xz
12
13Requires: gobject-introspection
14
15BuildRequires: clutter-devel
16BuildRequires: clutter-gtk-devel
17BuildRequires: libsoup-devel
18BuildRequires: sqlite3-devel
19BuildRequires: gtk-doc >= 1.14
20BuildRequires: gobject-introspection-devel >= 0.6.8
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29Libchamplain is a C library aimed to provide a ClutterActor to display
30rasterized maps.
31
32%description -l ja
33Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38
39Requires:       gobject-introspection-devel
40Requires:       clutter-devel
41Requires:       sqlite3-devel
42Requires:       libsoup-devel
43Requires:       %{name} = %{version}-%{release}
44
45%description devel
46This package contains development files for %{name}.
47
48%package        gtk
49Summary:        Gtk+ widget wrapper for %{name}
50Group:          System Environment/Libraries
51
52Requires:       %{name} = %{version}-%{release}
53
54%description gtk
55Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
56into Gtk+ applications.
57
58%package        gtk-devel
59Summary:        Development files for %{name}-gtk
60Group:          Development/Libraries
61
62Requires:       clutter-gtk-devel
63Requires:       gtk2-devel
64Requires:       %{name}-devel = %{version}-%{release}
65Requires:       %{name}-gtk = %{version}-%{release}
66
67%description gtk-devel
68This package contains development files for %{name}-gtk.
69
70%package        vala
71Summary:        Vala bindings for %{name}
72Summary(ja):    %{name} の Vala バインディング
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       %{name}-gtk = %{version}-%{release}
76Requires:       vala
77
78%description    vala
79Vala bindings for %{name}.
80
81%package        docs
82Summary:        Documentation for %{name}
83Summary(ja):    %{name} 用のドキュメント
84Group:          Documentation
85Requires:       %{name} = %{version}-%{release}
86Requires:               gtk-doc
87BuildArch:      noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93%prep
94%setup -q
95
96%build
97%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
98  --enable-introspection=yes --enable-silent-rules
99
100# Omit unused direct shared library dependencies.
101sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
102
103make %{?_smp_mflags}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
109find $RPM_BUILD_ROOT -type f -name "*.la" -delete
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post gtk -p /sbin/ldconfig
119
120%postun gtk -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc AUTHORS
125%doc ChangeLog
126%doc COPYING
127%doc NEWS
128%{_libdir}/girepository-1.0/Champlain-%{ver}.typelib
129%{_libdir}/%{name}-%{ver}.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%doc demos/animated-marker.c
134%doc demos/launcher.c
135%doc demos/markers.c
136%doc demos/markers.h
137%doc demos/polygons.c
138%doc demos/url-marker.c
139%{_datadir}/gir-1.0/Champlain-%{ver}.gir
140%{_libdir}/%{name}-%{ver}.so
141%{_libdir}/pkgconfig/champlain-%{ver}.pc
142
143%dir %{_includedir}/%{name}-%{ver}
144%{_includedir}/%{name}-%{ver}/champlain
145
146%files gtk
147%defattr(-,root,root,-)
148%{_libdir}/girepository-1.0/GtkChamplain-%{ver}.typelib
149%{_libdir}/%{name}-gtk-%{ver}.so.*
150
151%files gtk-devel
152%defattr(-,root,root,-)
153%doc demos/launcher-gtk.c
154%doc demos/markers.c
155%{_datadir}/gir-1.0/GtkChamplain-%{ver}.gir
156%{_libdir}/%{name}-gtk-%{ver}.so
157%{_libdir}/pkgconfig/champlain-gtk-%{ver}.pc
158
159%dir %{_includedir}/%{name}-gtk-%{ver}
160%{_includedir}/%{name}-gtk-%{ver}/champlain-gtk
161
162%files vala
163%defattr(-,root,root,-)
164%{_datadir}/vala/vapi/champlain-%{ver}.vapi
165%{_datadir}/vala/vapi/champlain-gtk-%{ver}.vapi
166
167%files docs
168%defattr(-,root,root,-)
169%{_datadir}/gtk-doc/html/libchamplain-%{ver}
170%{_datadir}/gtk-doc/html/libchamplain-gtk-%{ver}
171
172
173%changelog
174* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
175- new upstream release
176
177* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
178- new upstream release
179
180* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-2
181- rebuild with VineSeed environment
182
183* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-1
184- new upstream release
185- create vala, docs subpackages
186
187* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
188- new upstream release
189
190* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-3
191- rebuild with cogl-0.14.0
192
193* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-2
194- rebuild with cogl-0.12.0
195
196* Tue Jul 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
197- new upstream release
198
199* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
200- new upstream release
201
202* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
203- new upstream release
204
205* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
206- new upstream release
207
208* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
209- new upstream release
210- add Requires: sqlite3-devel, libsoup-devel (-devel package)
211
212* Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
213- add Requires: sqlite3-devel, libsoup-devel (-devel package)
214- add Requires: gtk2-devel (-gtk-devel package)
215
216* Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
217- new upstream release
218- remove BuildRequires: gir-repository-devel
219- fix %files (change version)
220
221* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
222- rebuild with rpm-4.8.1 for pkg-config file
223
224* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
225- new upstream release
226
227* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
228- new upstream release
229
230* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
231- new upstream release
232- fix BuildRequires: gtk-doc >= 1.14
233- add Requires: clutter-devel (devel package)
234- add Requires: clutter-gtk-devel (gtk-devel package)
235
236* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
237- Initial build for Vine Linux
238- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
239
240
241* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
242- Version bump to 0.4.2.
243  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
244  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
245  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
246  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
247
248* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
249- Version bump to 0.4.1.
250  * Added champlain_view_remove_layer.
251  * ChamplainSelectionLayer now has a "changed" signal.
252  * Added champlain_marker_get_highlighted_text_color,
253    champlain_marker_set_highlighted_text_color and
254    Added champlain_marker_get_highlighted_color.
255  * Fixed slowdowns with big caches.
256  * Don't emit invalid latitude and longitude notifications.
257  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
258    Bugzilla #598106)
259  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
260  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
261
262- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
263  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
264  (GNOME Bugzilla #598942)
265- Explicitly disabled debug code.
266- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
267
268* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
269- Version bump to 0.4.0.
270  * ChamplainView now has keyboard shortcuts (but not when used with
271    GtkChamplainEmbed).
272  * Removed deprecated symbols introduced in 0.3.
273  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
274  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
275  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
276  * Initial center_on should not result on the map being in Antarctica.
277    (GNOME Bugzilla #594963)
278  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
279  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
280
281* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
282- Version bump to 0.3.91.
283  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
284
285* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
286- Version bump to 0.3.90.
287  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
288  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
289
290* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
291- Version bump to 0.3.6.
292  * New marker animation API.
293  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
294  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
295  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
296
297* Sun Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
298- Version bump to 0.3.5.
299  * Marker selection API. (GNOME Bugzilla #577909)
300  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
301  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
302  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
303  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
304
305* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
306- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
307
308* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
309- Version bump to 0.3.3.
310  * Support for custom map sources and listing available map sources.
311  * Smooth movement to a new position. (GNOME Bugzilla #557641)
312  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
313    #557642)
314  * Double click to zoom and center. (GNOME Bugzilla #557644)
315  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
316    #557965)
317  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
318    Bugzilla #558020)
319  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
320  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
321  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
322    #559446)
323  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
324    #561700)
325  * Added disk cache management. (GNOME Bugzillla #568931)
326  * Host application should be able to limit the maximum and minimum zoom
327    levels. (GNOME Bugzilla #571702)
328  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
329    #572377)
330  * Support proxies. (GNOME Bugzilla #573937)
331  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
332  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
333  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
334    #575139)
335  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
336    (GNOME Bugzilla #575902).
337  * Implemented advanced markers. (GNOME Bugzilla #576055)
338  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
339    #576159)
340  * Any go_to should stop a previous and not yet finished go_to. (GNOME
341    Bugzilla #576832)
342  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
343  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
344    Bugzilla #577169)
345  * Set decel-rate correctly. (GNOME Bugzilla #580785)
346  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
347    #582786)
348  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
349  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
350    Bugzilla #584365)
351  * Make the cache work the first time. (GNOME Bugzilla #584390)
352  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
353    #585698)
354- Added 'BuildRequires: chrpath' for removing rpaths.
355
356* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
357- Version bump to 0.2.9.
358  * Fixed elastic effect.
359  * Reduced exported symbols.
360
361* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
362- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
363
364* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
365- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
366  for all distributions, except Fedora 10.
367- Fixed sample code to not use generic headers.
368
369* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
370- Initial build. Imported SPEC from openSUSE.
371  * Added a new constructor for ChamplainMarkers made of an image.
372  * Double clicking on the map will now zoom and recenter.
373  * When resizing a ChamplainView, the centered content will still be
374    centered after the resizing. Can be disabled.
375  * The Map's license is displayed by default on the lower right corner.
376  * Fixed map centering on startup.
377  * Fixed missing zoom level in OpenStreetMap Mapnik.
378  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.