source: projects/specs/trunk/lib/libc/libchamplain/libchamplain-vl.spec @ 8353

Revision 8353, 13.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define ver     0.12
2
3Summary:        Map view for Clutter
4Summary(ja):    Clutter用のマップビューア
5Name:           libchamplain
6Version:        0.12.7
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group: System Environment/Libraries
10URL: http://projects.gnome.org/libchamplain/
11Source0: http://download.gnome.org/sources/libchamplain/0.12/%{name}-%{version}.tar.xz
12
13Requires: gobject-introspection
14
15BuildRequires: clutter-devel
16BuildRequires: clutter-gtk-devel
17BuildRequires: libsoup-devel
18BuildRequires: sqlite3-devel
19BuildRequires: gtk-doc >= 1.14
20BuildRequires: gobject-introspection-devel >= 0.6.8
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29Libchamplain is a C library aimed to provide a ClutterActor to display
30rasterized maps.
31
32%description -l ja
33Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38
39Requires:       gobject-introspection-devel
40Requires:       clutter-devel
41Requires:       sqlite3-devel
42Requires:       libsoup-devel
43Requires:       %{name} = %{version}-%{release}
44
45%description devel
46This package contains development files for %{name}.
47
48%package        gtk
49Summary:        Gtk+ widget wrapper for %{name}
50Group:          System Environment/Libraries
51
52Requires:       %{name} = %{version}-%{release}
53
54%description gtk
55Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
56into Gtk+ applications.
57
58%package        gtk-devel
59Summary:        Development files for %{name}-gtk
60Group:          Development/Libraries
61
62Requires:       clutter-gtk-devel
63Requires:       gtk2-devel
64Requires:       %{name}-devel = %{version}-%{release}
65Requires:       %{name}-gtk = %{version}-%{release}
66
67%description gtk-devel
68This package contains development files for %{name}-gtk.
69
70%package        vala
71Summary:        Vala bindings for %{name}
72Summary(ja):    %{name} の Vala バインディング
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       %{name}-gtk = %{version}-%{release}
76Requires:       vala
77
78%description    vala
79Vala bindings for %{name}.
80
81%package        docs
82Summary:        Documentation for %{name}
83Summary(ja):    %{name} 用のドキュメント
84Group:          Documentation
85Requires:       %{name} = %{version}-%{release}
86Requires:               gtk-doc
87BuildArch:      noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93%prep
94%setup -q
95
96%build
97%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
98  --enable-introspection=yes --enable-silent-rules
99
100# Omit unused direct shared library dependencies.
101sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
102
103make %{?_smp_mflags}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
109find $RPM_BUILD_ROOT -type f -name "*.la" -delete
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post gtk -p /sbin/ldconfig
119
120%postun gtk -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc AUTHORS
125%doc ChangeLog
126%doc COPYING
127%doc NEWS
128%{_libdir}/girepository-1.0/Champlain-%{ver}.typelib
129%{_libdir}/%{name}-%{ver}.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%doc demos/animated-marker.c
134%doc demos/launcher.c
135%doc demos/markers.c
136%doc demos/markers.h
137%doc demos/polygons.c
138%doc demos/url-marker.c
139%{_datadir}/gir-1.0/Champlain-%{ver}.gir
140%{_libdir}/%{name}-%{ver}.so
141%{_libdir}/pkgconfig/champlain-%{ver}.pc
142
143%dir %{_includedir}/%{name}-%{ver}
144%{_includedir}/%{name}-%{ver}/champlain
145
146%files gtk
147%defattr(-,root,root,-)
148%{_libdir}/girepository-1.0/GtkChamplain-%{ver}.typelib
149%{_libdir}/%{name}-gtk-%{ver}.so.*
150
151%files gtk-devel
152%defattr(-,root,root,-)
153%doc demos/launcher-gtk.c
154%doc demos/markers.c
155%{_datadir}/gir-1.0/GtkChamplain-%{ver}.gir
156%{_libdir}/%{name}-gtk-%{ver}.so
157%{_libdir}/pkgconfig/champlain-gtk-%{ver}.pc
158
159%dir %{_includedir}/%{name}-gtk-%{ver}
160%{_includedir}/%{name}-gtk-%{ver}/champlain-gtk
161
162%files vala
163%defattr(-,root,root,-)
164%{_datadir}/vala/vapi/champlain-%{ver}.vapi
165%{_datadir}/vala/vapi/champlain-gtk-%{ver}.vapi
166
167%files docs
168%defattr(-,root,root,-)
169%{_datadir}/gtk-doc/html/libchamplain-%{ver}
170%{_datadir}/gtk-doc/html/libchamplain-gtk-%{ver}
171
172
173%changelog
174* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
175- new upstream release
176
177* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-2
178- rebuild with VineSeed environment
179
180* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-1
181- new upstream release
182- create vala, docs subpackages
183
184* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
185- new upstream release
186
187* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-3
188- rebuild with cogl-0.14.0
189
190* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-2
191- rebuild with cogl-0.12.0
192
193* Tue Jul 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
194- new upstream release
195
196* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
197- new upstream release
198
199* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
200- new upstream release
201
202* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
203- new upstream release
204
205* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
206- new upstream release
207- add Requires: sqlite3-devel, libsoup-devel (-devel package)
208
209* Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
210- add Requires: sqlite3-devel, libsoup-devel (-devel package)
211- add Requires: gtk2-devel (-gtk-devel package)
212
213* Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
214- new upstream release
215- remove BuildRequires: gir-repository-devel
216- fix %files (change version)
217
218* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
219- rebuild with rpm-4.8.1 for pkg-config file
220
221* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
222- new upstream release
223
224* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
225- new upstream release
226
227* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
228- new upstream release
229- fix BuildRequires: gtk-doc >= 1.14
230- add Requires: clutter-devel (devel package)
231- add Requires: clutter-gtk-devel (gtk-devel package)
232
233* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
234- Initial build for Vine Linux
235- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
236
237
238* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
239- Version bump to 0.4.2.
240  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
241  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
242  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
243  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
244
245* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
246- Version bump to 0.4.1.
247  * Added champlain_view_remove_layer.
248  * ChamplainSelectionLayer now has a "changed" signal.
249  * Added champlain_marker_get_highlighted_text_color,
250    champlain_marker_set_highlighted_text_color and
251    Added champlain_marker_get_highlighted_color.
252  * Fixed slowdowns with big caches.
253  * Don't emit invalid latitude and longitude notifications.
254  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
255    Bugzilla #598106)
256  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
257  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
258
259- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
260  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
261  (GNOME Bugzilla #598942)
262- Explicitly disabled debug code.
263- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
264
265* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
266- Version bump to 0.4.0.
267  * ChamplainView now has keyboard shortcuts (but not when used with
268    GtkChamplainEmbed).
269  * Removed deprecated symbols introduced in 0.3.
270  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
271  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
272  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
273  * Initial center_on should not result on the map being in Antarctica.
274    (GNOME Bugzilla #594963)
275  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
276  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
277
278* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
279- Version bump to 0.3.91.
280  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
281
282* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
283- Version bump to 0.3.90.
284  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
285  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
286
287* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
288- Version bump to 0.3.6.
289  * New marker animation API.
290  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
291  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
292  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
293
294* Sun Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
295- Version bump to 0.3.5.
296  * Marker selection API. (GNOME Bugzilla #577909)
297  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
298  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
299  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
300  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
301
302* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
303- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
304
305* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
306- Version bump to 0.3.3.
307  * Support for custom map sources and listing available map sources.
308  * Smooth movement to a new position. (GNOME Bugzilla #557641)
309  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
310    #557642)
311  * Double click to zoom and center. (GNOME Bugzilla #557644)
312  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
313    #557965)
314  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
315    Bugzilla #558020)
316  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
317  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
318  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
319    #559446)
320  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
321    #561700)
322  * Added disk cache management. (GNOME Bugzillla #568931)
323  * Host application should be able to limit the maximum and minimum zoom
324    levels. (GNOME Bugzilla #571702)
325  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
326    #572377)
327  * Support proxies. (GNOME Bugzilla #573937)
328  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
329  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
330  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
331    #575139)
332  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
333    (GNOME Bugzilla #575902).
334  * Implemented advanced markers. (GNOME Bugzilla #576055)
335  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
336    #576159)
337  * Any go_to should stop a previous and not yet finished go_to. (GNOME
338    Bugzilla #576832)
339  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
340  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
341    Bugzilla #577169)
342  * Set decel-rate correctly. (GNOME Bugzilla #580785)
343  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
344    #582786)
345  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
346  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
347    Bugzilla #584365)
348  * Make the cache work the first time. (GNOME Bugzilla #584390)
349  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
350    #585698)
351- Added 'BuildRequires: chrpath' for removing rpaths.
352
353* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
354- Version bump to 0.2.9.
355  * Fixed elastic effect.
356  * Reduced exported symbols.
357
358* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
359- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
360
361* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
362- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
363  for all distributions, except Fedora 10.
364- Fixed sample code to not use generic headers.
365
366* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
367- Initial build. Imported SPEC from openSUSE.
368  * Added a new constructor for ChamplainMarkers made of an image.
369  * Double clicking on the map will now zoom and recenter.
370  * When resizing a ChamplainView, the centered content will still be
371    centered after the resizing. Can be disabled.
372  * The Map's license is displayed by default on the lower right corner.
373  * Fixed map centering on startup.
374  * Fixed missing zoom level in OpenStreetMap Mapnik.
375  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.