source: projects/specs/trunk/lib/libc/libcdio/libcdio-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 0.80
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7License: GPLv2+
8URL: http://www.gnu.org/software/libcdio/
9
10Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.80.tar.gz
11Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-0.80.tar.gz.sig
12Source2: libcdio-no_date_footer.hml
13Patch1: libcdio-0.80-paranoia-fix.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: pkgconfig doxygen
17BuildRequires: ncurses-devel
18BuildRequires: help2man
19Requires(post): /sbin/ldconfig
20Requires(post): /sbin/install-info
21Requires(preun): /sbin/install-info
22
23# The patch touches Makefile.am files:
24BuildRequires: automake autoconf
25BuildRequires: libtool
26BuildRequires: gettext
27
28
29
30%description
31This library provides an interface for CD-ROM access. It can be used
32by applications that need OS- and device-independent access to CD-ROM
33devices.
34
35%package        devel
36Summary:        Header files and static libraries for %{name}
37Summary(ja):        Header files and static libraries for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description    devel
43This package contains header files and static libraries for %{name}.
44
45
46%prep
47%setup -q
48%patch1 -p1 -b .paranoia_pc
49
50f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
51iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
52
53
54%build
55libtoolize --force  || :
56aclocal  || :
57autoheader  || :
58automake  || :
59autoconf  || :
60%configure \
61        --disable-vcd-info \
62        --disable-dependency-tracking \
63        --disable-cddb \
64        --disable-rpath
65make %{?_smp_mflags}
66cd doc/doxygen
67sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
68cp %{SOURCE2} .
69./run_doxygen
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT
75
76rm -f $RPM_BUILD_ROOT%{_infodir}/dir
77find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
78
79mv $RPM_BUILD_ROOT%{_mandir}/{jp,ja}
80
81rm -rf examples
82mkdir -p examples/C++
83cp -a example/{*.c,README} examples
84cp -a example/C++/{*.cpp,README} examples/C++
85
86
87%check
88# disable test using local CDROM
89%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
90            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
91            test/Makefile
92make check
93
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98
99%post
100/sbin/ldconfig
101/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
102
103%preun
104if [ $1 = 0 ]; then
105        /sbin/install-info --delete %{_infodir}/%{name}.info \
106                %{_infodir}/dir 2>/dev/null || :
107fi
108
109%postun -p /sbin/ldconfig
110
111
112%files
113%defattr(-,root,root,-)
114%doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
115%{_bindir}/*
116%{_libdir}/*.so.*
117%{_infodir}/*
118%{_mandir}/man1/*
119%lang(ja) %{_mandir}/ja/man1/*
120
121
122%files devel
123%defattr(-,root,root,-)
124%doc doc/doxygen/html examples
125%{_includedir}/cdio
126%{_includedir}/cdio++
127%{_libdir}/*.a
128%{_libdir}/*.so
129%{_libdir}/pkgconfig/*.pc
130
131
132%changelog
133* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
134- initial build for Vine Linux
135
136* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
137- added patch enabling libcdio_paranoia.pc
138
139* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
140- updated to 0.80
141- removed upstreamed patches
142- last GPLv2+ release
143
144* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
145- added patch to compile with gcc43
146
147* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
148- fixed security fix (was off by two)
149
150* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
151- updated to 0.79
152- fixes #427197 (Long Joliet file name overflows cdio's buffer)
153- fixes #341981 (multiarch conflicts in libcdio)
154
155* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
156- rebuilt
157
158* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
159- updated to 0.78.2 (#221359) (this time for real)
160
161* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
162- updated to 0.78.2 (#221359)
163
164* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
165- disabled iso9660 test case (fails for some reason with date problems)
166  this seems to be a known problem according to the ChangeLog
167
168* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
169 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
170
171* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
172- Updated to 0.77
173
174* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
175- Rebuilt
176
177* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
178- Rebuilt
179
180* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
181- Updated to 0.76.
182- Included doxygen generated documentation into -devel
183- Included examples into -devel
184
185* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
186- disable test accessing local CDROM drive (#164266)
187
188* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
189- Rebuilt without libcddb dependency (#164270)
190
191* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
192- Rebuilt
193
194* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
195- Updated to 0.75.
196
197* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
198- Updated to 0.74.
199
200* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
201- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
202- Run test suite during build.
203- Install Japanese man pages.
204
205* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
206- Updated to 0.73.
207
208* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
209- Fix FC4 build (#151468).
210- Build with dependency tracking disabled.
211
212* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
213- Updated to 0.70.
214
215* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
216- Updated to 0.69.
217- Removed broken iso-read.
218- Split Requires(pre,post).
219- Added BuildReq pkgconfig.
220
221* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
222- Initial RPM release.
223
Note: See TracBrowser for help on using the repository browser.