source: projects/specs/trunk/lib/libc/libcdio/libcdio-vl.spec @ 1060

Revision 1060, 5.8 KB checked in by inagaki, 14 years ago (diff)

updated: libimobiledevice, libcdio, gvfs

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 0.82
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7License: GPLv2+
8URL: http://www.gnu.org/software/libcdio/
9
10Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
11Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2.sig
12Source2: libcdio-no_date_footer.hml
13Patch1: libcdio-0.80-paranoia-fix.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: pkgconfig doxygen
17BuildRequires: ncurses-devel
18BuildRequires: help2man
19BuildRequires: gcc-c++
20Requires(post): /sbin/install-info
21Requires(preun): /sbin/install-info
22
23%description
24This library provides an interface for CD-ROM access. It can be used
25by applications that need OS- and device-independent access to CD-ROM
26devices.
27
28%package        devel
29Summary:        Development files for %{name}
30Summary(ja):    %{name} の開発用ファイル
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       pkgconfig
34
35%description devel
36This package contains development files for %{name}.
37
38
39%prep
40%setup -q
41#patch1 -p1 -b .paranoia_pc
42
43f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
44iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
45
46%build
47#libtoolize --force  || :
48#aclocal  || :
49#autoheader  || :
50#automake  || :
51#autoconf  || :
52%configure \
53        --disable-vcd-info \
54        --disable-dependency-tracking \
55        --disable-cddb \
56        --disable-rpath \
57        --disable-static
58make %{?_smp_mflags}
59cd doc/doxygen
60sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
61cp %{SOURCE2} .
62./run_doxygen
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_infodir}/dir
70find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
71
72mv $RPM_BUILD_ROOT%{_mandir}/{jp,ja}
73
74rm -rf examples
75mkdir -p examples/C++
76cp -a example/{*.c,README} examples
77cp -a example/C++/{*.cpp,README} examples/C++
78
79
80%check
81# disable test using local CDROM
82%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
83            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
84            test/Makefile
85make check
86
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91
92%post
93/sbin/ldconfig
94/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
95
96%preun
97if [ $1 = 0 ]; then
98        /sbin/install-info --delete %{_infodir}/%{name}.info \
99                %{_infodir}/dir 2>/dev/null || :
100fi
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-,root,root,-)
106%doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
107%{_bindir}/*
108%{_libdir}/*.so.*
109%{_infodir}/*
110%{_mandir}/man1/*
111%lang(ja) %{_mandir}/ja/man1/*
112
113
114%files devel
115%defattr(-,root,root,-)
116%doc doc/doxygen/html examples
117%{_includedir}/cdio
118%{_includedir}/cdio++
119%{_libdir}/*.so
120%{_libdir}/pkgconfig/*.pc
121
122
123%changelog
124* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
125- new upstream release
126- dropt Patch1
127- removed static libraries from devel package
128
129* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
130- initial build for Vine Linux
131
132* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
133- added patch enabling libcdio_paranoia.pc
134
135* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
136- updated to 0.80
137- removed upstreamed patches
138- last GPLv2+ release
139
140* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
141- added patch to compile with gcc43
142
143* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
144- fixed security fix (was off by two)
145
146* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
147- updated to 0.79
148- fixes #427197 (Long Joliet file name overflows cdio's buffer)
149- fixes #341981 (multiarch conflicts in libcdio)
150
151* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
152- rebuilt
153
154* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
155- updated to 0.78.2 (#221359) (this time for real)
156
157* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
158- updated to 0.78.2 (#221359)
159
160* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
161- disabled iso9660 test case (fails for some reason with date problems)
162  this seems to be a known problem according to the ChangeLog
163
164* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
165 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
166
167* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
168- Updated to 0.77
169
170* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
171- Rebuilt
172
173* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
174- Rebuilt
175
176* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
177- Updated to 0.76.
178- Included doxygen generated documentation into -devel
179- Included examples into -devel
180
181* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
182- disable test accessing local CDROM drive (#164266)
183
184* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
185- Rebuilt without libcddb dependency (#164270)
186
187* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
188- Rebuilt
189
190* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
191- Updated to 0.75.
192
193* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
194- Updated to 0.74.
195
196* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
197- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
198- Run test suite during build.
199- Install Japanese man pages.
200
201* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
202- Updated to 0.73.
203
204* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
205- Fix FC4 build (#151468).
206- Build with dependency tracking disabled.
207
208* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
209- Updated to 0.70.
210
211* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
212- Updated to 0.69.
213- Removed broken iso-read.
214- Split Requires(pre,post).
215- Added BuildReq pkgconfig.
216
217* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
218- Initial RPM release.
219
Note: See TracBrowser for help on using the repository browser.