source: projects/specs/trunk/lib/libc/libcdio/libcdio-vl.spec @ 8793

Revision 8793, 5.7 KB checked in by Takemikaduchi, 10 years ago (diff)

libXi, libcdio, libusb1, qt4: new upstream release
others: rebuild

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 0.92
5Release: 1%{?_dist_release}
6
7Group: System Environment/Libraries
8License: GPLv3+
9URL: http://www.gnu.org/software/libcdio/
10
11Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
12Source2: libcdio-no_date_footer.hml
13Patch1: libcdio-0.80-paranoia-fix.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: pkgconfig doxygen
17BuildRequires: ncurses-devel
18BuildRequires: libcddb-devel
19BuildRequires: help2man
20BuildRequires: gcc-c++
21Requires(post): /sbin/install-info
22Requires(preun): /sbin/install-info
23
24%description
25This library provides an interface for CD-ROM access. It can be used
26by applications that need OS- and device-independent access to CD-ROM
27devices.
28
29%package        devel
30Summary:        Development files for %{name}
31Summary(ja):    %{name} の開発用ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description devel
36This package contains development files for %{name}.
37
38
39%prep
40%setup -q
41
42f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
43iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
44
45%build
46%configure \
47    --disable-vcd-info \
48    --disable-dependency-tracking \
49    --disable-rpath \
50    --enable-cddb \
51    --disable-static
52
53make %{?_smp_mflags}
54cd doc/doxygen
55sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
56cp %{SOURCE2} .
57./run_doxygen
58
59
60%install
61rm -rf $RPM_BUILD_ROOT
62make install DESTDIR=$RPM_BUILD_ROOT
63
64rm -f $RPM_BUILD_ROOT%{_infodir}/dir
65find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
66
67rm -rf examples
68mkdir -p examples/C++
69cp -a example/{*.c,README} examples
70cp -a example/C++/{*.cpp,README} examples/C++
71
72
73%check
74# disable test using local CDROM
75%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
76            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
77            test/Makefile
78make check
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%post
86/sbin/ldconfig
87/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
88
89%preun
90if [ $1 = 0 ]; then
91        /sbin/install-info --delete %{_infodir}/%{name}.info \
92                %{_infodir}/dir 2>/dev/null || :
93fi
94
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(-,root,root,-)
99%doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
100%{_bindir}/*
101%{_libdir}/*.so.*
102%{_infodir}/*
103%{_mandir}/man1/*
104
105
106%files devel
107%defattr(-,root,root,-)
108%doc doc/doxygen/html examples
109%{_includedir}/cdio
110%{_includedir}/cdio++
111%{_libdir}/*.so
112%{_libdir}/pkgconfig/*.pc
113
114
115%changelog
116* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
117- update to 0.92
118
119* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
120- rebuilt with rpm-4.8.1 for pkg-config
121- added --enable-cddb
122
123* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
124- new upstream release
125- dropt Patch1
126- removed static libraries from devel package
127
128* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
129- initial build for Vine Linux
130
131* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
132- added patch enabling libcdio_paranoia.pc
133
134* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
135- updated to 0.80
136- removed upstreamed patches
137- last GPLv2+ release
138
139* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
140- added patch to compile with gcc43
141
142* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
143- fixed security fix (was off by two)
144
145* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
146- updated to 0.79
147- fixes #427197 (Long Joliet file name overflows cdio's buffer)
148- fixes #341981 (multiarch conflicts in libcdio)
149
150* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
151- rebuilt
152
153* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
154- updated to 0.78.2 (#221359) (this time for real)
155
156* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
157- updated to 0.78.2 (#221359)
158
159* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
160- disabled iso9660 test case (fails for some reason with date problems)
161  this seems to be a known problem according to the ChangeLog
162
163* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
164 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
165
166* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
167- Updated to 0.77
168
169* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
170- Rebuilt
171
172* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
173- Rebuilt
174
175* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
176- Updated to 0.76.
177- Included doxygen generated documentation into -devel
178- Included examples into -devel
179
180* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
181- disable test accessing local CDROM drive (#164266)
182
183* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
184- Rebuilt without libcddb dependency (#164270)
185
186* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
187- Rebuilt
188
189* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
190- Updated to 0.75.
191
192* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
193- Updated to 0.74.
194
195* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
196- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
197- Run test suite during build.
198- Install Japanese man pages.
199
200* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
201- Updated to 0.73.
202
203* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
204- Fix FC4 build (#151468).
205- Build with dependency tracking disabled.
206
207* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
208- Updated to 0.70.
209
210* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
211- Updated to 0.69.
212- Removed broken iso-read.
213- Split Requires(pre,post).
214- Added BuildReq pkgconfig.
215
216* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
217- Initial RPM release.
218
Note: See TracBrowser for help on using the repository browser.