source: projects/specs/trunk/lib/libc/libcdio/libcdio-vl.spec @ 10500

Revision 10500, 5.9 KB checked in by tomop, 8 years ago (diff)

libcdio-0.93-1

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 0.93
5Release: 1%{?_dist_release}
6
7Group: System Environment/Libraries
8License: GPLv3+
9URL: http://www.gnu.org/software/libcdio/
10
11Vendor: Project Vine
12Distribution: Vine Linux
13
14Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
15Source2: libcdio-no_date_footer.hml
16Patch1: libcdio-0.80-paranoia-fix.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: pkgconfig doxygen
20BuildRequires: ncurses-devel
21BuildRequires: libcddb-devel
22BuildRequires: help2man
23BuildRequires: gcc-c++
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26
27%description
28This library provides an interface for CD-ROM access. It can be used
29by applications that need OS- and device-independent access to CD-ROM
30devices.
31
32%package        devel
33Summary:        Development files for %{name}
34Summary(ja):    %{name} の開発用ファイル
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37
38%description devel
39This package contains development files for %{name}.
40
41
42%prep
43%setup -q
44
45f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
46iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
47
48%build
49%configure \
50    --disable-vcd-info \
51    --disable-dependency-tracking \
52    --disable-rpath \
53    --enable-cddb \
54    --disable-static
55
56make %{?_smp_mflags}
57cd doc/doxygen
58sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
59cp %{SOURCE2} .
60./run_doxygen
61
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install DESTDIR=$RPM_BUILD_ROOT
66
67rm -f $RPM_BUILD_ROOT%{_infodir}/dir
68find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
69
70rm -rf examples
71mkdir -p examples/C++
72cp -a example/{*.c,README} examples
73cp -a example/C++/{*.cpp,README} examples/C++
74
75
76%check
77# disable test using local CDROM
78%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
79            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
80            test/Makefile
81make check
82
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87
88%post
89/sbin/ldconfig
90/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
91
92%preun
93if [ $1 = 0 ]; then
94        /sbin/install-info --delete %{_infodir}/%{name}.info \
95                %{_infodir}/dir 2>/dev/null || :
96fi
97
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
103%{_bindir}/*
104%{_libdir}/*.so.*
105%{_infodir}/*
106%{_mandir}/man1/*
107
108
109%files devel
110%defattr(-,root,root,-)
111%doc doc/doxygen/html examples
112%{_includedir}/cdio
113%{_includedir}/cdio++
114%{_libdir}/*.so
115%{_libdir}/pkgconfig/*.pc
116
117
118%changelog
119* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.93-1
120- updated to 0.93.
121
122* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
123- update to 0.92
124
125* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
126- rebuilt with rpm-4.8.1 for pkg-config
127- added --enable-cddb
128
129* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
130- new upstream release
131- dropt Patch1
132- removed static libraries from devel package
133
134* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
135- initial build for Vine Linux
136
137* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
138- added patch enabling libcdio_paranoia.pc
139
140* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
141- updated to 0.80
142- removed upstreamed patches
143- last GPLv2+ release
144
145* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
146- added patch to compile with gcc43
147
148* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
149- fixed security fix (was off by two)
150
151* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
152- updated to 0.79
153- fixes #427197 (Long Joliet file name overflows cdio's buffer)
154- fixes #341981 (multiarch conflicts in libcdio)
155
156* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
157- rebuilt
158
159* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
160- updated to 0.78.2 (#221359) (this time for real)
161
162* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
163- updated to 0.78.2 (#221359)
164
165* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
166- disabled iso9660 test case (fails for some reason with date problems)
167  this seems to be a known problem according to the ChangeLog
168
169* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
170 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
171
172* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
173- Updated to 0.77
174
175* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
176- Rebuilt
177
178* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
179- Rebuilt
180
181* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
182- Updated to 0.76.
183- Included doxygen generated documentation into -devel
184- Included examples into -devel
185
186* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
187- disable test accessing local CDROM drive (#164266)
188
189* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
190- Rebuilt without libcddb dependency (#164270)
191
192* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
193- Rebuilt
194
195* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
196- Updated to 0.75.
197
198* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
199- Updated to 0.74.
200
201* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
202- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
203- Run test suite during build.
204- Install Japanese man pages.
205
206* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
207- Updated to 0.73.
208
209* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
210- Fix FC4 build (#151468).
211- Build with dependency tracking disabled.
212
213* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
214- Updated to 0.70.
215
216* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
217- Updated to 0.69.
218- Removed broken iso-read.
219- Split Requires(pre,post).
220- Added BuildReq pkgconfig.
221
222* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
223- Initial RPM release.
224
Note: See TracBrowser for help on using the repository browser.