source: projects/specs/trunk/lib/libc/libcapseo/libcapseo-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define capseo_version 0.3.0
2
3# Tarfile created using git
4# git clone git://gitorious.org/capseo/mainline.git libcapseo
5# cd libcapseo
6# git-archive --format=tar --prefix=libcapseo-%{capseo_version}/ %{git_version} | bzip2 > libcapseo-%{capseo_version}-%{gitdate}.tar.bz2
7
8%define gitdate 20081031
9%define git_version 431a293
10
11%define tarfile %{name}-%{capseo_version}-%{gitdate}.tar.bz2
12%define snapshot %{gitdate}git%{git_version}
13
14Summary:        A realtime encoder/decoder library
15Name:           libcapseo
16Version:        %{capseo_version}
17Release:        0.%{snapshot}.1%{?_dist_release}
18License:        GPLv3
19Group:          System Environment/Libraries
20URL:            http://gitorious.org/projects/capseo/
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22BuildRequires:  libtool automake autoconf
23BuildRequires:  pkgconfig
24BuildRequires:  libtheora-devel
25BuildRequires:  libogg-devel
26BuildRequires:  libX11-devel
27BuildRequires:  mesa-libGL-devel
28
29# Fedora specific snapshot no upstream release (yet)
30Source0:        %{tarfile}
31
32%description
33Capseo is a realtime video codec being used by libcaptury/captury
34for encoding captured video frames in realtime. (think of FRAPS codec).
35
36Applications using capseo currently are libcaptury for encoding
37captured data, e.g. currently from third-party OpenGL applications
38via captury, the OpenGL video capturing tool.
39
40%package devel
41Summary: Files needed for development using %{name}
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: libtheora-devel
45Requires: libogg-devel
46Requires: libX11-devel
47Requires: mesa-libGL-devel
48Requires: pkgconfig
49
50%description devel
51This package contains libraries and header files for
52developing applications that use %{name}.
53
54%package tools
55Summary: Encoding/Decoding tools for capseo
56Group: Applications/Multimedia
57Requires: %{name} = %{version}-%{release}
58
59%description tools
60Utilities for capseo
61
62%prep
63%setup -q -n %{name}-%{version}
64./autogen.sh
65
66%build
67%configure --disable-static --enable-theora --disable-examples
68make %{?_smp_mflags}
69
70%install
71rm -rf %{buildroot}
72make install DESTDIR=%{buildroot}
73
74rm -rf %{buildroot}/%{_libdir}/*.la
75
76%clean
77rm -rf %{buildroot}
78
79%post -p /sbin/ldconfig
80
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(-,root,root,-)
85%doc AUTHORS COPYING TODO
86%{_libdir}/*.so.*
87
88%files tools
89%defattr(-,root,root,-)
90%{_bindir}/*
91
92%files devel
93%defattr(-,root,root,-)
94%{_includedir}/*.h
95%{_libdir}/libcapseo.so
96%{_libdir}/pkgconfig/capseo.pc
97
98%changelog
99* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.3.0-0.20081031git431a293.1
100- Initial build for Vine Linux
101
102* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-0.2.20081031git431a293
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
104
105* Fri Nov 14 2008 Shawn Starr <spstarr@fedoraproject.org> 0.3.0-0.1.20081031git431a293
106- New upstream snapshot release 0.3.0
107
108* Thu Oct 2 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.0-0.2.20080603gita6ec446
109- increment Release (#465297)
110
111* Tue Jul 1 2008 Shawn Starr <spstarr@fedoraproject.org> 0.2.0-0.1.20080603gita6ec446
112- Upstream snapshot, change GPLv2 to GPLv3.
113- Fix minor configure script issue.
114
115* Sat May 3 2008 Shawn Starr <shawn.starr@rogers.com> 0.2.0-0.1.20080323git1c5f3e5
116- Initial Fedora package.
Note: See TracBrowser for help on using the repository browser.