source: projects/specs/trunk/lib/libc/libcapseo/libcapseo-vl.spec @ 10570

Revision 10570, 3.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define capseo_version 0.3.0
2
3# Tarfile created using git
4# git clone git://gitorious.org/capseo/mainline.git libcapseo
5# cd libcapseo
6# git-archive --format=tar --prefix=libcapseo-%{capseo_version}/ %{git_version} | bzip2 > libcapseo-%{capseo_version}-%{gitdate}.tar.bz2
7
8%define gitdate 20081031
9%define git_version 431a293
10
11%define tarfile %{name}-%{capseo_version}-%{gitdate}.tar.bz2
12%define snapshot %{gitdate}git%{git_version}
13
14Summary:        A realtime encoder/decoder library
15Name:           libcapseo
16Version:        %{capseo_version}
17Release:        0.%{snapshot}.4%{?_dist_release}
18
19Group:          System Environment/Libraries
20License:        GPLv3
21URL:            http://gitorious.org/projects/capseo/
22
23# Fedora specific snapshot no upstream release (yet)
24Source0:        %{tarfile}
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  libtool automake autoconf
28BuildRequires:  pkgconfig
29BuildRequires:  libtheora-devel
30BuildRequires:  libogg-devel
31BuildRequires:  libX11-devel
32BuildRequires:  mesa-libGL-devel
33
34%description
35Capseo is a realtime video codec being used by libcaptury/captury
36for encoding captured video frames in realtime. (think of FRAPS codec).
37
38Applications using capseo currently are libcaptury for encoding
39captured data, e.g. currently from third-party OpenGL applications
40via captury, the OpenGL video capturing tool.
41
42%package devel
43Summary: Files needed for development using %{name}
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46#Requires: libtheora-devel
47#Requires: libogg-devel
48#Requires: libX11-devel
49#Requires: mesa-libGL-devel
50#Requires: pkgconfig
51
52%description devel
53This package contains libraries and header files for
54developing applications that use %{name}.
55
56%package tools
57Summary: Encoding/Decoding tools for capseo
58Group: Applications/Multimedia
59Requires: %{name} = %{version}-%{release}
60
61%description tools
62Utilities for capseo
63
64%prep
65%setup -q -n %{name}-%{version}
66./autogen.sh
67
68%build
69%configure --disable-static --enable-theora --disable-examples
70make %{?_smp_mflags}
71
72%install
73rm -rf %{buildroot}
74make install DESTDIR=%{buildroot}
75
76rm -rf %{buildroot}/%{_libdir}/*.la
77
78%clean
79rm -rf %{buildroot}
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85%files
86%defattr(-,root,root,-)
87%doc AUTHORS COPYING TODO
88%{_libdir}/*.so.*
89
90%files tools
91%defattr(-,root,root,-)
92%{_bindir}/*
93
94%files devel
95%defattr(-,root,root,-)
96%{_includedir}/*.h
97%{_libdir}/libcapseo.so
98%{_libdir}/pkgconfig/capseo.pc
99
100%changelog
101* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.3.0-0.20081031git431a293.4
102- rebuild with gcc-5.4.0
103
104* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.3.0-0.20081031git431a293.3
105- rebuild with VineSeed environment
106
107* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.3.0-0.20081031git431a293.2
108- rebuilt with rpm-4.8.1
109
110* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.3.0-0.20081031git431a293.1
111- Initial build for Vine Linux
112
113* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-0.2.20081031git431a293
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Fri Nov 14 2008 Shawn Starr <spstarr@fedoraproject.org> 0.3.0-0.1.20081031git431a293
117- New upstream snapshot release 0.3.0
118
119* Thu Oct 2 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.0-0.2.20080603gita6ec446
120- increment Release (#465297)
121
122* Tue Jul 1 2008 Shawn Starr <spstarr@fedoraproject.org> 0.2.0-0.1.20080603gita6ec446
123- Upstream snapshot, change GPLv2 to GPLv3.
124- Fix minor configure script issue.
125
126* Sat May 3 2008 Shawn Starr <shawn.starr@rogers.com> 0.2.0-0.1.20080323git1c5f3e5
127- Initial Fedora package.
Note: See TracBrowser for help on using the repository browser.