source: projects/specs/trunk/lib/libc/libcap/libcap-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.16
7Release: 1%{?_dist_release}
8
9Source: http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/%{name}-%{version}.tar.gz
10
11License: LGPLv2
12Patch0: libcap-2.16-headerfix.patch
13Group: System Environment/Libraries
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libattr-devel
16
17%description
18libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
19draft 15 capabilities.
20
21%package devel
22Summary: Development files for libcap
23Group: Development/Libraries
24Requires: %{name} = %{version}-%{release}
25
26%description devel
27Development files (Headers, libraries for static linking, etc) for libcap.
28
29libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
30draft 15 capabilities.
31
32Install libcap-devel if you want to develop or compile applications using
33libcap.
34
35# compat32
36%package -n compat32-%{name}
37Summary: Library for getting and setting POSIX.1e capabilities
38Group: System Environment/Libraries
39
40%description -n compat32-%{name}
41libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
42draft 15 capabilities.
43
44%package -n compat32-%{name}-devel
45Summary: Development files for libcap
46Group: Development/Libraries
47Requires: compat32-%{name} = %{version}-%{release}
48Requires: %{name}-devel = %{version}-%{release}
49
50%description -n compat32-%{name}-devel
51Development files (Headers, libraries for static linking, etc) for libcap.
52
53libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
54draft 15 capabilities.
55
56Install libcap-devel if you want to develop or compile applications using
57libcap.
58
59%prep
60%setup -q
61%patch0 -p1
62
63%build
64# libcap can not be build with _smp_mflags:
65make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
66     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=${RPM_BUILD_ROOT} \
71             LIBDIR=${RPM_BUILD_ROOT}/%{_lib} \
72             SBINDIR=${RPM_BUILD_ROOT}/%{_sbindir} \
73             INCDIR=${RPM_BUILD_ROOT}/%{_includedir} \
74             MANDIR=${RPM_BUILD_ROOT}/%{_mandir}/ \
75             COPTFLAG="$RPM_OPT_FLAGS"
76mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
77#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
78mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
79
80# remove static lib
81rm -f ${RPM_BUILD_ROOT}/%{_lib}/libcap.a
82
83chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%post -n compat32-%{name} -p /sbin/ldconfig
93
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root)
98%doc doc/capability.notes License
99/%{_lib}/*.so.*
100%{_sbindir}/*
101%{_mandir}/man8/*
102/%{_lib}/security/pam_cap.so
103
104%files devel
105%defattr(-,root,root)
106%{_includedir}/*
107/%{_lib}/*.so
108%{_mandir}/man3/*
109
110# compat32
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root)
114/%{_lib}/*.so.*
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root)
118/%{_lib}/*.so
119%endif
120
121%changelog
122* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
123- new upstream release
124- remove compat library (libpcap-1.10)
125
126* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
127- added compat32 package for x86_64 arch support
128
129* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
130- source updated
131- built with libattr 2.4.41
132
133* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
134- rebuilt
135
136* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
137- initial build for Vine Linux based on FC package
138
139* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
140- build with gcc-4
141
142* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
143- rebuilt
144
145* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
146- Fix wrong typedef in userland patch (#98801)
147
148* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
149- rebuilt
150
151* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
152- rebuilt
153
154* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
155- rebuilt
156
157* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
158- use _manpath
159
160* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
161- rebuilt
162
163* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
164- rebuilt
165
166* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
167- set execute bits on library so that requires are generated.
168
169* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
170- Removed %%name macro sillyness from package Summary, description text, etc.
171- Removed archaic Prefix: tag
172- lib64 fixes everywhere to use _lib, _libdir, etc
173- Removed deletion of RPM_BUILD_DIR from %%clean section
174- Added -q flag to setup macro
175- Severely cleaned up spec file, and removed usage of perl
176
177* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
178- CFLAGS was using COPTFLAG variable, not COPTFLAGS
179- build with -fpic
180- apply the IA-64 patch everywhere, use capget/capset from glibc,
181  not directly as _syscall (as it is broken on IA-32 with -fpic)
182- reenable alpha
183
184* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
185- automated rebuild
186
187* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
188- Exclude alpha for now, apparent gcc bug.
189
190* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
191- Fix sys/capabilities.h header (#55727)
192- Move to /lib, some applications seem to be using this rather early
193  (#55733)
194
195* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
196- Add post,postun scripts
197
198* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
199- don't build libcap.so.1 with ld -shared, but gcc -shared
200
201* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
202- Rebuild - it was missing for alpha
203
204* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
205- add s390/s390x support
206
207* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
208- initial RPM
209- fix build on ia64
Note: See TracBrowser for help on using the repository browser.