source: projects/specs/trunk/lib/libc/libcap/libcap-vl.spec @ 3487

Revision 3487, 6.1 KB checked in by inagaki, 13 years ago (diff)

update: lib{cap,mpcdec,net,njb}, lzo

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.16
7Release: 2%{?_dist_release}
8
9License: LGPLv2
10Group: System Environment/Libraries
11
12Source: http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/%{name}-%{version}.tar.gz
13
14Patch0: libcap-2.16-headerfix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libattr-devel
18
19%description
20libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
21draft 15 capabilities.
22
23%package devel
24Summary: Development files for libcap
25Summary(ja): libcap の開発用ファイル
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30Development files (Headers, libraries for static linking, etc) for libcap.
31
32libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
33draft 15 capabilities.
34
35Install libcap-devel if you want to develop or compile applications using
36libcap.
37
38# compat32
39%package -n compat32-%{name}
40Summary: Library for getting and setting POSIX.1e capabilities
41Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
42Group: System Environment/Libraries
43
44%description -n compat32-%{name}
45libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
46draft 15 capabilities.
47
48%package -n compat32-%{name}-devel
49Summary: Development files for libcap
50Summary(ja): libcap の開発用ファイル
51Group: Development/Libraries
52Requires: compat32-%{name} = %{version}-%{release}
53Requires: %{name}-devel = %{version}-%{release}
54
55%description -n compat32-%{name}-devel
56Development files (Headers, libraries for static linking, etc) for libcap.
57
58libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
59draft 15 capabilities.
60
61Install libcap-devel if you want to develop or compile applications using
62libcap.
63
64%prep
65%setup -q
66%patch0 -p1
67
68%build
69# libcap can not be build with _smp_mflags:
70make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
71     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make install DESTDIR=${RPM_BUILD_ROOT} \
76             LIBDIR=${RPM_BUILD_ROOT}/%{_lib} \
77             SBINDIR=${RPM_BUILD_ROOT}/%{_sbindir} \
78             INCDIR=${RPM_BUILD_ROOT}/%{_includedir} \
79             MANDIR=${RPM_BUILD_ROOT}/%{_mandir}/ \
80             COPTFLAG="$RPM_OPT_FLAGS"
81mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
82#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
83mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
84
85# remove static lib
86rm -f ${RPM_BUILD_ROOT}/%{_lib}/libcap.a
87
88chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98
99%postun -n compat32-%{name} -p /sbin/ldconfig
100
101%files
102%defattr(-,root,root)
103%doc doc/capability.notes License
104/%{_lib}/*.so.*
105%{_sbindir}/*
106%{_mandir}/man8/*
107/%{_lib}/security/pam_cap.so
108
109%files devel
110%defattr(-,root,root)
111%{_includedir}/*
112/%{_lib}/*.so
113%{_mandir}/man3/*
114
115# compat32
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-,root,root)
119/%{_lib}/*.so.*
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root)
123/%{_lib}/*.so
124%endif
125
126%changelog
127* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
128- rebuilt with current VineSeed
129
130* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
131- new upstream release
132- remove compat library (libpcap-1.10)
133
134* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
135- added compat32 package for x86_64 arch support
136
137* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
138- source updated
139- built with libattr 2.4.41
140
141* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
142- rebuilt
143
144* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
145- initial build for Vine Linux based on FC package
146
147* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
148- build with gcc-4
149
150* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
151- rebuilt
152
153* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
154- Fix wrong typedef in userland patch (#98801)
155
156* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
157- rebuilt
158
159* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
160- rebuilt
161
162* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
163- rebuilt
164
165* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
166- use _manpath
167
168* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
169- rebuilt
170
171* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
172- rebuilt
173
174* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
175- set execute bits on library so that requires are generated.
176
177* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
178- Removed %%name macro sillyness from package Summary, description text, etc.
179- Removed archaic Prefix: tag
180- lib64 fixes everywhere to use _lib, _libdir, etc
181- Removed deletion of RPM_BUILD_DIR from %%clean section
182- Added -q flag to setup macro
183- Severely cleaned up spec file, and removed usage of perl
184
185* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
186- CFLAGS was using COPTFLAG variable, not COPTFLAGS
187- build with -fpic
188- apply the IA-64 patch everywhere, use capget/capset from glibc,
189  not directly as _syscall (as it is broken on IA-32 with -fpic)
190- reenable alpha
191
192* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
193- automated rebuild
194
195* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
196- Exclude alpha for now, apparent gcc bug.
197
198* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
199- Fix sys/capabilities.h header (#55727)
200- Move to /lib, some applications seem to be using this rather early
201  (#55733)
202
203* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
204- Add post,postun scripts
205
206* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
207- don't build libcap.so.1 with ld -shared, but gcc -shared
208
209* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
210- Rebuild - it was missing for alpha
211
212* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
213- add s390/s390x support
214
215* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
216- initial RPM
217- fix build on ia64
Note: See TracBrowser for help on using the repository browser.