source: projects/specs/trunk/lib/libc/libcap/libcap-vl.spec @ 9665

Revision 9665, 6.7 KB checked in by iwamoto, 9 years ago (diff)

libcap: update to 2.24 (Thanks to tomop-san)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.24
7Release: 1%{?_dist_release}
8
9License: LGPLv2
10Group: System Environment/Libraries
11
12Source: http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/%{name}-%{version}.tar.xz
13
14# Patch0: libcap-2.16-headerfix.patch
15Patch1: %{name}-2.24-buildflags.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: libattr-devel
19BuildRequires: pam-devel
20
21%description
22libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
23draft 15 capabilities.
24
25%package devel
26Summary: Development files for libcap
27Summary(ja): libcap の開発用ファイル
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32Development files (Headers, libraries for static linking, etc) for libcap.
33
34libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
35draft 15 capabilities.
36
37Install libcap-devel if you want to develop or compile applications using
38libcap.
39
40# compat32
41%package -n compat32-%{name}
42Summary: Library for getting and setting POSIX.1e capabilities
43Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
44Group: System Environment/Libraries
45
46%description -n compat32-%{name}
47libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
48draft 15 capabilities.
49
50%package -n compat32-%{name}-devel
51Summary: Development files for libcap
52Summary(ja): libcap の開発用ファイル
53Group: Development/Libraries
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: %{name}-devel = %{version}-%{release}
56
57%description -n compat32-%{name}-devel
58Development files (Headers, libraries for static linking, etc) for libcap.
59
60libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
61draft 15 capabilities.
62
63Install libcap-devel if you want to develop or compile applications using
64libcap.
65
66%prep
67%setup -q
68# %patch0 -p1
69%patch1 -p1
70
71%build
72# libcap can not be build with _smp_mflags:
73make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
74     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install RAISE_SETFCAP=no \
79             DESTDIR=${RPM_BUILD_ROOT} \
80             LIBDIR=${RPM_BUILD_ROOT}/%{_lib} \
81             SBINDIR=${RPM_BUILD_ROOT}/%{_sbindir} \
82             INCDIR=${RPM_BUILD_ROOT}/%{_includedir} \
83             MANDIR=${RPM_BUILD_ROOT}/%{_mandir}/ \
84             PKGCONFIGDIR=%{buildroot}/%{_libdir}/pkgconfig/ \
85             COPTFLAG="$RPM_OPT_FLAGS"
86mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
87#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
88mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
89
90# remove static lib
91rm -f ${RPM_BUILD_ROOT}/%{_lib}/libcap.a
92
93chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%post -n compat32-%{name} -p /sbin/ldconfig
103
104%postun -n compat32-%{name} -p /sbin/ldconfig
105
106%files
107%defattr(-,root,root)
108%doc doc/capability.notes License
109/%{_lib}/*.so.*
110%{_sbindir}/*
111%{_mandir}/man8/*
112/%{_lib}/security/pam_cap.so
113
114%files devel
115%defattr(-,root,root)
116%{_includedir}/*
117/%{_lib}/*.so
118%{_mandir}/man3/*
119
120# compat32
121%if %{build_compat32}
122%files -n compat32-%{name}
123%defattr(-,root,root)
124/%{_lib}/*.so.*
125
126%files -n compat32-%{name}-devel
127%defattr(-,root,root)
128/%{_lib}/*.so
129%endif
130
131%changelog
132* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
133- new upstream release
134- change tarfile format
135- change flags in install section
136- add patch1, drop patch0 (patch1 from fedora)
137
138* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
139- rebuild with VineSeed environment
140
141* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
142- add BuildRequires: pam-devel
143
144* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
145- rebuilt with current VineSeed
146
147* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
148- new upstream release
149- remove compat library (libpcap-1.10)
150
151* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
152- added compat32 package for x86_64 arch support
153
154* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
155- source updated
156- built with libattr 2.4.41
157
158* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
159- rebuilt
160
161* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
162- initial build for Vine Linux based on FC package
163
164* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
165- build with gcc-4
166
167* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
168- rebuilt
169
170* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
171- Fix wrong typedef in userland patch (#98801)
172
173* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
174- rebuilt
175
176* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
177- rebuilt
178
179* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
180- rebuilt
181
182* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
183- use _manpath
184
185* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
186- rebuilt
187
188* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
189- rebuilt
190
191* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
192- set execute bits on library so that requires are generated.
193
194* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
195- Removed %%name macro sillyness from package Summary, description text, etc.
196- Removed archaic Prefix: tag
197- lib64 fixes everywhere to use _lib, _libdir, etc
198- Removed deletion of RPM_BUILD_DIR from %%clean section
199- Added -q flag to setup macro
200- Severely cleaned up spec file, and removed usage of perl
201
202* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
203- CFLAGS was using COPTFLAG variable, not COPTFLAGS
204- build with -fpic
205- apply the IA-64 patch everywhere, use capget/capset from glibc,
206  not directly as _syscall (as it is broken on IA-32 with -fpic)
207- reenable alpha
208
209* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
210- automated rebuild
211
212* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
213- Exclude alpha for now, apparent gcc bug.
214
215* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
216- Fix sys/capabilities.h header (#55727)
217- Move to /lib, some applications seem to be using this rather early
218  (#55733)
219
220* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
221- Add post,postun scripts
222
223* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
224- don't build libcap.so.1 with ld -shared, but gcc -shared
225
226* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
227- Rebuild - it was missing for alpha
228
229* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
230- add s390/s390x support
231
232* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
233- initial RPM
234- fix build on ia64
Note: See TracBrowser for help on using the repository browser.