source: projects/specs/trunk/lib/libc/libcap/libcap-vl.spec @ 10400

Revision 10400, 7.2 KB checked in by tomop, 8 years ago (diff)

libcap-2.25-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.25
7Release: 1%{?_dist_release}
8
9License: LGPLv2
10Group: System Environment/Libraries
11
12Vendor: Project Vine
13Distribution: Vine Linux
14
15Source: http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/%{name}-%{version}.tar.xz
16Source1: getpcaps.8
17
18
19# Patch0: libcap-2.16-headerfix.patch
20Patch1: %{name}-2.25-buildflags.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: libattr-devel
24BuildRequires: pam-devel
25
26%description
27libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
28draft 15 capabilities.
29
30%package devel
31Summary: Development files for libcap
32Summary(ja): libcap の開発用ファイル
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35
36%description devel
37Development files (Headers, libraries for static linking, etc) for libcap.
38
39libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
40draft 15 capabilities.
41
42Install libcap-devel if you want to develop or compile applications using
43libcap.
44
45%package static
46Summary: static library of libcap
47Summary(ja): libcap のスタティックライブラリ
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description static
52This package includes the static library of libpcap
53
54# compat32
55%package -n compat32-%{name}
56Summary: Library for getting and setting POSIX.1e capabilities
57Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
58Group: System Environment/Libraries
59
60%description -n compat32-%{name}
61libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
62draft 15 capabilities.
63
64%package -n compat32-%{name}-devel
65Summary: Development files for libcap
66Summary(ja): libcap の開発用ファイル
67Group: Development/Libraries
68Requires: compat32-%{name} = %{version}-%{release}
69Requires: %{name}-devel = %{version}-%{release}
70
71%description -n compat32-%{name}-devel
72Development files (Headers, libraries for static linking, etc) for libcap.
73
74libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
75draft 15 capabilities.
76
77Install libcap-devel if you want to develop or compile applications using
78libcap.
79
80%prep
81%setup -q
82# %patch0 -p1
83%patch1 -p1
84
85%build
86# libcap can not be build with _smp_mflags:
87make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
88     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
89
90%install
91rm -rf $RPM_BUILD_ROOT
92make install RAISE_SETFCAP=no \
93             DESTDIR=${RPM_BUILD_ROOT} \
94             LIBDIR=/%{_lib} \
95             SBINDIR=%{_sbindir} \
96             INCDIR=%{_includedir} \
97             MANDIR=%{_mandir}/ \
98             PKGCONFIGDIR=%{_libdir}/pkgconfig/ \
99             COPTFLAG="$RPM_OPT_FLAGS"
100mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
101#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
102mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
103
104chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
105
106# need to build init.lxc.static
107mv %{buildroot}/%{_lib}/libcap.a %{buildroot}/%{_libdir}/libcap.a
108
109cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root)
124%doc doc/capability.notes License
125/%{_lib}/*.so.*
126%{_sbindir}/*
127%{_mandir}/man1/*
128%{_mandir}/man8/*
129/%{_lib}/security/pam_cap.so
130
131%files devel
132%defattr(-,root,root)
133%{_includedir}/*
134/%{_lib}/*.so
135%{_libdir}/pkgconfig/*
136%{_mandir}/man3/*
137
138%files static
139%defattr(-,root,root)
140%{_libdir}/*.a
141
142# compat32
143%if %{build_compat32}
144%files -n compat32-%{name}
145%defattr(-,root,root)
146/%{_lib}/*.so.*
147
148%files -n compat32-%{name}-devel
149%defattr(-,root,root)
150/%{_lib}/*.so
151%endif
152
153%changelog
154* Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25-1
155- new upstream release.
156- added Source1.
157- added libcap-static.
158
159* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
160- new upstream release
161- change tarfile format
162- change flags in install section
163- add patch1, drop patch0 (patch1 from fedora)
164
165* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
166- rebuild with VineSeed environment
167
168* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
169- add BuildRequires: pam-devel
170
171* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
172- rebuilt with current VineSeed
173
174* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
175- new upstream release
176- remove compat library (libpcap-1.10)
177
178* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
179- added compat32 package for x86_64 arch support
180
181* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
182- source updated
183- built with libattr 2.4.41
184
185* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
186- rebuilt
187
188* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
189- initial build for Vine Linux based on FC package
190
191* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
192- build with gcc-4
193
194* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
195- rebuilt
196
197* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
198- Fix wrong typedef in userland patch (#98801)
199
200* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
201- rebuilt
202
203* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
204- rebuilt
205
206* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
207- rebuilt
208
209* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
210- use _manpath
211
212* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
213- rebuilt
214
215* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
216- rebuilt
217
218* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
219- set execute bits on library so that requires are generated.
220
221* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
222- Removed %%name macro sillyness from package Summary, description text, etc.
223- Removed archaic Prefix: tag
224- lib64 fixes everywhere to use _lib, _libdir, etc
225- Removed deletion of RPM_BUILD_DIR from %%clean section
226- Added -q flag to setup macro
227- Severely cleaned up spec file, and removed usage of perl
228
229* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
230- CFLAGS was using COPTFLAG variable, not COPTFLAGS
231- build with -fpic
232- apply the IA-64 patch everywhere, use capget/capset from glibc,
233  not directly as _syscall (as it is broken on IA-32 with -fpic)
234- reenable alpha
235
236* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
237- automated rebuild
238
239* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
240- Exclude alpha for now, apparent gcc bug.
241
242* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
243- Fix sys/capabilities.h header (#55727)
244- Move to /lib, some applications seem to be using this rather early
245  (#55733)
246
247* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
248- Add post,postun scripts
249
250* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
251- don't build libcap.so.1 with ld -shared, but gcc -shared
252
253* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
254- Rebuild - it was missing for alpha
255
256* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
257- add s390/s390x support
258
259* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
260- initial RPM
261- fix build on ia64
Note: See TracBrowser for help on using the repository browser.