source: projects/specs/trunk/lib/libb/libbonobo/libbonobo-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define libxml2_version 2.6.23
2%define orbit2_version 2.14.17
3
4%define po_package libbonobo-2.0
5
6%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
7
8Summary: Bonobo component system
9Summary(ja): Bonobo コンポーネントシステム
10Name: libbonobo
11Version: 2.24.2
12Release: 1%{?_dist_release}
13URL: http://ftp.gnome.org/
14Source0: %{name}-%{version}.tar.bz2
15Patch10: %{name}-2.14.0-i18n-help.patch
16License: LGPL
17Group: System Environment/Libraries
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21Obsoletes: bonobo-activation
22Provides: bonobo-activation
23
24%description
25Bonobo is a component system based on CORBA, used by the GNOME desktop.
26
27%description -l ja
28Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
29システムです。
30
31%package devel
32Summary: Libraries and headers for libbonobo
33Summary: libbonobo のライブラリおよびヘッダ
34Group: Development/Libraries
35Requires:  %{name} = %{version}-%{release}
36Requires:  ORBit2-devel >= %{orbit2_version}
37Requires:  libxml2-devel >= %{libxml2_version}
38Obsoletes: bonobo-activation-devel
39Provides:  bonobo-activation-devel
40Conflicts: bonobo-devel < 1.0.8
41
42%description devel
43Bonobo is a component system based on CORBA, used by the GNOME desktop.
44
45This package contains header files used to compile programs that
46use Bonobo.
47
48%description devel -l ja
49Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
50システムです。
51
52このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
53ヘッダファイルが収録されています。
54
55# compat32
56%package -n compat32-%{name}
57Summary: Bonobo component system
58Summary(ja): Bonobo コンポーネントシステム
59Group: System Environment/Libraries
60Requires:  %{name} = %{version}-%{release}
61
62%description -n compat32-%{name}
63Bonobo is a component system based on CORBA, used by the GNOME desktop.
64
65%description -n compat32-%{name} -l ja
66Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
67システムです。
68
69%package -n compat32-%{name}-devel
70Summary: Libraries and headers for libbonobo
71Summary: libbonobo のライブラリおよびヘッダ
72Group: Development/Libraries
73Requires:  %{name}-devel = %{version}-%{release}
74Requires:  compat32-%{name} = %{version}-%{release}
75Requires:  compat32-ORBit2-devel >= %{orbit2_version}
76Requires:  compat32-libxml2-devel >= %{libxml2_version}
77
78%description -n compat32-%{name}-devel
79Bonobo is a component system based on CORBA, used by the GNOME desktop.
80
81This package contains header files used to compile programs that
82use Bonobo.
83
84%description -n compat32-%{name}-devel -l ja
85Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
86システムです。
87
88このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
89ヘッダファイルが収録されています。
90
91%prep
92%setup -q -n %{name}-%{version}
93#patch1 -p1 -b .env-leak
94%patch10 -p1 -b .i18n-help
95
96%build
97%configure --disable-static
98make
99
100%install
101rm -rf $RPM_BUILD_ROOT
102%makeinstall
103
104## just kill this wherever it lives
105rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
106rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
107                       
108## kill other stuff
109rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
110rm $RPM_BUILD_ROOT%{_libdir}/*.la
111rm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.*a
112rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
113                       
114
115%find_lang %{po_package}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%post -n compat32-%{name} -p /sbin/ldconfig
125
126%postun -n compat32-%{name} -p /sbin/ldconfig
127
128%files -f %{po_package}.lang
129%defattr(-,root,root)
130%doc AUTHORS COPYING ChangeLog NEWS README
131%{_libdir}/lib*.so.*
132%{_libdir}/bonobo
133%{_libdir}/orbit-2.0/*.so*
134%{_bindir}*
135%{_libexecdir}/*
136%{_sbindir}/*
137%dir %{_sysconfdir}/bonobo-activation
138%config %{_sysconfdir}/bonobo-activation/*
139%{_mandir}/man*/*
140
141%files devel
142%defattr(-,root,root)
143#{_libdir}/lib*.a
144%{_libdir}/lib*.so
145%{_libdir}/pkgconfig/*.pc
146%{_includedir}/*
147%{_datadir}/idl
148%{_datadir}/gtk-doc
149
150# compat32
151%if %{build_compat32}
152%files -n compat32-%{name}
153%defattr(-,root,root)
154%{_libdir}/lib*.so.*
155%{_libdir}/bonobo
156%{_libdir}/orbit-2.0/*.so*
157
158%files -n compat32-%{name}-devel
159%defattr(-,root,root)
160#{_libdir}/lib*.a
161%{_libdir}/lib*.so
162%{_libdir}/pkgconfig/*.pc
163%endif
164
165%changelog
166* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
167- new upstream release
168
169* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
170- added --disable-static configure option
171- added compat32 package for x86_64 arch support
172
173* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
174- new upstream release
175
176* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
177- new upstream release
178
179* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
180- new upstream release
181
182* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
183- new upstream release
184
185* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
186- add upstream patch1
187
188* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
189- new upstream release
190
191* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
192- update Patch0 to fix more help message translation.
193
194* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
195- add bindtextdomain_codeset in bonobo-activation initialize
196  to fix corruption of help option message.(Patch0)
197
198* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
199- new upstream release
200
201* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
202- new upstream release
203
204* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
205- new upstream release
206
207* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
208- new upstream release
209
210* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
211- new upstream release
212
213* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
214- new upstream release
215
216* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
217- new upstream release
218
219* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
220- new upstream release
221
222* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
223- new upstream release
224- rebuild with new toolchains
225
226* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
227- new upstream release
228
229* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
230- new upstream release
231
232* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
233- new upstream release
234
235* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
236- new upstream release
237
238* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
239- new upstream release
240
241* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
242- new upstream release
243
244* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
245- build for Vine Linux
246
247* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
248- Fix find_lang
249
250* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
251- rebuild in different environment
252
253* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
254- 2.0.0
255
256* Sun May 26 2002 Tim Powers <timp@redhat.com>
257- automated rebuild
258
259* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
260- rebuild in different environment
261
262* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
263- 1.117.0
264
265* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
266- 1.116.0
267
268* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
269- 1.113.0
270
271* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
272- 1.111.0
273
274* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
275- Version 1.110.0
276- Rebuild for dependencies
277- Intltoolize, the included version has problems with our Perl
278
279* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
280- automake-1.4
281
282* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
283- 1.108.0.90 cvs snap
284
285* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
286- 1.107.0, glib 1.3.11
287
288* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
289- rebuild for new glib, new snap
290
291* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
292- rebuild for new glib
293
294* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
295- move to 1.103.0 tarball
296- call automake after patching Makefile.am
297- patch for parallel install
298
299* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
300- add some requires
301
302* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
303- conflict with bonobo < 1.0.8 to avoid header conflicts
304- update group
305
306* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
307- moved IDL files into subdir
308- remove smp_mflags, libbonobo does not like those
309
310* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
311- remove IDL files as temporary hack
312
313* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
314- Initial build.
315
316
Note: See TracBrowser for help on using the repository browser.