source: projects/specs/trunk/lib/libb/libbonobo/libbonobo-vl.spec @ 8084

Revision 8084, 9.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5
6%define po_package libbonobo-2.0
7
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9
10Summary: Bonobo component system
11Summary(ja): Bonobo コンポーネントシステム
12Name: libbonobo
13Version: 2.32.1
14Release: 2%{?_dist_release}
15URL: http://ftp.gnome.org/
16Source0: %{name}-%{version}.tar.bz2
17
18Patch0: %{name}-2.32.1-GStaticRecMutex.patch
19Patch10: %{name}-2.14.0-i18n-help.patch
20
21License: LGPL
22Group: System Environment/Libraries
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: libxml2-devel >= %{libxml2_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: dbus-devel >= %{dbus_version}
27BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
28BuildRequires: popt-devel
29BuildRequires: flex
30BuildRequires: byacc
31BuildRequires: gtk-doc
32Obsoletes: bonobo-activation
33Provides: bonobo-activation
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Bonobo is a component system based on CORBA, used by the GNOME desktop.
40
41%description -l ja
42Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
43システムです。
44
45%package devel
46Summary: Libraries and headers for libbonobo
47Summary: libbonobo のライブラリおよびヘッダ
48Group: Development/Libraries
49Requires:  %{name} = %{version}-%{release}
50Requires:  ORBit2-devel >= %{orbit2_version}
51Requires:  libxml2-devel >= %{libxml2_version}
52Obsoletes: bonobo-activation-devel
53Provides:  bonobo-activation-devel
54Conflicts: bonobo-devel < 1.0.8
55
56%description devel
57Bonobo is a component system based on CORBA, used by the GNOME desktop.
58
59This package contains header files used to compile programs that
60use Bonobo.
61
62%description devel -l ja
63Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
64システムです。
65
66このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
67ヘッダファイルが収録されています。
68
69# compat32
70%package -n compat32-%{name}
71Summary: Bonobo component system
72Summary(ja): Bonobo コンポーネントシステム
73Group: System Environment/Libraries
74Requires:  %{name} = %{version}-%{release}
75
76%description -n compat32-%{name}
77Bonobo is a component system based on CORBA, used by the GNOME desktop.
78
79%description -n compat32-%{name} -l ja
80Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
81システムです。
82
83%package -n compat32-%{name}-devel
84Summary: Libraries and headers for libbonobo
85Summary: libbonobo のライブラリおよびヘッダ
86Group: Development/Libraries
87Requires:  %{name}-devel = %{version}-%{release}
88Requires:  compat32-%{name} = %{version}-%{release}
89Requires:  compat32-ORBit2-devel >= %{orbit2_version}
90Requires:  compat32-libxml2-devel >= %{libxml2_version}
91
92%description -n compat32-%{name}-devel
93Bonobo is a component system based on CORBA, used by the GNOME desktop.
94
95This package contains header files used to compile programs that
96use Bonobo.
97
98%description -n compat32-%{name}-devel -l ja
99Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
100システムです。
101
102このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
103ヘッダファイルが収録されています。
104
105%prep
106%setup -q -n %{name}-%{version}
107%patch0 -p1 -b .mutex
108%patch10 -p1 -b .i18n-help
109
110%build
111%configure --disable-static
112make
113
114%install
115rm -rf $RPM_BUILD_ROOT
116%makeinstall
117
118## just kill this wherever it lives
119rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
120rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
121                       
122## kill other stuff
123rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
124find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
125find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
126
127%find_lang %{po_package}
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136%post -n compat32-%{name} -p /sbin/ldconfig
137
138%postun -n compat32-%{name} -p /sbin/ldconfig
139
140%files -f %{po_package}.lang
141%defattr(-,root,root)
142%doc AUTHORS COPYING ChangeLog NEWS README
143%{_libdir}/lib*.so.*
144%{_libdir}/bonobo
145%{_libdir}/orbit-2.0/*.so*
146%{_bindir}*
147%{_libexecdir}/*
148%{_sbindir}/*
149%dir %{_sysconfdir}/bonobo-activation
150%config %{_sysconfdir}/bonobo-activation/*
151%{_mandir}/man*/*
152
153%files devel
154%defattr(-,root,root)
155#{_libdir}/lib*.a
156%{_libdir}/lib*.so
157%{_libdir}/pkgconfig/*.pc
158%{_includedir}/*
159%{_datadir}/idl
160%{_datadir}/gtk-doc
161
162# compat32
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(-,root,root)
166%{_libdir}/lib*.so.*
167%{_libdir}/bonobo
168%{_libdir}/orbit-2.0/*.so*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root)
172%{_libdir}/lib*.so
173%endif
174
175%changelog
176* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
177- rebuild with VineSeed environment
178- add Patch0 (libbonobo-2.32.1-GStaticRecMutex.patch)
179
180* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
181- new upstream release
182
183* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
184- new upstream release
185
186* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
187- build with rpm-4.8.1-1 for pkg-config file
188
189* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
190- new upstream release
191- add BuildRequires: dbus-devel, dbus-glib-devel, popt-devel, flex, byacc
192
193* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
194- new upstream release
195
196* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
197- added --disable-static configure option
198- added compat32 package for x86_64 arch support
199
200* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
201- new upstream release
202
203* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
204- new upstream release
205
206* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
207- new upstream release
208
209* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
210- new upstream release
211
212* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
213- add upstream patch1
214
215* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
216- new upstream release
217
218* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
219- update Patch0 to fix more help message translation.
220
221* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
222- add bindtextdomain_codeset in bonobo-activation initialize
223  to fix corruption of help option message.(Patch0)
224
225* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
226- new upstream release
227
228* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
229- new upstream release
230
231* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
232- new upstream release
233
234* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
235- new upstream release
236
237* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
238- new upstream release
239
240* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
241- new upstream release
242
243* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
244- new upstream release
245
246* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
247- new upstream release
248
249* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
250- new upstream release
251- rebuild with new toolchains
252
253* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
254- new upstream release
255
256* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
257- new upstream release
258
259* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
260- new upstream release
261
262* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
263- new upstream release
264
265* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
266- new upstream release
267
268* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
269- new upstream release
270
271* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
272- build for Vine Linux
273
274* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
275- Fix find_lang
276
277* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
278- rebuild in different environment
279
280* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
281- 2.0.0
282
283* Sun May 26 2002 Tim Powers <timp@redhat.com>
284- automated rebuild
285
286* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
287- rebuild in different environment
288
289* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
290- 1.117.0
291
292* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
293- 1.116.0
294
295* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
296- 1.113.0
297
298* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
299- 1.111.0
300
301* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
302- Version 1.110.0
303- Rebuild for dependencies
304- Intltoolize, the included version has problems with our Perl
305
306* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
307- automake-1.4
308
309* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
310- 1.108.0.90 cvs snap
311
312* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
313- 1.107.0, glib 1.3.11
314
315* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
316- rebuild for new glib, new snap
317
318* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
319- rebuild for new glib
320
321* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
322- move to 1.103.0 tarball
323- call automake after patching Makefile.am
324- patch for parallel install
325
326* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
327- add some requires
328
329* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
330- conflict with bonobo < 1.0.8 to avoid header conflicts
331- update group
332
333* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
334- moved IDL files into subdir
335- remove smp_mflags, libbonobo does not like those
336
337* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
338- remove IDL files as temporary hack
339
340* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
341- Initial build.
342
343
Note: See TracBrowser for help on using the repository browser.