source: projects/specs/trunk/lib/libb/libbonobo/libbonobo-vl.spec @ 4616

Revision 4616, 9.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5
6%define po_package libbonobo-2.0
7
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9
10Summary: Bonobo component system
11Summary(ja): Bonobo コンポーネントシステム
12Name: libbonobo
13Version: 2.32.1
14Release: 1%{?_dist_release}
15URL: http://ftp.gnome.org/
16Source0: %{name}-%{version}.tar.bz2
17Patch10: %{name}-2.14.0-i18n-help.patch
18License: LGPL
19Group: System Environment/Libraries
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libxml2-devel >= %{libxml2_version}
22BuildRequires: ORBit2-devel >= %{orbit2_version}
23BuildRequires: dbus-devel >= %{dbus_version}
24BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
25BuildRequires: popt-devel
26BuildRequires: flex
27BuildRequires: byacc
28Obsoletes: bonobo-activation
29Provides: bonobo-activation
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35Bonobo is a component system based on CORBA, used by the GNOME desktop.
36
37%description -l ja
38Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
39システムです。
40
41%package devel
42Summary: Libraries and headers for libbonobo
43Summary: libbonobo のライブラリおよびヘッダ
44Group: Development/Libraries
45Requires:  %{name} = %{version}-%{release}
46Requires:  ORBit2-devel >= %{orbit2_version}
47Requires:  libxml2-devel >= %{libxml2_version}
48Obsoletes: bonobo-activation-devel
49Provides:  bonobo-activation-devel
50Conflicts: bonobo-devel < 1.0.8
51
52%description devel
53Bonobo is a component system based on CORBA, used by the GNOME desktop.
54
55This package contains header files used to compile programs that
56use Bonobo.
57
58%description devel -l ja
59Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
60システムです。
61
62このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
63ヘッダファイルが収録されています。
64
65# compat32
66%package -n compat32-%{name}
67Summary: Bonobo component system
68Summary(ja): Bonobo コンポーネントシステム
69Group: System Environment/Libraries
70Requires:  %{name} = %{version}-%{release}
71
72%description -n compat32-%{name}
73Bonobo is a component system based on CORBA, used by the GNOME desktop.
74
75%description -n compat32-%{name} -l ja
76Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
77システムです。
78
79%package -n compat32-%{name}-devel
80Summary: Libraries and headers for libbonobo
81Summary: libbonobo のライブラリおよびヘッダ
82Group: Development/Libraries
83Requires:  %{name}-devel = %{version}-%{release}
84Requires:  compat32-%{name} = %{version}-%{release}
85Requires:  compat32-ORBit2-devel >= %{orbit2_version}
86Requires:  compat32-libxml2-devel >= %{libxml2_version}
87
88%description -n compat32-%{name}-devel
89Bonobo is a component system based on CORBA, used by the GNOME desktop.
90
91This package contains header files used to compile programs that
92use Bonobo.
93
94%description -n compat32-%{name}-devel -l ja
95Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
96システムです。
97
98このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
99ヘッダファイルが収録されています。
100
101%prep
102%setup -q -n %{name}-%{version}
103#patch1 -p1 -b .env-leak
104%patch10 -p1 -b .i18n-help
105
106%build
107%configure --disable-static
108make
109
110%install
111rm -rf $RPM_BUILD_ROOT
112%makeinstall
113
114## just kill this wherever it lives
115rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
116rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
117                       
118## kill other stuff
119rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
120rm $RPM_BUILD_ROOT%{_libdir}/*.la
121rm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.*a
122rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
123                       
124
125%find_lang %{po_package}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131
132%postun -p /sbin/ldconfig
133
134%post -n compat32-%{name} -p /sbin/ldconfig
135
136%postun -n compat32-%{name} -p /sbin/ldconfig
137
138%files -f %{po_package}.lang
139%defattr(-,root,root)
140%doc AUTHORS COPYING ChangeLog NEWS README
141%{_libdir}/lib*.so.*
142%{_libdir}/bonobo
143%{_libdir}/orbit-2.0/*.so*
144%{_bindir}*
145%{_libexecdir}/*
146%{_sbindir}/*
147%dir %{_sysconfdir}/bonobo-activation
148%config %{_sysconfdir}/bonobo-activation/*
149%{_mandir}/man*/*
150
151%files devel
152%defattr(-,root,root)
153#{_libdir}/lib*.a
154%{_libdir}/lib*.so
155%{_libdir}/pkgconfig/*.pc
156%{_includedir}/*
157%{_datadir}/idl
158%{_datadir}/gtk-doc
159
160# compat32
161%if %{build_compat32}
162%files -n compat32-%{name}
163%defattr(-,root,root)
164%{_libdir}/lib*.so.*
165%{_libdir}/bonobo
166%{_libdir}/orbit-2.0/*.so*
167
168%files -n compat32-%{name}-devel
169%defattr(-,root,root)
170#{_libdir}/lib*.a
171%{_libdir}/lib*.so
172%{_libdir}/pkgconfig/*.pc
173%endif
174
175%changelog
176* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
177- new upstream release
178
179* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
180- new upstream release
181
182* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
183- build with rpm-4.8.1-1 for pkg-config file
184
185* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
186- new upstream release
187- add BuildRequires: dbus-devel, dbus-glib-devel, popt-devel, flex, byacc
188
189* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
190- new upstream release
191
192* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
193- added --disable-static configure option
194- added compat32 package for x86_64 arch support
195
196* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
197- new upstream release
198
199* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
200- new upstream release
201
202* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
203- new upstream release
204
205* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
206- new upstream release
207
208* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
209- add upstream patch1
210
211* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
212- new upstream release
213
214* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
215- update Patch0 to fix more help message translation.
216
217* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
218- add bindtextdomain_codeset in bonobo-activation initialize
219  to fix corruption of help option message.(Patch0)
220
221* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
222- new upstream release
223
224* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
225- new upstream release
226
227* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
228- new upstream release
229
230* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
231- new upstream release
232
233* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
234- new upstream release
235
236* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
237- new upstream release
238
239* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
240- new upstream release
241
242* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
243- new upstream release
244
245* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
246- new upstream release
247- rebuild with new toolchains
248
249* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
250- new upstream release
251
252* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
253- new upstream release
254
255* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
256- new upstream release
257
258* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
259- new upstream release
260
261* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
262- new upstream release
263
264* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
265- new upstream release
266
267* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
268- build for Vine Linux
269
270* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
271- Fix find_lang
272
273* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
274- rebuild in different environment
275
276* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
277- 2.0.0
278
279* Sun May 26 2002 Tim Powers <timp@redhat.com>
280- automated rebuild
281
282* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
283- rebuild in different environment
284
285* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
286- 1.117.0
287
288* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
289- 1.116.0
290
291* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
292- 1.113.0
293
294* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
295- 1.111.0
296
297* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
298- Version 1.110.0
299- Rebuild for dependencies
300- Intltoolize, the included version has problems with our Perl
301
302* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
303- automake-1.4
304
305* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
306- 1.108.0.90 cvs snap
307
308* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
309- 1.107.0, glib 1.3.11
310
311* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
312- rebuild for new glib, new snap
313
314* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
315- rebuild for new glib
316
317* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
318- move to 1.103.0 tarball
319- call automake after patching Makefile.am
320- patch for parallel install
321
322* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
323- add some requires
324
325* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
326- conflict with bonobo < 1.0.8 to avoid header conflicts
327- update group
328
329* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
330- moved IDL files into subdir
331- remove smp_mflags, libbonobo does not like those
332
333* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
334- remove IDL files as temporary hack
335
336* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
337- Initial build.
338
339
Note: See TracBrowser for help on using the repository browser.