source: projects/specs/trunk/lib/libX/libXt/libXt-vl.spec @ 8064

Revision 8064, 10.8 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.1.4
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libSM-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27X.Org X11 libXt runtime library
28
29%package devel
30Summary: X.Org X11 libXt development package
31Group: Development/Libraries
32Requires(pre): xorg-x11-filesystem
33Requires: %{name} = %{version}-%{release}
34Requires: xorg-x11-proto-devel
35Requires: libX11-devel
36Requires: libSM-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXt development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXt runtime library
45Summary(ja): X.Org X11 libXt ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49X.Org X11 libXt runtime library
50
51%package -n compat32-%{name}-devel
52Summary: X.Org X11 libXt development package
53Group: Development/Libraries
54Requires(pre): xorg-x11-filesystem
55Requires: compat32-%{name} = %{version}-%{release}
56Requires: %{name}-devel = %{version}-%{release}
57Requires: compat32-libX11-devel
58Requires: compat32-libSM-devel
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXt development package
62
63%prep
64%setup -q
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70# FIXME: Work around pointer aliasing warnings from compiler for now
71export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
72%configure \
73%if ! %{with_static}
74        --disable-static \
75%endif
76        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
77
78make
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83make install DESTDIR=$RPM_BUILD_ROOT
84# NOTE: Create app-defaults directory so this package can be the canonical
85# owner of the directory.
86mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
87
88# We intentionally don't ship *.la files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc COPYING README ChangeLog
103%{_libdir}/libXt.so.*
104%dir %{_datadir}/X11/app-defaults
105
106%files devel
107%defattr(-,root,root,-)
108%dir %{_includedir}/X11
109# Listed explicitly instead of with glob, in order for rpm to autodetect
110# when any additions or removals happen.  ie: New Xprint support that we
111# do not want.
112%{_includedir}/X11/CallbackI.h
113%{_includedir}/X11/Composite.h
114%{_includedir}/X11/CompositeP.h
115%{_includedir}/X11/ConstrainP.h
116%{_includedir}/X11/Constraint.h
117%{_includedir}/X11/ConvertI.h
118%{_includedir}/X11/Core.h
119%{_includedir}/X11/CoreP.h
120%{_includedir}/X11/CreateI.h
121%{_includedir}/X11/EventI.h
122%{_includedir}/X11/HookObjI.h
123%{_includedir}/X11/InitialI.h
124%{_includedir}/X11/Intrinsic.h
125%{_includedir}/X11/IntrinsicI.h
126%{_includedir}/X11/IntrinsicP.h
127%{_includedir}/X11/Object.h
128%{_includedir}/X11/ObjectP.h
129%{_includedir}/X11/PassivGraI.h
130%{_includedir}/X11/RectObj.h
131%{_includedir}/X11/RectObjP.h
132%{_includedir}/X11/ResConfigP.h
133%{_includedir}/X11/ResourceI.h
134%{_includedir}/X11/SelectionI.h
135%{_includedir}/X11/Shell.h
136%{_includedir}/X11/ShellI.h
137%{_includedir}/X11/ShellP.h
138%{_includedir}/X11/StringDefs.h
139%{_includedir}/X11/ThreadsI.h
140%{_includedir}/X11/TranslateI.h
141%{_includedir}/X11/VarargsI.h
142%{_includedir}/X11/Vendor.h
143%{_includedir}/X11/VendorP.h
144%{_includedir}/X11/Xtos.h
145%if %{with_static}
146%{_libdir}/libXt.a
147%endif
148%{_libdir}/libXt.so
149%{_libdir}/pkgconfig/xt.pc
150%{_datadir}/doc/%{name}
151%{_mandir}/man3/*.3*
152
153# compat32
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-,root,root,-)
157%{_libdir}/libXt.so.6
158%{_libdir}/libXt.so.6.0.0
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root,-)
162%if %{with_static}
163%{_libdir}/libXt.a
164%endif
165%{_libdir}/libXt.so
166%endif
167
168%changelog
169* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-2
170- rebuild with VineSeed environment
171
172* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
173- new upstream release
174  (including security fix for CVE-2013-2002,2005)
175
176* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
177- new upstream release
178
179* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
180- new upstream release
181- add BuildRequires: xorg-x11-util-macros
182
183* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
184- new upstream release
185
186* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
187- new upstream release
188- remove Patch0
189
190* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
191- rebuild with rpm-4.8.1 for pkg-config file
192
193* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
194- new upstream release
195
196* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
197- new upstream release
198
199* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
200- added compat32 package for x86_64 arch support
201
202* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
203- new upstream release
204
205* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
206- new versioning policy
207
208* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
209- initial build for Vine Linux
210
211* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
212- Rebuild for build id
213
214* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
215- Don't install INSTALL
216
217* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
218- Update to 1.0.4
219
220* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
221- rebuild
222
223* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
224- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
225  libXt is the canonical owner of the directory.  Discovered in (#198025).
226
227* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
228- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
229  in the installed pkgconfig file.  Apps should link against libSM if they
230  need it, but we shouldn't force them to link against it if they don't.
231
232* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
233- Updated libXt to version 1.0.2 from X11R7.1
234
235* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
236- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
237
238* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
239- Added "BuildRequires: pkgconfig" for (#193503)
240- Replace "makeinstall" with "make install DESTDIR=..."
241- Remove package ownership of mandir/libdir/etc.
242
243* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
244- Update to 1.0.1
245
246* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
247- bump again for double-long bug on ppc(64)
248
249* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
250- rebuilt for new gcc4.1 snapshot and glibc changes
251
252* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
253- Bumped and rebuilt
254
255* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
256- Updated libXt to version 1.0.0 from X11R7 RC4
257- Added makestrs and it's manpage to the devel subpackage.
258
259* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
260- Updated libXt to version 0.99.3 from X11R7 RC3
261- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
262  that /usr/lib/X11 and /usr/include/X11 pre-exist.
263- Removed 'x' suffix from manpage directories to match RC3 upstream.
264
265* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
266- rebuilt
267
268* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
269- Use the default value from configure.ac for --with-xfile-search-path
270  except with %%{_datadir} instead of $(libdir), so Xt can search for
271  app-default files as usual.
272- Move the --with-xfile-search-path outside the with_static condition.
273
274* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
275- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
276  to make sure Xt is looking in the right place for app-defaults files.
277
278* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
279- Updated libXt to version 0.99.2 from X11R7 RC2
280- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
281- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
282
283* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
284- Actually spell RPM_OPT_FLAGS correctly this time.
285
286* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
287- Build with -fno-strict-aliasing to work around possible pointer aliasing
288  issue
289
290* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
291- Updated libXt to version 0.99.1 from X11R7 RC1
292- Updated file manifest to find manpages in 'man3x'
293
294* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
295- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
296  include Xlib headers causing xterm and other things to fail to compile.
297
298* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
299- Renamed package to remove xorg-x11 from the name due to unanimous decision
300  between developers.
301- Use Fedora Extras style BuildRoot tag.
302- Disable static library creation by default.
303- Add missing defattr to devel subpackage
304- Add missing documentation files to doc macro
305- Fix BuildRequires to use new style X library package names
306
307* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
308- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
309  package names, as we want xorg-x11 libs to explicitly build against
310  X.Org supplied libs, rather than "any implementation", which is what the
311  virtual provides is intended for.
312
313* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
314- Renamed package to prepend "xorg-x11" to the name for consistency with
315  the rest of the X11R7 packages.
316- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
317  subpackage to ensure the devel package matches the installed shared libs.
318- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
319  allow applications to use implementation agnostic dependencies.
320- Added post/postun scripts which call ldconfig.
321- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
322  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
323
324* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
325- Initial build.
Note: See TracBrowser for help on using the repository browser.