source: projects/specs/trunk/lib/libX/libXt/libXt-vl.spec @ 7707

Revision 7707, 10.6 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.1.4
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libSM-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libXt runtime library
24
25%package devel
26Summary: X.Org X11 libXt development package
27Group: Development/Libraries
28Requires(pre): xorg-x11-filesystem
29Requires: %{name} = %{version}-%{release}
30Requires: xorg-x11-proto-devel
31Requires: libX11-devel
32Requires: libSM-devel
33Obsoletes: XFree86-devel, XOrg-devel
34
35%description devel
36X.Org X11 libXt development package
37
38# compat32
39%package -n compat32-%{name}
40Summary: X.Org X11 libXt runtime library
41Summary(ja): X.Org X11 libXt ランタイムライブラリ
42Group: System Environment/Libraries
43
44%description -n compat32-%{name}
45X.Org X11 libXt runtime library
46
47%package -n compat32-%{name}-devel
48Summary: X.Org X11 libXt development package
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53Requires: compat32-libX11-devel
54Requires: compat32-libSM-devel
55
56%description -n compat32-%{name}-devel
57X.Org X11 libXt development package
58
59%prep
60%setup -q
61
62# Disable static library creation by default.
63%define with_static 0
64
65%build
66# FIXME: Work around pointer aliasing warnings from compiler for now
67export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
68%configure \
69%if ! %{with_static}
70        --disable-static \
71%endif
72        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
73
74make
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79make install DESTDIR=$RPM_BUILD_ROOT
80# NOTE: Create app-defaults directory so this package can be the canonical
81# owner of the directory.
82mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc COPYING README ChangeLog
99%{_libdir}/libXt.so.*
100%dir %{_datadir}/X11/app-defaults
101
102%files devel
103%defattr(-,root,root,-)
104%dir %{_includedir}/X11
105# Listed explicitly instead of with glob, in order for rpm to autodetect
106# when any additions or removals happen.  ie: New Xprint support that we
107# do not want.
108%{_includedir}/X11/CallbackI.h
109%{_includedir}/X11/Composite.h
110%{_includedir}/X11/CompositeP.h
111%{_includedir}/X11/ConstrainP.h
112%{_includedir}/X11/Constraint.h
113%{_includedir}/X11/ConvertI.h
114%{_includedir}/X11/Core.h
115%{_includedir}/X11/CoreP.h
116%{_includedir}/X11/CreateI.h
117%{_includedir}/X11/EventI.h
118%{_includedir}/X11/HookObjI.h
119%{_includedir}/X11/InitialI.h
120%{_includedir}/X11/Intrinsic.h
121%{_includedir}/X11/IntrinsicI.h
122%{_includedir}/X11/IntrinsicP.h
123%{_includedir}/X11/Object.h
124%{_includedir}/X11/ObjectP.h
125%{_includedir}/X11/PassivGraI.h
126%{_includedir}/X11/RectObj.h
127%{_includedir}/X11/RectObjP.h
128%{_includedir}/X11/ResConfigP.h
129%{_includedir}/X11/ResourceI.h
130%{_includedir}/X11/SelectionI.h
131%{_includedir}/X11/Shell.h
132%{_includedir}/X11/ShellI.h
133%{_includedir}/X11/ShellP.h
134%{_includedir}/X11/StringDefs.h
135%{_includedir}/X11/ThreadsI.h
136%{_includedir}/X11/TranslateI.h
137%{_includedir}/X11/VarargsI.h
138%{_includedir}/X11/Vendor.h
139%{_includedir}/X11/VendorP.h
140%{_includedir}/X11/Xtos.h
141%if %{with_static}
142%{_libdir}/libXt.a
143%endif
144%{_libdir}/libXt.so
145%{_libdir}/pkgconfig/xt.pc
146%{_datadir}/doc/%{name}
147%{_mandir}/man3/*.3*
148
149# compat32
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-,root,root,-)
153%{_libdir}/libXt.so.6
154%{_libdir}/libXt.so.6.0.0
155
156%files -n compat32-%{name}-devel
157%defattr(-,root,root,-)
158%if %{with_static}
159%{_libdir}/libXt.a
160%endif
161%{_libdir}/libXt.so
162%{_libdir}/pkgconfig/xt.pc
163%endif
164
165%changelog
166* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
167- new upstream release
168  (including security fix for CVE-2013-2002,2005)
169
170* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
171- new upstream release
172
173* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
174- new upstream release
175- add BuildRequires: xorg-x11-util-macros
176
177* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
178- new upstream release
179
180* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
181- new upstream release
182- remove Patch0
183
184* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
185- rebuild with rpm-4.8.1 for pkg-config file
186
187* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
188- new upstream release
189
190* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
191- new upstream release
192
193* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
194- added compat32 package for x86_64 arch support
195
196* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
197- new upstream release
198
199* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
200- new versioning policy
201
202* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
203- initial build for Vine Linux
204
205* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
206- Rebuild for build id
207
208* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
209- Don't install INSTALL
210
211* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
212- Update to 1.0.4
213
214* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
215- rebuild
216
217* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
218- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
219  libXt is the canonical owner of the directory.  Discovered in (#198025).
220
221* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
222- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
223  in the installed pkgconfig file.  Apps should link against libSM if they
224  need it, but we shouldn't force them to link against it if they don't.
225
226* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
227- Updated libXt to version 1.0.2 from X11R7.1
228
229* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
230- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
231
232* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
233- Added "BuildRequires: pkgconfig" for (#193503)
234- Replace "makeinstall" with "make install DESTDIR=..."
235- Remove package ownership of mandir/libdir/etc.
236
237* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
238- Update to 1.0.1
239
240* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
241- bump again for double-long bug on ppc(64)
242
243* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
244- rebuilt for new gcc4.1 snapshot and glibc changes
245
246* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
247- Bumped and rebuilt
248
249* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
250- Updated libXt to version 1.0.0 from X11R7 RC4
251- Added makestrs and it's manpage to the devel subpackage.
252
253* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
254- Updated libXt to version 0.99.3 from X11R7 RC3
255- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
256  that /usr/lib/X11 and /usr/include/X11 pre-exist.
257- Removed 'x' suffix from manpage directories to match RC3 upstream.
258
259* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
260- rebuilt
261
262* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
263- Use the default value from configure.ac for --with-xfile-search-path
264  except with %%{_datadir} instead of $(libdir), so Xt can search for
265  app-default files as usual.
266- Move the --with-xfile-search-path outside the with_static condition.
267
268* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
269- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
270  to make sure Xt is looking in the right place for app-defaults files.
271
272* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
273- Updated libXt to version 0.99.2 from X11R7 RC2
274- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
275- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
276
277* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
278- Actually spell RPM_OPT_FLAGS correctly this time.
279
280* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
281- Build with -fno-strict-aliasing to work around possible pointer aliasing
282  issue
283
284* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
285- Updated libXt to version 0.99.1 from X11R7 RC1
286- Updated file manifest to find manpages in 'man3x'
287
288* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
289- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
290  include Xlib headers causing xterm and other things to fail to compile.
291
292* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
293- Renamed package to remove xorg-x11 from the name due to unanimous decision
294  between developers.
295- Use Fedora Extras style BuildRoot tag.
296- Disable static library creation by default.
297- Add missing defattr to devel subpackage
298- Add missing documentation files to doc macro
299- Fix BuildRequires to use new style X library package names
300
301* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
302- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
303  package names, as we want xorg-x11 libs to explicitly build against
304  X.Org supplied libs, rather than "any implementation", which is what the
305  virtual provides is intended for.
306
307* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
308- Renamed package to prepend "xorg-x11" to the name for consistency with
309  the rest of the X11R7 packages.
310- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
311  subpackage to ensure the devel package matches the installed shared libs.
312- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
313  allow applications to use implementation agnostic dependencies.
314- Added post/postun scripts which call ldconfig.
315- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
316  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
317
318* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
319- Initial build.
Note: See TracBrowser for help on using the repository browser.