source: projects/specs/trunk/lib/libX/libXp/libXp-vl.spec @ 1887

Revision 1887, 8.6 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1# libXp will be removed from future release.
2%define without_devel   0
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: X.Org X11 libXp runtime library
7Summary(ja): X.Org X11 libXp ランタイムライブラリ
8Name: libXp
9Version: 1.0.0
10Release: 4%{?_dist_release}
11License: MIT/X11
12Group: System Environment/Libraries
13URL: http://www.x.org
14
15Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
16Patch0: add-proto-files.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: xorg-x11-util-macros
21BuildRequires: xorg-x11-proto-devel
22BuildRequires: libX11-devel
23BuildRequires: libXext-devel
24BuildRequires: libXau-devel
25BuildRequires: libtool automake autoconf gettext
26Obsoletes: XFree86-libs, XOrg-libs
27
28%description
29X.Org X11 libXp runtime library
30
31%package devel
32Summary: X.Org X11 libXp development package
33Summary(ja): X.Org X11 libXp 開発パッケージ
34Group: Development/Libraries
35Requires(pre): xorg-x11-filesystem
36Requires: libXau-devel
37Requires: %{name} = %{version}-%{release}
38BuildRequires: xorg-x11-proto-devel
39Obsoletes: XFree86-devel, XOrg-devel
40
41%description devel
42X.Org X11 libXp development package
43
44# compat32
45%package -n compat32-%{name}
46Summary: X.Org X11 libXp runtime library
47Summary(ja): X.Org X11 libXp ランタイムライブラリ
48Group: System Environment/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52X.Org X11 libXp runtime library
53
54%package -n compat32-%{name}-devel
55Summary: X.Org X11 libXp development package
56Summary(ja): X.Org X11 libXp 開発パッケージ
57Group: Development/Libraries
58Requires(pre): xorg-x11-filesystem
59Requires: %{name}-devel = %{version}-%{release}
60Requires: compat32-%{name} = %{version}-%{release}
61Requires: compat32-libXau-devel
62
63%description -n compat32-%{name}-devel
64X.Org X11 libXp development package
65
66%prep
67%setup -q
68
69%patch0 -p1 -b .add-proto-files
70
71# Disable static library creation by default.
72%define with_static 0
73
74%build
75
76# There is a patch that changes configure.ac, so we have
77# run autoreconf
78
79CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
80export CPPFLAGS
81
82autoreconf -v --install
83
84%configure \
85%if ! %{with_static}
86        --disable-static
87%endif
88make
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install DESTDIR=$RPM_BUILD_ROOT
94
95%if %{without_devel}
96{
97   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
98   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
99   rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
100   rm -rf $RPM_BUILD_ROOT%{_mandir}
101}
102%endif
103
104# Don't encourage people to use the deprecated Xprint APIs.
105rm -rf $RPM_BUILD_ROOT%{_mandir}
106
107# We intentionally don't ship *.la files
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%post -n compat32-%{name} -p /sbin/ldconfig
117%postun -n compat32-%{name} -p /sbin/ldconfig
118
119%files
120%defattr(-,root,root,-)
121%doc AUTHORS COPYING README INSTALL ChangeLog
122%{_libdir}/libXp.so.6
123%{_libdir}/libXp.so.6.2.0
124
125%if ! %{without_devel}
126%files devel
127%defattr(-,root,root,-)
128%if %{with_static}
129%{_libdir}/libXp.a
130%endif
131%{_includedir}/X11/extensions/Print.h
132%{_includedir}/X11/extensions/Printstr.h
133%{_libdir}/pkgconfig/printproto.pc
134# FIXME: Should we remove the shared lib during deprecation, so that things
135# that keep linking to libXp, will always get the static lib and not break
136# when we eventually drop libXp?
137%{_libdir}/libXp.so
138%{_libdir}/pkgconfig/xp.pc
139#%dir %{_mandir}/man3x
140#%{_mandir}/man3/*.3x*
141%endif
142
143# compat32
144%if %{build_compat32}
145%files -n compat32-%{name}
146%defattr(-,root,root,-)
147%{_libdir}/libXp.so.6
148%{_libdir}/libXp.so.6.2.0
149
150%if ! %{without_devel}
151%files -n compat32-%{name}-devel
152%defattr(-,root,root,-)
153%if %{with_static}
154%{_libdir}/libXp.a
155%endif
156%{_libdir}/pkgconfig/printproto.pc
157# FIXME: Should we remove the shared lib during deprecation, so that things
158# that keep linking to libXp, will always get the static lib and not break
159# when we eventually drop libXp?
160%{_libdir}/libXp.so
161%{_libdir}/pkgconfig/xp.pc
162%endif
163%endif
164
165%changelog
166* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
167- rebuild with rpm-4.8.1 for pkg-config file
168
169* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
170- added compat32 package for x86_64 arch support
171
172* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
173- spec in utf-8
174
175* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
176- new versioning policy
177
178* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
179- initial build for Vine Linux
180
181* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
182- Rebuild for build id
183
184* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
185- rebuilt for unwind info generation, broken in gcc-4.1.1-21
186
187* Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
188- Add requires for the devel package on libXau-devel (173530)
189
190* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
191- Add the proto files directly instead of attempting to build a separate
192  tarball. Also remove last traces of printproto-1.0.3.tar.gz
193
194* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
195- Remove printproto source.
196
197* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
198- BuildRequire autoconf automake libtool gettext
199
200* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
201- Run autoreconf to make sure changes to configure.ac take effect
202
203* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
204- Add patch to not check for printproto.pc. (Since it's part of this
205  package now, it isn't installed at the time libXp is configured).
206
207* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
208- Moved Print.h, Printstr.h and printproto.pc into the devel package here
209  (they used to be in xorg-x11-proto-devel).
210
211* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
212- rebuild
213
214* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
215- Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion.  This
216  library is still deprecated, we just decided to remove the word "deprecated"
217  from the package name for library naming consistency.
218
219* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
220- Replace "makeinstall" with "make install DESTDIR=..."
221- Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
222- Remove package ownership of mandir/libdir/etc.
223
224* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
225- bump again for double-long bug on ppc(64)
226
227* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
228- rebuilt for new gcc4.1 snapshot and glibc changes
229
230* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
231- Bumped and rebuilt
232
233* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
234- Updated libXp to version 1.0.0 from X11R7 RC4
235
236* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
237- Updated libXp to version 0.99.2 from X11R7 RC3
238- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
239  that /usr/lib/X11 and /usr/include/X11 pre-exist.
240- Removed 'x' suffix from manpage directories to match RC3 upstream.
241
242* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
243- rebuilt
244
245* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
246- Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
247  "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
248
249* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
250- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
251- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
252
253* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
254- Updated libXp to version 0.99.1 from X11R7 RC1
255
256* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
257- Renamed package to remove xorg-x11 from the name due to unanimous decision
258  between developers.
259- Use Fedora Extras style BuildRoot tag.
260- Disable static library creation by default.
261- Add missing defattr to devel subpackage
262- Add missing documentation files to doc macro
263
264* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
265- Renamed package to prepend "xorg-x11" to the name for consistency with
266  the rest of the X11R7 packages.
267- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
268  subpackage to ensure the devel package matches the installed shared libs.
269- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
270  allow applications to use implementation agnostic dependencies.
271- Added post/postun scripts which call ldconfig.
272- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
273  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
274
275* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
276- Initial build.
Note: See TracBrowser for help on using the repository browser.