source: projects/specs/trunk/lib/libX/libXmu/libXmu-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXmu/libXmuu runtime libraries
4Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
5Name: libXmu
6Version: 1.0.5
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXt-devel
20BuildRequires: libXau-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23%description
24X.Org X11 libXmu/libXmuu runtime libraries
25
26%package devel
27Summary: X.Org X11 libXmu development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: pkgconfig
32Requires: xorg-x11-util-macros
33Requires: xorg-x11-proto-devel libX11-devel libXt-devel libXext-devel
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libXmu development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libXmu/libXmuu runtime libraries
42Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
43Group: System Environment/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description -n compat32-%{name}
47X.Org X11 libXmu/libXmuu runtime libraries
48
49%package -n compat32-%{name}-devel
50Summary: X.Org X11 libXmu development package
51Group: Development/Libraries
52Requires(pre): xorg-x11-filesystem
53Requires: %{name}-devel = %{version}-%{release}
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: compat32-libX11-devel compat32-libXt-devel compat32-libXext-devel
56
57%description -n compat32-%{name}-devel
58X.Org X11 libXmu development package
59
60%prep
61%setup -q
62
63# Disable static library creation by default.
64%define with_static 0
65
66%build
67%configure \
68%if ! %{with_static}
69        --disable-static
70%endif
71make
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# We intentionally don't ship *.la files
79rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%post -n compat32-%{name} -p /sbin/ldconfig
88%postun -n compat32-%{name} -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%doc AUTHORS COPYING README ChangeLog
93%{_libdir}/libXmu.so.6
94%{_libdir}/libXmu.so.6.2.0
95%{_libdir}/libXmuu.so.1
96%{_libdir}/libXmuu.so.1.0.0
97
98%files devel
99%defattr(-,root,root,-)
100%dir %{_includedir}/X11
101%dir %{_includedir}/X11/Xmu
102%{_includedir}/X11/Xmu/Atoms.h
103%{_includedir}/X11/Xmu/CharSet.h
104%{_includedir}/X11/Xmu/CloseHook.h
105%{_includedir}/X11/Xmu/Converters.h
106%{_includedir}/X11/Xmu/CurUtil.h
107%{_includedir}/X11/Xmu/CvtCache.h
108%{_includedir}/X11/Xmu/DisplayQue.h
109%{_includedir}/X11/Xmu/Drawing.h
110%{_includedir}/X11/Xmu/Editres.h
111%{_includedir}/X11/Xmu/EditresP.h
112%{_includedir}/X11/Xmu/Error.h
113%{_includedir}/X11/Xmu/ExtAgent.h
114%{_includedir}/X11/Xmu/Initer.h
115%{_includedir}/X11/Xmu/Lookup.h
116%{_includedir}/X11/Xmu/Misc.h
117%{_includedir}/X11/Xmu/StdCmap.h
118%{_includedir}/X11/Xmu/StdSel.h
119%{_includedir}/X11/Xmu/SysUtil.h
120%{_includedir}/X11/Xmu/WidgetNode.h
121%{_includedir}/X11/Xmu/WinUtil.h
122%{_includedir}/X11/Xmu/Xct.h
123%{_includedir}/X11/Xmu/Xmu.h
124%if %{with_static}
125%{_libdir}/libXmu.a
126%{_libdir}/libXmuu.a
127%endif
128%{_libdir}/libXmu.so
129%{_libdir}/libXmuu.so
130%{_libdir}/pkgconfig/xmu.pc
131%{_libdir}/pkgconfig/xmuu.pc
132
133# compat32
134%if %{build_compat32}
135%files -n compat32-%{name}
136%defattr(-,root,root,-)
137%{_libdir}/libXmu.so.6
138%{_libdir}/libXmu.so.6.2.0
139%{_libdir}/libXmuu.so.1
140%{_libdir}/libXmuu.so.1.0.0
141
142%files -n compat32-%{name}-devel
143%defattr(-,root,root,-)
144%if %{with_static}
145%{_libdir}/libXmu.a
146%{_libdir}/libXmuu.a
147%endif
148%{_libdir}/libXmu.so
149%{_libdir}/libXmuu.so
150%{_libdir}/pkgconfig/xmu.pc
151%{_libdir}/pkgconfig/xmuu.pc
152%endif
153
154%changelog
155* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
156- new upstream release
157
158* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
159- added compat32 package for x86_64 arch support
160
161* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
162- new upstream release
163
164* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
165- new versioning policy
166
167* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
168- initial build for Vine Linux
169
170* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
171- Rebuild for build id
172
173* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
174- Don't install INSTALL
175
176* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.3-1.fc7
177- Update to 1.0.3
178
179* Fri Oct 13 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-6.fc7
180- Also add Requires for libXext-devel for development package (#210123)
181- Add pkgconfig dependency for -devel package.
182
183* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.2-5
184- Add Requires on libXt (bug 202558)
185
186* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
187- rebuild
188
189* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-4
190- Rebuild, brew doesn't pick up buildroot changes fast enough.
191
192* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-3
193- Rebuild for libXt pkgconfig fixes.
194
195* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
196- Replace "makeinstall" with "make install DESTDIR=..."
197- Added "Requires: xorg-x11-proto-devel, libX11-devel, libXt-devel" to devel
198  subpackage needed by xmu.pc, xmuu.pc
199- Remove package ownership of mandir/libdir/etc.
200
201* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
202- Update to 1.0.2
203
204* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
205- Update to 1.0.1
206
207* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
208- bump again for double-long bug on ppc(64)
209
210* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
211- rebuilt for new gcc4.1 snapshot and glibc changes
212
213* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
214- Bumped and rebuilt
215
216* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
217- Updated libXmu to version 1.0.0 from X11R7 RC4
218
219* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
220- Updated libXmu to version 0.99.2 from X11R7 RC3
221- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
222  that /usr/lib/X11 and /usr/include/X11 pre-exist.
223- Removed 'x' suffix from manpage directories to match RC3 upstream.
224- Added "BuildRequires: pkgconfig, libXau-devel, xorg-x11-util-macros" to
225  fix build dependencies.
226
227* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
228- rebuilt
229
230* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
231- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
232- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
233
234* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
235- Updated libXmu to version 0.99.1 from X11R7 RC1
236
237* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
238- Renamed package to remove xorg-x11 from the name due to unanimous decision
239  between developers.
240- Use Fedora Extras style BuildRoot tag.
241- Disable static library creation by default.
242- Add missing defattr to devel subpackage
243- Add missing documentation files to doc macro
244- Fix BuildRequires to use new style X library package names
245
246* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
247- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
248  package names, as we want xorg-x11 libs to explicitly build against
249  X.Org supplied libs, rather than "any implementation", which is what the
250  virtual provides is intended for.
251
252* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
253- Renamed package to prepend "xorg-x11" to the name for consistency with
254  the rest of the X11R7 packages.
255- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
256  subpackage to ensure the devel package matches the installed shared libs.
257- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
258  allow applications to use implementation agnostic dependencies.
259- Added post/postun scripts which call ldconfig.
260- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
261  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
262
263* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
264- Initial build.
Note: See TracBrowser for help on using the repository browser.