source: projects/specs/trunk/lib/libX/libXmu/libXmu-vl.spec @ 12185

Revision 12185, 8.8 KB checked in by tomop, 5 years ago (diff)

updated X11 libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXmu/libXmuu runtime libraries
4Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
5Name: libXmu
6Version: 1.1.3
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXt-devel
20BuildRequires: libXau-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27X.Org X11 libXmu/libXmuu runtime libraries
28
29%package devel
30Summary: X.Org X11 libXmu development package
31Group: Development/Libraries
32Requires(pre): xorg-x11-filesystem
33Requires: %{name} = %{version}-%{release}
34Requires: pkgconfig
35Requires: xorg-x11-util-macros
36Requires: xorg-x11-proto-devel libX11-devel libXt-devel libXext-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXmu development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXmu/libXmuu runtime libraries
45Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
46Group: System Environment/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description -n compat32-%{name}
50X.Org X11 libXmu/libXmuu runtime libraries
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXmu development package
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem
56Requires: %{name}-devel = %{version}-%{release}
57Requires: compat32-%{name} = %{version}-%{release}
58Requires: compat32-libX11-devel compat32-libXt-devel compat32-libXext-devel
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXmu development package
62
63%prep
64%setup -q
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70%configure \
71%if ! %{with_static}
72        --disable-static
73%endif
74make
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79make install DESTDIR=$RPM_BUILD_ROOT
80
81# We intentionally don't ship *.la files
82rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
83
84# remove xml and txt file
85rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%license COPYING
99%doc AUTHORS README ChangeLog
100%{_libdir}/libXmu.so.6
101%{_libdir}/libXmu.so.6.2.0
102%{_libdir}/libXmuu.so.1
103%{_libdir}/libXmuu.so.1.0.0
104
105%files devel
106%defattr(-,root,root,-)
107%dir %{_includedir}/X11
108%dir %{_includedir}/X11/Xmu
109%{_includedir}/X11/Xmu/Atoms.h
110%{_includedir}/X11/Xmu/CharSet.h
111%{_includedir}/X11/Xmu/CloseHook.h
112%{_includedir}/X11/Xmu/Converters.h
113%{_includedir}/X11/Xmu/CurUtil.h
114%{_includedir}/X11/Xmu/CvtCache.h
115%{_includedir}/X11/Xmu/DisplayQue.h
116%{_includedir}/X11/Xmu/Drawing.h
117%{_includedir}/X11/Xmu/Editres.h
118%{_includedir}/X11/Xmu/EditresP.h
119%{_includedir}/X11/Xmu/Error.h
120%{_includedir}/X11/Xmu/ExtAgent.h
121%{_includedir}/X11/Xmu/Initer.h
122%{_includedir}/X11/Xmu/Lookup.h
123%{_includedir}/X11/Xmu/Misc.h
124%{_includedir}/X11/Xmu/StdCmap.h
125%{_includedir}/X11/Xmu/StdSel.h
126%{_includedir}/X11/Xmu/SysUtil.h
127%{_includedir}/X11/Xmu/WhitePoint.h
128%{_includedir}/X11/Xmu/WidgetNode.h
129%{_includedir}/X11/Xmu/WinUtil.h
130%{_includedir}/X11/Xmu/Xct.h
131%{_includedir}/X11/Xmu/Xmu.h
132%if %{with_static}
133%{_libdir}/libXmu.a
134%{_libdir}/libXmuu.a
135%endif
136%{_libdir}/libXmu.so
137%{_libdir}/libXmuu.so
138%{_libdir}/pkgconfig/xmu.pc
139%{_libdir}/pkgconfig/xmuu.pc
140
141# compat32
142%if %{build_compat32}
143%files -n compat32-%{name}
144%defattr(-,root,root,-)
145%{_libdir}/libXmu.so.6
146%{_libdir}/libXmu.so.6.2.0
147%{_libdir}/libXmuu.so.1
148%{_libdir}/libXmuu.so.1.0.0
149
150%files -n compat32-%{name}-devel
151%defattr(-,root,root,-)
152%if %{with_static}
153%{_libdir}/libXmu.a
154%{_libdir}/libXmuu.a
155%endif
156%{_libdir}/libXmu.so
157%{_libdir}/libXmuu.so
158%endif
159
160%changelog
161* Fri Sep 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.3-1
162- new upstream release.
163
164* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
165- rebuild with VineSeed environment
166
167* Mon Sep 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
168- new upstream release
169
170* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
171- new upstream release
172
173* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
174- new upstream release
175- fix %%install, %%files
176
177* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
178- rebuild with rpm-4.8.1 for pkg-config file
179
180* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
181- new upstream release
182
183* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
184- added compat32 package for x86_64 arch support
185
186* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
187- new upstream release
188
189* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
190- new versioning policy
191
192* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
193- initial build for Vine Linux
194
195* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
196- Rebuild for build id
197
198* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
199- Don't install INSTALL
200
201* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.3-1.fc7
202- Update to 1.0.3
203
204* Fri Oct 13 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-6.fc7
205- Also add Requires for libXext-devel for development package (#210123)
206- Add pkgconfig dependency for -devel package.
207
208* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.2-5
209- Add Requires on libXt (bug 202558)
210
211* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
212- rebuild
213
214* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-4
215- Rebuild, brew doesn't pick up buildroot changes fast enough.
216
217* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-3
218- Rebuild for libXt pkgconfig fixes.
219
220* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
221- Replace "makeinstall" with "make install DESTDIR=..."
222- Added "Requires: xorg-x11-proto-devel, libX11-devel, libXt-devel" to devel
223  subpackage needed by xmu.pc, xmuu.pc
224- Remove package ownership of mandir/libdir/etc.
225
226* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
227- Update to 1.0.2
228
229* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
230- Update to 1.0.1
231
232* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
233- bump again for double-long bug on ppc(64)
234
235* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
236- rebuilt for new gcc4.1 snapshot and glibc changes
237
238* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
239- Bumped and rebuilt
240
241* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
242- Updated libXmu to version 1.0.0 from X11R7 RC4
243
244* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
245- Updated libXmu to version 0.99.2 from X11R7 RC3
246- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
247  that /usr/lib/X11 and /usr/include/X11 pre-exist.
248- Removed 'x' suffix from manpage directories to match RC3 upstream.
249- Added "BuildRequires: pkgconfig, libXau-devel, xorg-x11-util-macros" to
250  fix build dependencies.
251
252* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
253- rebuilt
254
255* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
256- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
257- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
258
259* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
260- Updated libXmu to version 0.99.1 from X11R7 RC1
261
262* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
263- Renamed package to remove xorg-x11 from the name due to unanimous decision
264  between developers.
265- Use Fedora Extras style BuildRoot tag.
266- Disable static library creation by default.
267- Add missing defattr to devel subpackage
268- Add missing documentation files to doc macro
269- Fix BuildRequires to use new style X library package names
270
271* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
272- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
273  package names, as we want xorg-x11 libs to explicitly build against
274  X.Org supplied libs, rather than "any implementation", which is what the
275  virtual provides is intended for.
276
277* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
278- Renamed package to prepend "xorg-x11" to the name for consistency with
279  the rest of the X11R7 packages.
280- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
281  subpackage to ensure the devel package matches the installed shared libs.
282- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
283  allow applications to use implementation agnostic dependencies.
284- Added post/postun scripts which call ldconfig.
285- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
286  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
287
288* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
289- Initial build.
Note: See TracBrowser for help on using the repository browser.