source: projects/specs/trunk/lib/libX/libXext/libXext-vl.spec @ 7707

Revision 7707, 7.0 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXext runtime library
4Summary(ja): X.Org X11 libXext ランタイムライブラリ
5Name: libXext
6Version: 1.3.2
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libXau-devel
20
21Obsoletes: XFree86-libs, XOrg-libs
22
23%description
24X.Org X11 libXext runtime library
25
26%package devel
27Summary: X.Org X11 libXext development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem >= 0.99.2-3
30Requires: %{name} = %{version}-%{release}
31Requires: libX11-devel
32Requires: xorg-x11-proto-devel >= 7.5
33Conflicts: xorg-x11-proto-devel < 7.5
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libXext development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libXext runtime library
42Summary(ja): X.Org X11 libXext ランタイムライブラリ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46X.Org X11 libXext runtime library
47
48%package -n compat32-%{name}-devel
49Summary: X.Org X11 libXext development package
50Group: Development/Libraries
51Requires(pre): xorg-x11-filesystem >= 0.99.2-3
52Requires: compat32-%{name} = %{version}-%{release}
53Requires: %{name}-devel = %{version}-%{release}
54Requires: compat32-libX11-devel
55
56%description -n compat32-%{name}-devel
57X.Org X11 libXext development package
58
59%prep
60%setup -q
61
62# Disable static library creation by default.
63%define with_static 0
64
65%build
66
67%configure \
68%if ! %{with_static}
69        --disable-static
70%endif
71make
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# We intentionally don't ship *.la files
79rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
80
81# remove xml and txt file
82rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%post -n compat32-%{name} -p /sbin/ldconfig
91%postun -n compat32-%{name} -p /sbin/ldconfig
92
93%files
94%defattr(-,root,root,-)
95%doc AUTHORS COPYING README ChangeLog
96%{_libdir}/libXext.so.6
97%{_libdir}/libXext.so.6.4.*
98
99%files devel
100%defattr(-,root,root,-)
101%{_includedir}/X11/extensions/*.h
102%if %{with_static}
103%{_libdir}/libXext.a
104%endif
105%{_libdir}/libXext.so
106%{_libdir}/pkgconfig/xext.pc
107%{_mandir}/man3/*.3*
108
109# compat32
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-,root,root,-)
113%{_libdir}/libXext.so.6
114%{_libdir}/libXext.so.6.4.*
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root,-)
118%if %{with_static}
119%{_libdir}/libXext.a
120%endif
121%{_libdir}/libXext.so
122%{_libdir}/pkgconfig/xext.pc
123%endif
124
125%changelog
126* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
127- new upstream release
128  (including security fix for CVE-2013-1982)
129
130* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
131- new upstream release
132- add BuildRequires: xorg-x11-util-macros
133
134* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
135- new upstream release
136
137* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
138- new upstream release
139
140* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
141- rebuild with rpm-4.8.1 for pkg-config file
142
143* Fri Jul 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-1
144- new upstream release
145
146* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
147- new upstream release
148
149* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
150- new upstream release
151
152* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
153- added compat32 package for x86_64 arch support
154
155* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
156- new upstream release
157
158* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
159- new versioning policy
160
161* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
162- initial build for Vine Linux
163
164* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
165- Rebuild for build id
166
167* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.1-4
168- Don't install INSTALL
169
170* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
171- Force xorg-x11-proto-devel on >= 7.1-10 (for LBX headers), and rebuild.
172
173* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.1
174- rebuild
175
176* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
177- Replace "makeinstall" with "make install DESTDIR=..."
178- Remove package ownership of mandir/libdir/etc.
179
180* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
181- Update to 1.0.1
182
183* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.2
184- bump again for double-long bug on ppc(64)
185
186* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.1
187- rebuilt for new gcc4.1 snapshot and glibc changes
188
189* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
190- Added "Requires: xorg-x11-proto-devel >= 7.0-1" to devel package (#173713)
191- Added "libX11-devel" to devel package (#176078)
192
193* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
194- Bumped and rebuilt
195
196* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
197- Updated libXext to version 1.0.0 from X11R7 RC4
198
199* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
200- Updated libXext to version 0.99.3 from X11R7 RC3
201- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
202  that /usr/lib/X11 and /usr/include/X11 pre-exist.
203- Removed 'x' suffix from manpage directories to match RC3 upstream.
204
205* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
206- rebuilt
207
208* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
209- Updated libXext to version 0.99.2 from X11R7 RC2
210- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
211- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
212
213* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
214- Updated to libXext-0.99.1 from the X11R7 RC1 release.
215- Added manpages that were absent in X11R7 RC0, and updated the file lists
216  to find them in section "man3x".
217
218* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
219- Renamed package to remove xorg-x11 from the name due to unanimous decision
220  between developers.
221- Use Fedora Extras style BuildRoot tag.
222- Disable static library creation by default.
223- Add missing defattr to devel subpackage
224- Add missing documentation files to doc macro
225
226* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
227- Renamed package to prepend "xorg-x11" to the name for consistency with
228  the rest of the X11R7 packages.
229- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
230  subpackage to ensure the devel package matches the installed shared libs.
231- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
232  allow applications to use implementation agnostic dependencies.
233- Added post/postun scripts which call ldconfig.
234- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
235  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
236
237* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
238- Initial build.
Note: See TracBrowser for help on using the repository browser.