source: projects/specs/trunk/lib/libX/libXext/libXext-vl.spec @ 8064

Revision 8064, 7.2 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXext runtime library
4Summary(ja): X.Org X11 libXext ランタイムライブラリ
5Name: libXext
6Version: 1.3.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libXau-devel
20
21Obsoletes: XFree86-libs, XOrg-libs
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28X.Org X11 libXext runtime library
29
30%package devel
31Summary: X.Org X11 libXext development package
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem >= 0.99.2-3
34Requires: %{name} = %{version}-%{release}
35Requires: libX11-devel
36Requires: xorg-x11-proto-devel >= 7.5
37Conflicts: xorg-x11-proto-devel < 7.5
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXext development package
42
43# compat32
44%package -n compat32-%{name}
45Summary: X.Org X11 libXext runtime library
46Summary(ja): X.Org X11 libXext ランタイムライブラリ
47Group: System Environment/Libraries
48
49%description -n compat32-%{name}
50X.Org X11 libXext runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXext development package
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem >= 0.99.2-3
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-libX11-devel
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXext development package
62
63%prep
64%setup -q
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# We intentionally don't ship *.la files
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85# remove xml and txt file
86rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97%files
98%defattr(-,root,root,-)
99%doc AUTHORS COPYING README ChangeLog
100%{_libdir}/libXext.so.6
101%{_libdir}/libXext.so.6.4.*
102
103%files devel
104%defattr(-,root,root,-)
105%{_includedir}/X11/extensions/*.h
106%if %{with_static}
107%{_libdir}/libXext.a
108%endif
109%{_libdir}/libXext.so
110%{_libdir}/pkgconfig/xext.pc
111%{_mandir}/man3/*.3*
112
113# compat32
114%if %{build_compat32}
115%files -n compat32-%{name}
116%defattr(-,root,root,-)
117%{_libdir}/libXext.so.6
118%{_libdir}/libXext.so.6.4.*
119
120%files -n compat32-%{name}-devel
121%defattr(-,root,root,-)
122%if %{with_static}
123%{_libdir}/libXext.a
124%endif
125%{_libdir}/libXext.so
126%endif
127
128%changelog
129* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
130- rebuild with VineSeed environment
131
132* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
133- new upstream release
134  (including security fix for CVE-2013-1982)
135
136* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
137- new upstream release
138- add BuildRequires: xorg-x11-util-macros
139
140* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
141- new upstream release
142
143* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
144- new upstream release
145
146* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
147- rebuild with rpm-4.8.1 for pkg-config file
148
149* Fri Jul 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-1
150- new upstream release
151
152* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
153- new upstream release
154
155* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
156- new upstream release
157
158* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
159- added compat32 package for x86_64 arch support
160
161* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
162- new upstream release
163
164* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
165- new versioning policy
166
167* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
168- initial build for Vine Linux
169
170* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
171- Rebuild for build id
172
173* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.1-4
174- Don't install INSTALL
175
176* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
177- Force xorg-x11-proto-devel on >= 7.1-10 (for LBX headers), and rebuild.
178
179* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.1
180- rebuild
181
182* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
183- Replace "makeinstall" with "make install DESTDIR=..."
184- Remove package ownership of mandir/libdir/etc.
185
186* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
187- Update to 1.0.1
188
189* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.2
190- bump again for double-long bug on ppc(64)
191
192* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.1
193- rebuilt for new gcc4.1 snapshot and glibc changes
194
195* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
196- Added "Requires: xorg-x11-proto-devel >= 7.0-1" to devel package (#173713)
197- Added "libX11-devel" to devel package (#176078)
198
199* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
200- Bumped and rebuilt
201
202* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
203- Updated libXext to version 1.0.0 from X11R7 RC4
204
205* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
206- Updated libXext to version 0.99.3 from X11R7 RC3
207- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
208  that /usr/lib/X11 and /usr/include/X11 pre-exist.
209- Removed 'x' suffix from manpage directories to match RC3 upstream.
210
211* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
212- rebuilt
213
214* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
215- Updated libXext to version 0.99.2 from X11R7 RC2
216- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
217- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
218
219* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
220- Updated to libXext-0.99.1 from the X11R7 RC1 release.
221- Added manpages that were absent in X11R7 RC0, and updated the file lists
222  to find them in section "man3x".
223
224* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
225- Renamed package to remove xorg-x11 from the name due to unanimous decision
226  between developers.
227- Use Fedora Extras style BuildRoot tag.
228- Disable static library creation by default.
229- Add missing defattr to devel subpackage
230- Add missing documentation files to doc macro
231
232* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
233- Renamed package to prepend "xorg-x11" to the name for consistency with
234  the rest of the X11R7 packages.
235- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
236  subpackage to ensure the devel package matches the installed shared libs.
237- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
238  allow applications to use implementation agnostic dependencies.
239- Added post/postun scripts which call ldconfig.
240- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
241  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
242
243* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
244- Initial build.
Note: See TracBrowser for help on using the repository browser.