source: projects/specs/trunk/lib/libI/libIDL/libIDL-vl.spec @ 521

Revision 521, 6.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for parsing IDL (Interface Definition Language)
4Summary(ja): IDL (インターフェース定義言語) 解析ライブラリ
5Name: libIDL
6Version: 0.8.13
7Release: 2%{?_dist_release}
8Source: ftp://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/%{name}-%{version}.tar.bz2
9Group: System Environment/Libraries
10License: LGPL
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig >= 0.8
13BuildRequires: glib2-devel >= 2.0
14
15%description
16libIDL is a library for parsing IDL (Interface Definition Language).
17It can be used for both COM-style and CORBA-style IDL.
18
19%description -l ja
20libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
21COM形式とCORBA形式の両方のIDLで利用することができます.
22
23%package devel
24Summary: Development libraries and header files for libIDL
25Summary(ja): libIDL の開発用ライブラリとヘッダファイル
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28Requires: pkgconfig >= 0.8
29Requires: glib2-devel >= 2.0
30Requires(post): /sbin/install-info
31Requires(preun): /sbin/install-info
32
33%description devel
34libIDL is a library for parsing IDL (Interface Definition Language).
35It can be used for both COM-style and CORBA-style IDL.
36
37This package contains the header files and libraries needed to write
38or compile programs that use libIDL.
39
40# compat32
41%package -n compat32-%{name}
42Summary: Development libraries and header files for libIDL
43Summary(ja): libIDL の開発用ライブラリとヘッダファイル
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description -n compat32-%{name}
48libIDL is a library for parsing IDL (Interface Definition Language).
49It can be used for both COM-style and CORBA-style IDL.
50
51%description -n compat32-%{name} -l ja
52libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
53COM形式とCORBA形式の両方のIDLで利用することができます.
54
55%package -n compat32-%{name}-devel
56Summary: Development libraries and header files for libIDL
57Summary(ja): libIDL の開発用ライブラリとヘッダファイル
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60Requires: compat32-%{name} = %{version}-%{release}
61Requires: compat32-glib2-devel >= 2.0
62Requires(post): /sbin/install-info
63Requires(preun): /sbin/install-info
64
65%description -n compat32-%{name}-devel
66libIDL is a library for parsing IDL (Interface Definition Language).
67It can be used for both COM-style and CORBA-style IDL.
68
69This package contains the header files and libraries needed to write
70or compile programs that use libIDL.
71
72%prep
73%setup -q -n %{name}-%{version}
74
75%build
76%configure --disable-static
77make %{?_smp_mflags}
78
79%install
80rm -rf %{buildroot}
81%makeinstall
82
83rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
84rm -f $RPM_BUILD_ROOT%{_infodir}/dir
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%post -n compat32-%{name} -p /sbin/ldconfig
91
92%postun -n compat32-%{name} -p /sbin/ldconfig
93
94%post devel
95/sbin/install-info --quiet %{_infodir}/libIDL2.info.gz %{_infodir}/dir
96
97%preun devel
98if [ $1 = 0 ]; then
99   /sbin/install-info --quiet --delete %{_infodir}/libIDL2.info.gz %{_infodir}/dir
100fi
101
102%clean
103rm -rf %{buildroot}
104
105%files
106%doc AUTHORS COPYING README NEWS
107%defattr(-,root,root)
108%{_libdir}/lib*.so.*
109
110%files devel
111%defattr(-,root,root)
112%{_bindir}/libIDL-config-2
113%{_includedir}/*
114%{_libdir}/%{name}-2.so
115%{_libdir}/pkgconfig/*.pc
116%{_infodir}/libIDL2.info.gz
117
118# compat32
119%if %{build_compat32}
120%files -n compat32-%{name}
121%defattr(-,root,root)
122%{_libdir}/lib*.so.*
123
124%files -n compat32-%{name}-devel
125%defattr(-,root,root)
126%{_libdir}/%{name}-2.so
127%{_libdir}/pkgconfig/*.pc
128%endif
129
130%changelog
131* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.8.13-2
132- added compat32 package for x86_64 arch support
133
134* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.13-1
135- new upstream release
136- removed static library
137
138* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-1
139- new upstream release
140- spec in UTF-8
141
142* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.10-2vl5
143- dropt libIDL-2.la
144
145* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-1vl5
146- new upstream release
147
148* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
149- new upstream release
150
151* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
152- new upstream release
153
154* Wed Aug  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.7-0vl1
155- new upstream release
156
157* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-0vl1
158- new upstream release
159
160* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.5-0vl1
161- new upstream release
162
163* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.4-0vl1
164- new upstream release
165
166* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl2
167- rebuild with new toolchains
168
169* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl1
170- new upstream release
171- add Japanese summary and description
172
173* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
174- build for Vine Linux
175
176* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
177- 0.8.0
178
179* Sun May 26 2002 Tim Powers <timp@redhat.com>
180- automated rebuild
181
182* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
183- rebuild in different environment
184
185* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
186- rebuild in different environment
187
188* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
189- move include files to -devel
190- other spec file tweaks
191
192* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
193- 0.7.4
194
195* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
196- automated rebuild
197
198* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
199- cvs snap 0.7.1.91
200
201* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
202- cvs snap, rebuild on new glib 1.3.11
203
204* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
205- glib 1.3.10
206
207* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
208- rebuild for new glib
209
210* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
211- initial build of standalone libIDL
212- fix braindamage
213
Note: See TracBrowser for help on using the repository browser.