source: projects/specs/trunk/lib/libI/libIDL/libIDL-vl.spec @ 8073

Revision 8073, 6.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for parsing IDL (Interface Definition Language)
4Summary(ja): IDL (インターフェース定義言語) 解析ライブラリ
5Name: libIDL
6Version: 0.8.14
7Release: 3%{?_dist_release}
8Source: ftp://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/%{name}-%{version}.tar.bz2
9Group: System Environment/Libraries
10License: LGPL
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig >= 0.8
13BuildRequires: glib2-devel >= 2.0
14BuildRequires: flex bison
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20libIDL is a library for parsing IDL (Interface Definition Language).
21It can be used for both COM-style and CORBA-style IDL.
22
23%description -l ja
24libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
25COM形式とCORBA形式の両方のIDLで利用することができます.
26
27%package devel
28Summary: Development libraries and header files for libIDL
29Summary(ja): libIDL の開発用ライブラリとヘッダファイル
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: pkgconfig >= 0.8
33Requires: glib2-devel >= 2.0
34Requires(post): /sbin/install-info
35Requires(preun): /sbin/install-info
36
37%description devel
38libIDL is a library for parsing IDL (Interface Definition Language).
39It can be used for both COM-style and CORBA-style IDL.
40
41This package contains the header files and libraries needed to write
42or compile programs that use libIDL.
43
44# compat32
45%package -n compat32-%{name}
46Summary: Development libraries and header files for libIDL
47Summary(ja): libIDL の開発用ライブラリとヘッダファイル
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52libIDL is a library for parsing IDL (Interface Definition Language).
53It can be used for both COM-style and CORBA-style IDL.
54
55%description -n compat32-%{name} -l ja
56libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
57COM形式とCORBA形式の両方のIDLで利用することができます.
58
59%package -n compat32-%{name}-devel
60Summary: Development libraries and header files for libIDL
61Summary(ja): libIDL の開発用ライブラリとヘッダファイル
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64Requires: compat32-%{name} = %{version}-%{release}
65Requires: compat32-glib2-devel >= 2.0
66Requires(post): /sbin/install-info
67Requires(preun): /sbin/install-info
68
69%description -n compat32-%{name}-devel
70libIDL is a library for parsing IDL (Interface Definition Language).
71It can be used for both COM-style and CORBA-style IDL.
72
73This package contains the header files and libraries needed to write
74or compile programs that use libIDL.
75
76%prep
77%setup -q -n %{name}-%{version}
78
79%build
80%configure --disable-static
81make %{?_smp_mflags}
82
83%install
84rm -rf %{buildroot}
85%makeinstall
86
87rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
88rm -f $RPM_BUILD_ROOT%{_infodir}/dir
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95
96%postun -n compat32-%{name} -p /sbin/ldconfig
97
98%post devel
99/sbin/install-info --quiet %{_infodir}/libIDL2.info.gz %{_infodir}/dir
100
101%preun devel
102if [ $1 = 0 ]; then
103   /sbin/install-info --quiet --delete %{_infodir}/libIDL2.info.gz %{_infodir}/dir
104fi
105
106%clean
107rm -rf %{buildroot}
108
109%files
110%doc AUTHORS COPYING README NEWS
111%defattr(-,root,root)
112%{_libdir}/lib*.so.*
113
114%files devel
115%defattr(-,root,root)
116%{_bindir}/libIDL-config-2
117%{_includedir}/*
118%{_libdir}/%{name}-2.so
119%{_libdir}/pkgconfig/*.pc
120%{_infodir}/libIDL2.info.gz
121
122# compat32
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root)
126%{_libdir}/lib*.so.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root)
130%{_libdir}/%{name}-2.so
131%{_libdir}/pkgconfig/*.pc
132%endif
133
134%changelog
135* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.14-3
136- rebuild with VineSeed environment
137
138* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> - 0.8.14-2
139- build with rpm-4.8.1-1 for pkg-config file
140
141* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.14-1
142- new upstream release
143
144* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.8.13-2
145- added compat32 package for x86_64 arch support
146
147* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.13-1
148- new upstream release
149- removed static library
150
151* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-1
152- new upstream release
153- spec in UTF-8
154
155* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.10-2vl5
156- dropt libIDL-2.la
157
158* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-1vl5
159- new upstream release
160
161* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
162- new upstream release
163
164* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
165- new upstream release
166
167* Wed Aug  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.7-0vl1
168- new upstream release
169
170* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-0vl1
171- new upstream release
172
173* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.5-0vl1
174- new upstream release
175
176* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.4-0vl1
177- new upstream release
178
179* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl2
180- rebuild with new toolchains
181
182* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl1
183- new upstream release
184- add Japanese summary and description
185
186* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
187- build for Vine Linux
188
189* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
190- 0.8.0
191
192* Sun May 26 2002 Tim Powers <timp@redhat.com>
193- automated rebuild
194
195* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
196- rebuild in different environment
197
198* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
199- rebuild in different environment
200
201* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
202- move include files to -devel
203- other spec file tweaks
204
205* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
206- 0.7.4
207
208* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
212- cvs snap 0.7.1.91
213
214* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
215- cvs snap, rebuild on new glib 1.3.11
216
217* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
218- glib 1.3.10
219
220* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
221- rebuild for new glib
222
223* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
224- initial build of standalone libIDL
225- fix braindamage
226
Note: See TracBrowser for help on using the repository browser.