source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 8067

Revision 8067, 8.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define _fontdir %{_datadir}/fonts/%{name}
2
3%define texmf           %{_datadir}/texmf
4%define build_texmf     %{buildroot}%{texmf}
5
6%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
7
8Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
9Summary(ja): LaTeX 形式で保存できるワードプロセッサ
10Name: lyx
11Version: 2.0.6
12Release: 1%{?_dist_release}
13License: GPLv2+
14Group: Applications/Editors
15URL: http://www.lyx.org/
16Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
17
18Source1: lyxrc.dist
19Source10: lyx.desktop
20
21## upstreamable patches
22# submitted, but upstream rejected it.  we currently agree to disagree.
23Patch50: lyx-2.0.6-xdg_open.patch
24
25## vine
26# reverted checkLatex to lyx-1.6.5
27Patch100: lyx-2.0.1-configurepy-vine.patch
28
29
30# BuildRequires: aiksaurus-devel
31# BuildRequires:   aspell-devel
32BuildRequires:   enchant-devel
33BuildRequires:   hunspell-devel
34BuildRequires:   libboost-devel
35BuildRequires:   libboost-filesystem
36BuildRequires:   libboost-signals
37BuildRequires:   libboost-regex
38BuildRequires:   desktop-file-utils
39BuildRequires:   gettext
40BuildRequires:   python
41BuildRequires:   xorg-x11-devel
42BuildRequires:   qt4-devel
43BuildRequires:   libpng-devel
44BuildRequires:   glib2-devel
45BuildRequires:   zlib-devel
46
47Requires(post):  texlive-common
48Requires(postun): texlive-common
49Requires:        ghostscript
50Requires:        python
51
52# optional minimal qt4 dep
53%{?_qt_version:Requires: qt4 >= %{_qt4_version}}
54
55Requires:        %{name}-fonts = %{version}-%{release}
56
57Requires:        xdg-utils
58Requires:        rcs
59
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62Vendor:       Project Vine
63Distribution: Vine Linux
64
65
66%description
67LyX is a modern approach to writing documents which breaks with the
68obsolete "typewriter paradigm" of most other document preparation
69systems.
70
71It is designed for people who want professional quality output
72with a minimum of time and effort, without becoming specialists in
73typesetting.
74
75The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
76That is, the author focuses on content, not on the details of formatting.
77This allows for greater productivity, and leaves the final typesetting
78to the backends (like LaTeX) that are specifically designed for the task.
79
80With LyX, the author can concentrate on the contents of his writing,
81and let the computer take care of the rest.
82
83This is LyX built with the Qt frontend.
84
85%description -l ja
86LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
87特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
88してあります。
89
90
91%package fonts
92Summary: Lyx/MathML fonts
93Group:   User Interface/X
94# The actual license says "The author of these fonts, Basil K. Malyshev, has
95# kindly granted permission to use and modify these fonts."
96# One of the font files (wasy10) is separately licensed GPL+.
97License: Copyright only and GPL+
98Obsoletes:       latex-xft-fonts
99BuildArch: noarch
100%description  fonts
101A collection of Math symbol fonts for %{name}.
102
103
104%prep
105%setup -q
106
107%patch50 -p1 -b .xdg_open
108%patch100 -p1 -b .vine
109
110#./autogen.sh
111
112
113%build
114%configure \
115    --disable-dependency-tracking \
116    --disable-rpath \
117    --enable-build-type=release \
118    --disable-debug \
119    --enable-optimization="%{optflags}" \
120    --without-included-boost \
121    --disable-stdlib-debug \
122    --enable-shared \
123    --disable-static \
124    \
125    --with-frontend=qt4 \
126    --without-aiksaurus \
127    --with-enchant \
128    --with-hunspell \
129    ;
130%__make %{?_smp_mflags}
131
132# # make sure all .gmo files are regenerated from .po files
133# (cd po; make update-gmo)
134
135
136%install
137%__rm -rf ${RPM_BUILD_ROOT}
138%__make DESTDIR=${RPM_BUILD_ROOT} install
139
140# misc/extras
141%__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
142
143# Set up the lyx-specific class files where TeX can see them
144%__mkdir_p %{build_texmf}/tex/latex
145%__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
146
147# desktop & icon
148desktop-file-install --vendor="vine" \
149  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
150%__install -p -D -m644 lib/images/lyx.png \
151  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
152
153# ghost'd files
154touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
155touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
156
157# fonts
158install -m 0755 -d %{buildroot}%{_fontdir}
159mv %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
160rm -rf %{buildroot}%{_datadir}/lyx/fonts
161
162%find_lang %{name}
163
164%check
165# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
166%__make -k check ||:
167
168
169%clean
170%__rm -rf ${RPM_BUILD_ROOT}
171
172
173%post
174touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
175
176%postun
177if [ $1 -eq 0 ] ; then
178    %{exec_texhash} >& /dev/null
179    update-desktop-database -q &> /dev/null
180    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
181    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
182fi
183
184%posttrans
185%{exec_texhash} >& /dev/null
186update-desktop-database -q &> /dev/null
187touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
188gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
189
190%post fonts
191%__font_install_post %{_fontdir}
192
193%postun fonts
194%__font_install_postun %{_fontdir}
195
196
197%files -f %{name}.lang
198%defattr(-,root,root,-)
199%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
200%{_bindir}/*
201%{_datadir}/lyx/
202%{texmf}/tex/latex/lyx/
203%{_datadir}/applications/*.desktop
204%{_datadir}/icons/hicolor/*/*/*
205%{_mandir}/man*/*
206%config(noreplace) %{_datadir}/lyx/lyxrc.dist
207%ghost %{_datadir}/lyx/lyxrc.defaults
208%ghost %{_datadir}/lyx/*.lst
209%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
210
211%files fonts
212%defattr(-,root,root,-)
213%dir %{_fontdir}/
214%{_fontdir}/*.ttf
215
216
217%changelog
218* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
219- update to 2.0.6
220- update Patch50 (lyx-2.0.6-xdg_open.patch)
221
222* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
223- rebuild with hunspell-devel
224
225* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
226- new upstream release
227- added subpackage "lyx-fonts"
228  - added Obsoletes: latex-xft-fonts
229
230* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
231- applied lyx-2.0.1-configurepy-vine.patch
232  - reverted checkLatex to lyx-1.6.5
233
234* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
235- new upstream release
236
237* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
238- new upstream release
239- dropped BuildRequires: aspell-devel
240- added BuildRequires:
241  - libboost-regex
242  - enchant-devel
243  - hunspell-devel
244
245* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
246- new upstream release
247
248* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
249- new upstream release
250- TeX Live 2009
251  - dropped Requires: xdvik, dvipdfmx
252
253* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
254- new upstream release
255- updated Patch0: lyx-1.6.5-xdg_open.patch
256
257* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
258- new upstream release
259  - dropped old source files
260- change License: GPLv2+
261- added lyx.desktop
262- added BuildRequires:
263  - aspell-devel
264  - desktop-file-utils
265  - gettext
266  - python
267  - qt4-devel
268  - zlib-devel
269  - libboost-devel
270  - libboost-filesystem
271  - libboost-signals
272  - libpng-devel
273  - glib2-devel
274- added Requires:
275  - ghostscript
276  - dvipdfmx
277  - xdvik
278  - qt4
279  - xdg-utils
280- optimized some configure options
281
282* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
283- applied new versioning policy, spec in utf-8
284
285* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
286- updated to 1.4.4 with the most recent CJK patch
287- updated Patch1
288
289* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
290- base spec file : Vine Linux BTS #219
291  * Mon Nov  6 2006 M.H
292  - new upstream release
293  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
294
295* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
296- changed Group to Applications/Editors
297
298* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
299- rebuild with qt-3.3.5
300
301* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
302- new upstream version
303- change frontend, xforms -> qt
304- require tetex, qt, latex-xft-fonts
305- change applnk file
306- change Group
307
308* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
309- new upstream version
310- add mime-info
311- minor change in spec file
312
313* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
314- 1.0.3_jp-4
315- added BuildPrereq:
316
317* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
318- 1.0.3_jp-3
319- minor change in spec file
320- build for Vine Linux 2.1
321
322* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
323- change group
324
325* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
326- updated to lyx-1.0.3
327- rebuild for Vine Linux 2.0
328
329* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
330- merged Japanese Documents
331
332* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
333- first build
334
Note: See TracBrowser for help on using the repository browser.