source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define texmf           %{_datadir}/texmf
2%define build_texmf     %{buildroot}%{texmf}
3
4%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
5%define exec_updmap   [ -x %{_bindir}/updmap-sys  ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop 2>/dev/null
6%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
7%define vartexfonts %{_var}/lib/texmf
8
9Summary: A WYSIWYM (What You See Is What You Mean) frontend to LaTeX
10Summary(ja): LaTeX形式でも保存できる簡易ワープロ
11Name: lyx
12Version: 1.6.5
13Release: 1%{?_dist_release}
14License: GPLv2+
15Group: Applications/Editors
16URL: http://www.lyx.org/
17Source: ftp://ftp.lyx.org/pub/lyx/stable/%{name}-%{version}.tar.bz2
18#Source1: http://www.ring.gr.jp/pub/text/CTAN/macros/latex/contrib/koma-script/koma-script.tds.zip
19
20Source10: lyx.desktop
21Source11: lyxrc.dist
22Patch0: lyx-1.6.5-xdg_open.patch
23
24# vine
25Patch10: lyx-1.6.3-customize-vine.patch
26
27# BuildRequires: aiksaurus-devel
28BuildRequires:   aspell-devel
29BuildRequires:   libboost-devel
30BuildRequires:   libboost-filesystem
31BuildRequires:   libboost-signals
32BuildRequires:   desktop-file-utils
33BuildRequires:   gettext
34BuildRequires:   python
35BuildRequires:   xorg-x11-devel
36BuildRequires:   qt4-devel
37BuildRequires:   libpng-devel
38BuildRequires:   glib2-devel
39BuildRequires:   zlib-devel
40
41Requires:        tetex
42Requires(post):  tetex
43Requires:        ghostscript
44Requires:        dvipdfmx
45Requires:        xdvik
46Requires:        python
47Requires:        qt4
48Requires:        latex-xft-fonts
49
50Requires(hint):  xdg-utils
51Requires(hint):  rcs
52
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54
55Vendor:       Project Vine
56Distribution: Vine Linux
57
58
59%description
60LyX is a modern approach to writing documents which breaks with the
61obsolete "typewriter paradigm" of most other document preparation
62systems.
63
64It is designed for people who want professional quality output
65with a minimum of time and effort, without becoming specialists in
66typesetting.
67
68The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
69That is, the author focuses on content, not on the details of formatting.
70This allows for greater productivity, and leaves the final typesetting
71to the backends (like LaTeX) that are specifically designed for the task.
72
73With LyX, the author can concentrate on the contents of his writing,
74and let the computer take care of the rest.
75
76This is LyX built with the Qt frontend.
77
78%description -l ja
79LaTeX形式で出力もできる簡易ワープロです。数式の入力も簡単にできます。
80特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
81してあります。
82
83
84%prep
85%setup -q
86%patch0 -p1 -b .xdg_open
87
88%patch10 -p1 -b .vine
89
90
91%build
92%configure \
93    --enable-build-type=release \
94    --disable-dependency-tracking \
95    --disable-rpath \
96    --disable-debug \
97    --enable-optimization="%{optflags}" \
98    --enable-shared \
99    --disable-static \
100    \
101    --with-frontend=qt4 \
102    --without-aiksaurus \
103    --with-aspell \
104    ;
105#    --without-included-boost \
106%__make %{?_smp_mflags}
107
108# # make sure all .gmo files are regenerated from .po files
109# (cd po; make update-gmo)
110
111
112%install
113%__rm -rf ${RPM_BUILD_ROOT}
114%__make DESTDIR=${RPM_BUILD_ROOT} install
115
116# for pdf: ps2pdf, pdf3: dvipdfmx
117(cd ${RPM_BUILD_ROOT}%{_datadir}/lyx/images
118    ln -sf buffer-update_pdf2.png buffer-update_pdf.png
119    ln -sf buffer-update_pdf2.png buffer-update_pdf3.png
120    ln -sf buffer-view_pdf2.png buffer-view_pdf.png
121    ln -sf buffer-view_pdf2.png buffer-view_pdf3.png
122)
123
124# misc/extras
125%__install -p -m644 -D %{SOURCE11} %{buildroot}%{_datadir}/lyx/lyxrc.dist
126
127# latex
128%__mkdir_p %{build_texmf}/tex/latex
129%__mv -f ${RPM_BUILD_ROOT}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
130
131## it semms the newest Japanese translations already included in the upstream...
132#%__install -m 644 layouts/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/layouts/
133#%__install -m 644 1.3.3/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/doc/
134
135# # it semms the newest Japanese translations already included in the upstream...
136# install -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES/lyx.mo
137
138# desktop & icon
139desktop-file-install --vendor="Vine" \
140  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
141%__install -p -D -m644 lib/images/lyx.png \
142  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
143
144# ghost'd files
145touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
146touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
147touch %{buildroot}%{_datadir}/lyx/doc/LaTeXConfig.lyx
148
149# unpackaged files
150rm -rf %{buildroot}%{_datadir}/lyx/fonts
151
152%find_lang %{name}
153
154
155%clean
156%__rm -rf ${RPM_BUILD_ROOT}
157
158
159%post
160%{exec_texhash} >& /dev/null
161if [ -d %{_datadir}/lyx ]; then
162    cd %{_datadir}/lyx
163    echo -n "  "
164    echo "Configuring LyX for your system..."
165    %__python ./configure.py >& /dev/null || :
166fi
167
168update-desktop-database -q &> /dev/null
169touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
170gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
171
172
173%postun
174if [ $1 -eq 0 ] ; then
175    %{exec_texhash} >& /dev/null
176    update-desktop-database -q &> /dev/null
177    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
178    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
179fi
180
181
182%files -f %{name}.lang
183%defattr(-,root,root,-)
184%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
185%{_bindir}/*
186%{_datadir}/lyx/
187%{texmf}/tex/latex/lyx/
188%{_datadir}/applications/*.desktop
189%{_datadir}/icons/hicolor/*/*/*
190%{_mandir}/man*/*
191%config(noreplace) %{_datadir}/lyx/lyxrc.dist
192%ghost %{_datadir}/lyx/lyxrc.defaults
193%ghost %{_datadir}/lyx/*.lst
194%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
195
196
197%changelog
198* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
199- new upstream release
200- updated Patch0: lyx-1.6.5-xdg_open.patch
201
202* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
203- new upstream release
204  - dropped old source files
205- change License: GPLv2+
206- added lyx.desktop
207- added BuildRequires:
208  - aspell-devel
209  - desktop-file-utils
210  - gettext
211  - python
212  - qt4-devel
213  - zlib-devel
214  - libboost-devel
215  - libboost-filesystem
216  - libboost-signals
217  - libpng-devel
218  - glib2-devel
219- added Requires:
220  - ghostscript
221  - dvipdfmx
222  - xdvik
223  - qt4
224  - xdg-utils
225- optimized some configure options
226
227* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
228- applied new versioning policy, spec in utf-8
229
230* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
231- updated to 1.4.4 with the most recent CJK patch
232- updated Patch1
233
234* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
235- base spec file : Vine Linux BTS #219
236  * Mon Nov  6 2006 M.H
237  - new upstream release
238  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
239
240* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
241- changed Group to Applications/Editors
242
243* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
244- rebuild with qt-3.3.5
245
246* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
247- new upstream version
248- change frontend, xforms -> qt
249- require tetex, qt, latex-xft-fonts
250- change applnk file
251- change Group
252
253* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
254- new upstream version
255- add mime-info
256- minor change in spec file
257
258* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
259- 1.0.3_jp-4
260- added BuildPrereq:
261
262* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
263- 1.0.3_jp-3
264- minor change in spec file
265- build for Vine Linux 2.1
266
267* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
268- change group
269
270* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
271- updated to lyx-1.0.3
272- rebuild for Vine Linux 2.0
273
274* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
275- merged Japanese Documents
276
277* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
278- first build
279
Note: See TracBrowser for help on using the repository browser.