source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 4848

Revision 4848, 7.7 KB checked in by munepi, 13 years ago (diff)

updated lyx-vl.spec

Line 
1%define texmf           %{_datadir}/texmf
2%define build_texmf     %{buildroot}%{texmf}
3
4%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
5
6Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
7Summary(ja): LaTeX 形式で保存できるワードプロセッサ
8Name: lyx
9Version: 2.0.1
10Release: 2%{?_dist_release}
11License: GPLv2+
12Group: Applications/Editors
13URL: http://www.lyx.org/
14Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
15
16Source1: lyxrc.dist
17Source10: lyx.desktop
18
19## upstreamable patches
20# submitted, but upstream rejected it.  we currently agree to disagree.
21Patch50: lyx-2.0.1-xdg_open.patch
22
23## vine
24# reverted checkLatex to lyx-1.6.5
25Patch100: lyx-2.0.1-configurepy-vine.patch
26
27
28# BuildRequires: aiksaurus-devel
29# BuildRequires:   aspell-devel
30BuildRequires:   enchant-devel
31BuildRequires:   hunspell-devel
32BuildRequires:   libboost-devel
33BuildRequires:   libboost-filesystem
34BuildRequires:   libboost-signals
35BuildRequires:   libboost-regex
36BuildRequires:   desktop-file-utils
37BuildRequires:   gettext
38BuildRequires:   python
39BuildRequires:   xorg-x11-devel
40BuildRequires:   qt4-devel
41BuildRequires:   libpng-devel
42BuildRequires:   glib2-devel
43BuildRequires:   zlib-devel
44
45Requires(post):  texlive-common
46Requires(postun): texlive-common
47Requires:        ghostscript
48Requires:        python
49Requires:        qt4
50Requires:        latex-xft-fonts
51
52Requires:        xdg-utils
53Requires:        rcs
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57Vendor:       Project Vine
58Distribution: Vine Linux
59
60
61%description
62LyX is a modern approach to writing documents which breaks with the
63obsolete "typewriter paradigm" of most other document preparation
64systems.
65
66It is designed for people who want professional quality output
67with a minimum of time and effort, without becoming specialists in
68typesetting.
69
70The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
71That is, the author focuses on content, not on the details of formatting.
72This allows for greater productivity, and leaves the final typesetting
73to the backends (like LaTeX) that are specifically designed for the task.
74
75With LyX, the author can concentrate on the contents of his writing,
76and let the computer take care of the rest.
77
78This is LyX built with the Qt frontend.
79
80%description -l ja
81LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
82特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
83してあります。
84
85
86%prep
87%setup -q
88
89%patch50 -p1 -b .xdg_open
90%patch100 -p1 -b .vine
91
92#./autogen.sh
93
94
95%build
96%configure \
97    --disable-dependency-tracking \
98    --disable-rpath \
99    --enable-build-type=release \
100    --disable-debug \
101    --enable-optimization="%{optflags}" \
102    --without-included-boost \
103    --enable-shared \
104    --disable-static \
105    \
106    --with-frontend=qt4 \
107    --without-aiksaurus \
108    --with-enchant \
109    --with-hunspell \
110    ;
111%__make %{?_smp_mflags}
112
113# # make sure all .gmo files are regenerated from .po files
114# (cd po; make update-gmo)
115
116
117%install
118%__rm -rf ${RPM_BUILD_ROOT}
119%__make DESTDIR=${RPM_BUILD_ROOT} install
120
121# misc/extras
122%__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
123
124# Set up the lyx-specific class files where TeX can see them
125%__mkdir_p %{build_texmf}/tex/latex
126%__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
127
128# desktop & icon
129desktop-file-install --vendor="vine" \
130  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
131%__install -p -D -m644 lib/images/lyx.png \
132  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
133
134# ghost'd files
135touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
136touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
137
138# unpackaged files
139%__rm -rf %{buildroot}%{_datadir}/lyx/fonts
140
141%find_lang %{name}
142
143%check
144# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
145%__make -k check ||:
146
147
148%clean
149%__rm -rf ${RPM_BUILD_ROOT}
150
151
152%post
153touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
154
155%postun
156if [ $1 -eq 0 ] ; then
157    %{exec_texhash} >& /dev/null
158    update-desktop-database -q &> /dev/null
159    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
160    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
161fi
162
163%posttrans
164%{exec_texhash} >& /dev/null
165update-desktop-database -q &> /dev/null
166touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
167gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
168
169
170%files -f %{name}.lang
171%defattr(-,root,root,-)
172%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
173%{_bindir}/*
174%{_datadir}/lyx/
175%{texmf}/tex/latex/lyx/
176%{_datadir}/applications/*.desktop
177%{_datadir}/icons/hicolor/*/*/*
178%{_mandir}/man*/*
179%config(noreplace) %{_datadir}/lyx/lyxrc.dist
180%ghost %{_datadir}/lyx/lyxrc.defaults
181%ghost %{_datadir}/lyx/*.lst
182%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
183
184
185%changelog
186* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
187- applied lyx-2.0.1-configurepy-vine.patch
188  - reverted checkLatex to lyx-1.6.5
189
190* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
191- new upstream release
192
193* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
194- new upstream release
195- dropped BuildRequires: aspell-devel
196- added BuildRequires:
197  - libboost-regex
198  - enchant-devel
199  - hunspell-devel
200
201* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
202- new upstream release
203
204* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
205- new upstream release
206- TeX Live 2009
207  - dropped Requires: xdvik, dvipdfmx
208
209* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
210- new upstream release
211- updated Patch0: lyx-1.6.5-xdg_open.patch
212
213* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
214- new upstream release
215  - dropped old source files
216- change License: GPLv2+
217- added lyx.desktop
218- added BuildRequires:
219  - aspell-devel
220  - desktop-file-utils
221  - gettext
222  - python
223  - qt4-devel
224  - zlib-devel
225  - libboost-devel
226  - libboost-filesystem
227  - libboost-signals
228  - libpng-devel
229  - glib2-devel
230- added Requires:
231  - ghostscript
232  - dvipdfmx
233  - xdvik
234  - qt4
235  - xdg-utils
236- optimized some configure options
237
238* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
239- applied new versioning policy, spec in utf-8
240
241* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
242- updated to 1.4.4 with the most recent CJK patch
243- updated Patch1
244
245* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
246- base spec file : Vine Linux BTS #219
247  * Mon Nov  6 2006 M.H
248  - new upstream release
249  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
250
251* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
252- changed Group to Applications/Editors
253
254* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
255- rebuild with qt-3.3.5
256
257* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
258- new upstream version
259- change frontend, xforms -> qt
260- require tetex, qt, latex-xft-fonts
261- change applnk file
262- change Group
263
264* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
265- new upstream version
266- add mime-info
267- minor change in spec file
268
269* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
270- 1.0.3_jp-4
271- added BuildPrereq:
272
273* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
274- 1.0.3_jp-3
275- minor change in spec file
276- build for Vine Linux 2.1
277
278* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
279- change group
280
281* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
282- updated to lyx-1.0.3
283- rebuild for Vine Linux 2.0
284
285* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
286- merged Japanese Documents
287
288* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
289- first build
290
Note: See TracBrowser for help on using the repository browser.