source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 2373

Revision 2373, 8.3 KB checked in by munepi, 13 years ago (diff)

updated lyx-vl.spec

Line 
1%define texmf           %{_datadir}/texmf
2%define build_texmf     %{buildroot}%{texmf}
3
4%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
5%define exec_updmap   [ -x %{_bindir}/updmap-sys  ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop 2>/dev/null
6%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
7%define vartexfonts %{_var}/lib/texmf
8
9Summary: A WYSIWYM (What You See Is What You Mean) frontend to LaTeX
10Summary(ja): LaTeX形式でも保存できる簡易ワープロ
11Name: lyx
12Version: 1.6.8
13Release: 1%{?_dist_release}
14License: GPLv2+
15Group: Applications/Editors
16URL: http://www.lyx.org/
17Source: ftp://ftp.lyx.org/pub/lyx/stable/%{name}-%{version}.tar.bz2
18#Source1: http://www.ring.gr.jp/pub/text/CTAN/macros/latex/contrib/koma-script/koma-script.tds.zip
19
20Source10: lyx.desktop
21Source11: lyxrc.dist
22Patch0: lyx-1.6.5-xdg_open.patch
23
24# vine
25Patch10: lyx-1.6.3-customize-vine.patch
26
27# BuildRequires: aiksaurus-devel
28BuildRequires:   aspell-devel
29BuildRequires:   libboost-devel
30BuildRequires:   libboost-filesystem
31BuildRequires:   libboost-signals
32BuildRequires:   desktop-file-utils
33BuildRequires:   gettext
34BuildRequires:   python
35BuildRequires:   xorg-x11-devel
36BuildRequires:   qt4-devel
37BuildRequires:   libpng-devel
38BuildRequires:   glib2-devel
39BuildRequires:   zlib-devel
40
41%if %{?_dist_release} == "vl6"
42Requires:        texlive
43Requires(post):  texlive
44%endif
45%if %{?_dist_release} == "vl5"
46Requires:        tetex
47Requires(post):  tetex
48Requires:        dvipdfmx
49Requires:        xdvik
50%endif
51Requires:        ghostscript
52Requires:        python
53Requires:        qt4
54Requires:        latex-xft-fonts
55
56Requires(hint):  xdg-utils
57Requires(hint):  rcs
58
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61Vendor:       Project Vine
62Distribution: Vine Linux
63
64
65%description
66LyX is a modern approach to writing documents which breaks with the
67obsolete "typewriter paradigm" of most other document preparation
68systems.
69
70It is designed for people who want professional quality output
71with a minimum of time and effort, without becoming specialists in
72typesetting.
73
74The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
75That is, the author focuses on content, not on the details of formatting.
76This allows for greater productivity, and leaves the final typesetting
77to the backends (like LaTeX) that are specifically designed for the task.
78
79With LyX, the author can concentrate on the contents of his writing,
80and let the computer take care of the rest.
81
82This is LyX built with the Qt frontend.
83
84%description -l ja
85LaTeX形式で出力もできる簡易ワープロです。数式の入力も簡単にできます。
86特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
87してあります。
88
89
90%prep
91%setup -q
92%patch0 -p1 -b .xdg_open
93
94%patch10 -p1 -b .vine
95
96
97%build
98unset QTDIR || : ; . /etc/profile.d/qt4.sh
99export QT4DIR=$(echo $QTDIR | %__sed -e "s,/lib$,,")
100
101%configure \
102    --enable-build-type=release \
103    --disable-dependency-tracking \
104    --disable-rpath \
105    --disable-debug \
106    --enable-optimization="%{optflags}" \
107    --enable-shared \
108    --disable-static \
109    \
110    --with-qt4-dir=${QT4DIR} \
111    --with-frontend=qt4 \
112    --without-aiksaurus \
113    --with-aspell \
114    ;
115#    --without-included-boost \
116%__make %{?_smp_mflags}
117
118# # make sure all .gmo files are regenerated from .po files
119# (cd po; make update-gmo)
120
121
122%install
123%__rm -rf ${RPM_BUILD_ROOT}
124%__make DESTDIR=${RPM_BUILD_ROOT} install
125
126# for pdf: ps2pdf, pdf3: dvipdfmx
127(cd ${RPM_BUILD_ROOT}%{_datadir}/lyx/images
128    ln -sf buffer-update_pdf2.png buffer-update_pdf.png
129    ln -sf buffer-update_pdf2.png buffer-update_pdf3.png
130    ln -sf buffer-view_pdf2.png buffer-view_pdf.png
131    ln -sf buffer-view_pdf2.png buffer-view_pdf3.png
132)
133
134# misc/extras
135%__install -p -m644 -D %{SOURCE11} %{buildroot}%{_datadir}/lyx/lyxrc.dist
136
137# latex
138%__mkdir_p %{build_texmf}/tex/latex
139%__mv -f ${RPM_BUILD_ROOT}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
140
141## it semms the newest Japanese translations already included in the upstream...
142#%__install -m 644 layouts/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/layouts/
143#%__install -m 644 1.3.3/* ${RPM_BUILD_ROOT}%{_datadir}/lyx/doc/
144
145# # it semms the newest Japanese translations already included in the upstream...
146# install -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES/lyx.mo
147
148# desktop & icon
149desktop-file-install --vendor="Vine" \
150  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
151%__install -p -D -m644 lib/images/lyx.png \
152  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
153
154# ghost'd files
155touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
156touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
157touch %{buildroot}%{_datadir}/lyx/doc/LaTeXConfig.lyx
158
159# unpackaged files
160rm -rf %{buildroot}%{_datadir}/lyx/fonts
161
162%find_lang %{name}
163
164
165%clean
166%__rm -rf ${RPM_BUILD_ROOT}
167
168
169%post
170%{exec_texhash} >& /dev/null
171if [ -d %{_datadir}/lyx ]; then
172    cd %{_datadir}/lyx
173    echo -n "  "
174    echo "Configuring LyX for your system..."
175    %__python ./configure.py >& /dev/null || :
176fi
177
178update-desktop-database -q &> /dev/null
179touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
180gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
181
182
183%postun
184if [ $1 -eq 0 ] ; then
185    %{exec_texhash} >& /dev/null
186    update-desktop-database -q &> /dev/null
187    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
188    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
189fi
190
191
192%files -f %{name}.lang
193%defattr(-,root,root,-)
194%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
195%{_bindir}/*
196%{_datadir}/lyx/
197%{texmf}/tex/latex/lyx/
198%{_datadir}/applications/*.desktop
199%{_datadir}/icons/hicolor/*/*/*
200%{_mandir}/man*/*
201%config(noreplace) %{_datadir}/lyx/lyxrc.dist
202%ghost %{_datadir}/lyx/lyxrc.defaults
203%ghost %{_datadir}/lyx/*.lst
204%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
205
206
207%changelog
208* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
209- new upstream release
210
211* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
212- new upstream release
213- TeX Live 2009
214  - dropped Requires: xdvik, dvipdfmx
215
216* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
217- new upstream release
218- updated Patch0: lyx-1.6.5-xdg_open.patch
219
220* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
221- new upstream release
222  - dropped old source files
223- change License: GPLv2+
224- added lyx.desktop
225- added BuildRequires:
226  - aspell-devel
227  - desktop-file-utils
228  - gettext
229  - python
230  - qt4-devel
231  - zlib-devel
232  - libboost-devel
233  - libboost-filesystem
234  - libboost-signals
235  - libpng-devel
236  - glib2-devel
237- added Requires:
238  - ghostscript
239  - dvipdfmx
240  - xdvik
241  - qt4
242  - xdg-utils
243- optimized some configure options
244
245* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
246- applied new versioning policy, spec in utf-8
247
248* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
249- updated to 1.4.4 with the most recent CJK patch
250- updated Patch1
251
252* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
253- base spec file : Vine Linux BTS #219
254  * Mon Nov  6 2006 M.H
255  - new upstream release
256  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
257
258* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
259- changed Group to Applications/Editors
260
261* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
262- rebuild with qt-3.3.5
263
264* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
265- new upstream version
266- change frontend, xforms -> qt
267- require tetex, qt, latex-xft-fonts
268- change applnk file
269- change Group
270
271* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
272- new upstream version
273- add mime-info
274- minor change in spec file
275
276* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
277- 1.0.3_jp-4
278- added BuildPrereq:
279
280* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
281- 1.0.3_jp-3
282- minor change in spec file
283- build for Vine Linux 2.1
284
285* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
286- change group
287
288* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
289- updated to lyx-1.0.3
290- rebuild for Vine Linux 2.0
291
292* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
293- merged Japanese Documents
294
295* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
296- first build
297
Note: See TracBrowser for help on using the repository browser.